aboutsummaryrefslogtreecommitdiffstats
path: root/main/haproxy
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-28 07:01:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 08:36:00 +0000
commitfa8515b5bf2ac2247a2062d56f25106f56b1ee1c (patch)
tree8ebb1066c90bbad862e568618f9f2726ea0edee3 /main/haproxy
parent2aca8d20a8e97a69f1883a09935cfb849891934e (diff)
downloadaports-fa8515b5bf2ac2247a2062d56f25106f56b1ee1c.tar.bz2
aports-fa8515b5bf2ac2247a2062d56f25106f56b1ee1c.tar.xz
main/haproxy: fix build on mips{el} (-latomic)
Note mipsel* is intentional to cover out-of-tree mipseln8hf.
Diffstat (limited to 'main/haproxy')
-rw-r--r--main/haproxy/APKBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/main/haproxy/APKBUILD b/main/haproxy/APKBUILD
index 84644fc13b..e83bb1259c 100644
--- a/main/haproxy/APKBUILD
+++ b/main/haproxy/APKBUILD
@@ -22,7 +22,9 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+ case "$CARCH" in mips|mipsel*) _carchflags="ADDLIB=-latomic";; esac
make \
+ $_carchflags \
TARGET=linux2628 \
USE_PCRE=1 \
USE_OPENSSL=1 \