aboutsummaryrefslogtreecommitdiffstats
path: root/main/haveged
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-04-08 22:43:47 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 08:48:18 +0000
commit65662ceedf9c895da8e96d9cdba7a68f9cfe8740 (patch)
treedb5414aff54ab9049501f66919ac66bfe8421b02 /main/haveged
parentdb18b4c886bd03a942e1c7bdbcf4e2e5d30fed7f (diff)
downloadaports-65662ceedf9c895da8e96d9cdba7a68f9cfe8740.tar.bz2
aports-65662ceedf9c895da8e96d9cdba7a68f9cfe8740.tar.xz
main/haveged: more samples in check()
Decrease the probability of a failing Chi-Square test by doubling the sample size used. While at it add openrc subpkg
Diffstat (limited to 'main/haveged')
-rw-r--r--main/haveged/APKBUILD13
-rw-r--r--main/haveged/double-the-sample-size-used-in-the-entest.patch24
2 files changed, 34 insertions, 3 deletions
diff --git a/main/haveged/APKBUILD b/main/haveged/APKBUILD
index beaccff30b..fa1d071e0e 100644
--- a/main/haveged/APKBUILD
+++ b/main/haveged/APKBUILD
@@ -3,19 +3,25 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=haveged
pkgver=1.9.4
-pkgrel=2
+pkgrel=3
pkgdesc="Entropy harvesting daemon using CPU timings"
url="http://www.issihosts.com/haveged/"
arch="all"
license="GPL-3.0-or-later"
-subpackages="$pkgname-doc"
-makedepends="linux-headers"
+subpackages="$pkgname-doc $pkgname-openrc"
+makedepends="autoconf automake libtool linux-headers"
source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/$pkgver.tar.gz
fix-cpu-cache-size-detection.patch
+ double-the-sample-size-used-in-the-entest.patch
haveged.initd
haveged.confd"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
build() {
cd "$builddir"
@@ -47,5 +53,6 @@ package() {
sha512sums="20017c7637779c0cfa414233bb67efb2976f92c08e4eb1b7ea41ccd483dad755629d8e05fb8560a2db811fc2ded7d05fa081ab10c59341cb4c206595a964641d haveged-1.9.4.tar.gz
6279296b057f19daf25020ac14997268230af4b11510d6e5c4a86989c119d6b081d2501069af198772302d5cce1464514c749033a4928fb95671268825a84ba8 fix-cpu-cache-size-detection.patch
+e977a6487df29a0e7de07ef3ef6546776ee9671cc8ac02868800351c6461be4d0d2e05cf40c5bc54742c00d5fe1878027959ab598d96be4f81a9eb4969fce08d double-the-sample-size-used-in-the-entest.patch
b721ad2d14a358b663a7a161c94963a152c99c69434eeb6fd012e6d6af18b3b88372da9603e2485675ce5c092424795e03953a3a0033fa6501252c25a86ea491 haveged.initd
57201472fc659aaab919562a00d474d3823d5becea62e8b13ef93eda05e1fd667721c968f224fcae871d13cfcd16d1924403d9181e0899fa214fa00bf4fefc75 haveged.confd"
diff --git a/main/haveged/double-the-sample-size-used-in-the-entest.patch b/main/haveged/double-the-sample-size-used-in-the-entest.patch
new file mode 100644
index 0000000000..673566f94c
--- /dev/null
+++ b/main/haveged/double-the-sample-size-used-in-the-entest.patch
@@ -0,0 +1,24 @@
+From 55eb83a7d6c29667a4035df487b5417529fc8518 Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Mon, 8 Apr 2019 22:42:05 +0200
+Subject: [PATCH] double the sample size used in the entest
+
+---
+ ent/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ent/Makefile.am b/ent/Makefile.am
+index 265504c..4782377 100644
+--- a/ent/Makefile.am
++++ b/ent/Makefile.am
+@@ -17,6 +17,6 @@ MAINTAINERCLEANFILES = Makefile.in
+ if ENABLE_ENT_TEST
+ check-local:
+ ./entest -t ${srcdir}/entitle.gif
+- ../src/haveged -n 16384k -v 1 $*
++ ../src/haveged -n 32768k -v 1 $*
+ ./entest -vf sample
+ endif
+--
+2.21.0
+