aboutsummaryrefslogtreecommitdiffstats
path: root/main/haveged
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 11:23:36 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-18 10:21:25 +0000
commitc1b6b2e5ce2ffd4e40c3ae4cb54c00e9b6ebb1fa (patch)
treebd4e97233520021c4ef3d1f3a9b98aacf3b7027c /main/haveged
parent76ebf9540158e91c3df6c9e2219b3d2deea4da21 (diff)
downloadaports-c1b6b2e5ce2ffd4e40c3ae4cb54c00e9b6ebb1fa.tar.bz2
aports-c1b6b2e5ce2ffd4e40c3ae4cb54c00e9b6ebb1fa.tar.xz
main/haveged: upgrade to 1.9.6
Diffstat (limited to 'main/haveged')
-rw-r--r--main/haveged/APKBUILD16
-rw-r--r--main/haveged/fix-cpu-cache-size-detection.patch15
-rw-r--r--main/haveged/haveged.initd10
3 files changed, 13 insertions, 28 deletions
diff --git a/main/haveged/APKBUILD b/main/haveged/APKBUILD
index 920c0f09f9..cd88274908 100644
--- a/main/haveged/APKBUILD
+++ b/main/haveged/APKBUILD
@@ -2,20 +2,18 @@
# Contributor: Danilo Godec <danilo.godec@agenda.si>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=haveged
-pkgver=1.9.4
-pkgrel=4
+pkgver=1.9.6
+pkgrel=0
pkgdesc="Entropy harvesting daemon using CPU timings"
url="http://www.issihosts.com/haveged/"
arch="all"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc $pkgname-openrc"
makedepends="autoconf automake libtool linux-headers"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/$pkgver.tar.gz
- fix-cpu-cache-size-detection.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/jirka-h/haveged/archive/v$pkgver.tar.gz
double-the-sample-size-used-in-the-entest.patch
haveged.initd
haveged.confd"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
@@ -29,7 +27,8 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ --disable-static
make
}
@@ -51,8 +50,7 @@ package() {
"$pkgdir"/etc/conf.d/haveged
}
-sha512sums="20017c7637779c0cfa414233bb67efb2976f92c08e4eb1b7ea41ccd483dad755629d8e05fb8560a2db811fc2ded7d05fa081ab10c59341cb4c206595a964641d haveged-1.9.4.tar.gz
-6279296b057f19daf25020ac14997268230af4b11510d6e5c4a86989c119d6b081d2501069af198772302d5cce1464514c749033a4928fb95671268825a84ba8 fix-cpu-cache-size-detection.patch
+sha512sums="cae10fcadf13d736111f438c9ed3906544afd9194da4b13236c6e167e1e85b42a89110dec15b94485e0f2f46e6332391a54c82f8052b03253651a121100a2c30 haveged-1.9.6.tar.gz
e977a6487df29a0e7de07ef3ef6546776ee9671cc8ac02868800351c6461be4d0d2e05cf40c5bc54742c00d5fe1878027959ab598d96be4f81a9eb4969fce08d double-the-sample-size-used-in-the-entest.patch
-ede46769216bfbd2847b9405121d3baa78d50c263fef1762465491af708361702d2948ab58b6f7f677a95d7b329dd4630caa422339612505fee8a158bae4620b haveged.initd
+9d39a7f94987b5734ba414edf23ec986f344e00748d20dd5b37b64403cebd4fad68469df52ce1d115d0ee0c71497f1ac21144d0370345b5ef57e306d7d376f89 haveged.initd
57201472fc659aaab919562a00d474d3823d5becea62e8b13ef93eda05e1fd667721c968f224fcae871d13cfcd16d1924403d9181e0899fa214fa00bf4fefc75 haveged.confd"
diff --git a/main/haveged/fix-cpu-cache-size-detection.patch b/main/haveged/fix-cpu-cache-size-detection.patch
deleted file mode 100644
index 07da2b46d9..0000000000
--- a/main/haveged/fix-cpu-cache-size-detection.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Some ARM cpus does not report the cache size or say it is -1
-
-diff --git a/src/havegetune.c b/src/havegetune.c
-index f1a99f2..de39c53 100644
---- a/src/havegetune.c
-+++ b/src/havegetune.c
-@@ -795,6 +795,8 @@ static int vfs_configInfoCache(
- ctype = vfs_configFile(pAnchor, path, vfs_configType);
- strcpy(path+plen, "size");
- size = vfs_configFile(pAnchor, path, vfs_configInt);
-+ if (size == -1)
-+ size = ctype == 'I' ? GENERIC_ICACHE : GENERIC_DCACHE;
- cfg_cacheAdd(pAnchor, SRC_VFS_INDEX, pArgs[1], level, ctype, size);
- }
- }
diff --git a/main/haveged/haveged.initd b/main/haveged/haveged.initd
index 015fc59561..da1d6245f2 100644
--- a/main/haveged/haveged.initd
+++ b/main/haveged/haveged.initd
@@ -1,10 +1,12 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
-command="/usr/sbin/haveged"
-command_args="$HAVEGED_OPTS"
-command_background="yes"
+name="RNG Daemon"
+description="haveged Random Number Generator"
-pidfile="/run/$RC_SVCNAME.pid"
+command=/usr/sbin/haveged
+command_args="$HAVEGED_OPTS"
+command_args_foreground="--Foreground"
depend() {
need localmount