aboutsummaryrefslogtreecommitdiffstats
path: root/main/hexchat/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-03-11 20:17:53 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 21:49:29 +0100
commit6434ec0ad1003158a1cc6f4725151f93ae9258e4 (patch)
treef2b74b01f9713774f2ce0d8c98c75afa064a5773 /main/hexchat/APKBUILD
parentbb93e8ea567f2020fad2812580d8bc716f9cd8ee (diff)
downloadaports-6434ec0ad1003158a1cc6f4725151f93ae9258e4.tar.bz2
aports-6434ec0ad1003158a1cc6f4725151f93ae9258e4.tar.xz
main/hexchat: upgrade to 2.14, modernize
Diffstat (limited to 'main/hexchat/APKBUILD')
-rw-r--r--main/hexchat/APKBUILD58
1 files changed, 20 insertions, 38 deletions
diff --git a/main/hexchat/APKBUILD b/main/hexchat/APKBUILD
index a5b25be245..3feec09d10 100644
--- a/main/hexchat/APKBUILD
+++ b/main/hexchat/APKBUILD
@@ -1,54 +1,38 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hexchat
-pkgver=2.12.4
-pkgrel=1
-pkgdesc="A popular and easy to use graphical IRC (chat) client"
+pkgver=2.14.0
+pkgrel=0
+pkgdesc="Graphical IRC client based on XChat"
url="https://hexchat.github.io"
arch="all"
license="GPL-2.0-or-later"
depends=""
-makedepends="gtk+2.0-dev libressl-dev dbus-glib-dev perl-dev
- libsexy-dev python2-dev libnotify-dev libproxy-dev lua5.3-dev
- bash libtool autoconf automake"
+makedepends="dbus-glib-dev gtk+2.0-dev libnotify-dev libproxy-dev
+ libressl-dev libsexy-dev lua5.3-dev meson python3-dev"
install=""
subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
-source="https://dl.hexchat.net/hexchat/hexchat-$pkgver-repack.tar.xz
- libressl.patch
- pixdata.patch
- "
-
-builddir="$srcdir"/hexchat-$pkgver
-prepare() {
- local i
- cd "$builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- autoreconf -vif || return 1
-}
+source="https://dl.hexchat.net/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- LUA=lua5.3 \
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --enable-openssl \
- --enable-dbus \
- --disable-textfe \
- --disable-perl \
- --enable-python \
- --enable-lua \
- || return 1
- make || return 1
+ meson --prefix=/usr \
+ -Dwith-perl=false \
+ -Dwith-lua=lua5.3 \
+ -Dwith-sysinfo=false \
+ -Dwith-libcanberra=false \
+ build_dir/
+ ninja -C build_dir/
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ DESTDIR="$pkgdir" ninja -C build_dir/ install
+
# not worth a -dev pkg
- rm -r "$pkgdir"/usr/include
+ rm -fr "$pkgdir"/usr/include
+ # remove useless files
+ rm -fr "$pkgdir"/usr/lib/pkgconfig
}
_python() {
@@ -58,6 +42,4 @@ _python() {
"$subpkgdir"/usr/lib/hexchat/plugins
}
-sha512sums="30d42f5b488abec3fa457254720a39f62619338a5a2c3fe2e5a255aafe1b19817451b01cd260eab90868df1ebf9f663c60b78b6db974ca3c777272327c0b8a25 hexchat-2.12.4-repack.tar.xz
-1d7cd46a8a22439e8e37a6d425288e9f43fddc0e8bc2db9dcf94254955f60b6da580d0b3db2c26e8d4758ca8b4381629ed7ae42fee72371d7b4898bd338bf81f libressl.patch
-5cb7ac95e6d53d677d7ec82485636f2c36003ba7fa0c4d4d353095dc6207c51abdc7a2230d43616895fef8ce2c7c2096bec21ac47117d0adbc7416ff3d4ba2c3 pixdata.patch"
+sha512sums="b23f227065b7911123e335d19cb76bd5f0bfa9c891eb3f68030677a7346a3bf410ab1679b9c349cf4a2819244fc00766552b1e677f33a45db95d7b928daf49ec hexchat-2.14.0.tar.xz"