aboutsummaryrefslogtreecommitdiffstats
path: root/main/hunspell
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 12:55:11 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 12:55:11 +0000
commit580b9217f4197754a82eac8d0d2ce304943e23cd (patch)
tree1b639ef03a4d483fc980a80d2d0a2e35304ef592 /main/hunspell
parent02e3b0af91057fe8113a3a4727f08a14fb075b55 (diff)
downloadaports-580b9217f4197754a82eac8d0d2ce304943e23cd.tar.bz2
aports-580b9217f4197754a82eac8d0d2ce304943e23cd.tar.xz
main/hunspell: fix musl build
Diffstat (limited to 'main/hunspell')
-rw-r--r--main/hunspell/APKBUILD16
-rw-r--r--main/hunspell/fix-includes.patch20
2 files changed, 34 insertions, 2 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index 26aa2c844c..ead098f1ec 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -9,13 +9,20 @@ license="GPL LGPL MPL"
subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends="gettext-dev"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-includes.patch
+ "
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -36,4 +43,9 @@ package() {
rm "$pkgdir"/usr/lib/*.la || return 1
}
-md5sums="3121aaf3e13e5d88dfff13fb4a5f1ab8 hunspell-1.3.2.tar.gz"
+md5sums="3121aaf3e13e5d88dfff13fb4a5f1ab8 hunspell-1.3.2.tar.gz
+17ccb7870adf6c15d44db451a05ed139 fix-includes.patch"
+sha256sums="b4edd4a4ee944cb9f485b35473e46b729ed768e9d24da8e78e4c4c6ca56addbd hunspell-1.3.2.tar.gz
+b2beb505d7bf92218ad8bc9e3da772d4fe69129aaa2f9974bec8802f8a0b2644 fix-includes.patch"
+sha512sums="fdc165af6fc7d66b858184e34851fb6d8022736af4133fe51535afcadd9c7fdb824c05c3d33b948fafcea165ccc23f5918adb7d81e5eeb5525c05abda0cbd43c hunspell-1.3.2.tar.gz
+fc80b90bdb001fc0771a74b3464b429057446b4314bcd8d9957ba00ea9410a77331e38c8225e91dfa2b4984281b701ea86b2bcd8dcd8266ea59f4f3b9cb74546 fix-includes.patch"
diff --git a/main/hunspell/fix-includes.patch b/main/hunspell/fix-includes.patch
new file mode 100644
index 0000000000..aeb16ac496
--- /dev/null
+++ b/main/hunspell/fix-includes.patch
@@ -0,0 +1,20 @@
+--- hunspell-1.3.2.orig/src/tools/munch.c
++++ hunspell-1.3.2/src/tools/munch.c
+@@ -9,7 +9,6 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #ifdef __linux__
+-#include <error.h>
+ #include <errno.h>
+ #include <sys/mman.h>
+ #endif
+--- hunspell-1.3.2.orig/src/tools/unmunch.c
++++ hunspell-1.3.2/src/tools/unmunch.c
+@@ -11,7 +11,6 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #ifdef __linux__
+-#include <error.h>
+ #include <errno.h>
+ #include <sys/mman.h>
+ #endif