aboutsummaryrefslogtreecommitdiffstats
path: root/main/iceauth/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-03 17:28:46 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-03 17:28:46 +0000
commit47b232bff87befeca52cfba70dcfb7b45e41350c (patch)
tree94dc97312604358ec7b18815209cb390aa0b0e99 /main/iceauth/APKBUILD
parent9ad3b6580b4ec80041cd1ec44a2f84ce2ba46c7c (diff)
downloadaports-47b232bff87befeca52cfba70dcfb7b45e41350c.tar.bz2
aports-47b232bff87befeca52cfba70dcfb7b45e41350c.tar.xz
main/iceauth: upgrade to 1.0.7, modernize APKBUILD
Diffstat (limited to 'main/iceauth/APKBUILD')
-rw-r--r--main/iceauth/APKBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/main/iceauth/APKBUILD b/main/iceauth/APKBUILD
index cab1b39a66..692ff50c6e 100644
--- a/main/iceauth/APKBUILD
+++ b/main/iceauth/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iceauth
-pkgver=1.0.6
+pkgver=1.0.7
pkgrel=0
pkgdesc="X.Org ICE authority file utility"
url="http://xorg.freedesktop.org/"
@@ -11,27 +11,26 @@ depends=""
makedepends="libice-dev"
source="http://xorg.freedesktop.org/releases/individual/app/iceauth-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$_builddir"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ make check
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- || return 1
- make || return 1
+ --mandir=/usr/share/man
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="2527344acc60741a709f4858564c5ae6 iceauth-1.0.6.tar.bz2"
-sha256sums="bd990837353b439e6f45d478a87b8dbfa3f67d72d903e7a9ed4eb8de52f2e2f4 iceauth-1.0.6.tar.bz2"
-sha512sums="45a89d9742570f837225313032a63d66e658c379e7f6b776836e5aeed17443b26faa48ff23645517bf32353fb346de13b62c61d43f1fb1b044686d9fd4c4578d iceauth-1.0.6.tar.bz2"
+sha512sums="4fe08b3137904c99219456716879cbdf5b49ca9bf390011ffb44b1e896f9a6e008b5f761346a533e682f5cfbf18d18a859c74ad4268ec8d40002ffb79c33bcd7 iceauth-1.0.7.tar.bz2"