aboutsummaryrefslogtreecommitdiffstats
path: root/main/iftop/APKBUILD
diff options
context:
space:
mode:
authorTed Trask <ttrask01@yahoo.com>2009-11-05 21:10:53 +0000
committerTed Trask <ttrask01@yahoo.com>2009-11-05 21:10:53 +0000
commit93d66cee3bb101d76748ca7d814204cbfb1d2284 (patch)
tree07caa3644848b8d6da8035d6353d17eae82f0c4e /main/iftop/APKBUILD
parent8b6d2d806f1767023331ed07d4a2fff86cf3c666 (diff)
parent783a255238a7ad893471d9cdf0dfac5952bb8a95 (diff)
downloadaports-93d66cee3bb101d76748ca7d814204cbfb1d2284.tar.bz2
aports-93d66cee3bb101d76748ca7d814204cbfb1d2284.tar.xz
Merge branch 'master' of git://dev.alpinelinux.org/aports
Diffstat (limited to 'main/iftop/APKBUILD')
-rw-r--r--main/iftop/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/iftop/APKBUILD b/main/iftop/APKBUILD
new file mode 100644
index 0000000000..db210d4933
--- /dev/null
+++ b/main/iftop/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iftop
+pkgver=0.17
+pkgrel=0
+pkgdesc="iftop does for network usage what top(1) does for CPU usage"
+url="http://www.ex-parrot.com/~pdw/iftop/"
+license="GPL"
+depends=
+makedepends="libpcap-dev>=1 ncurses-dev"
+subpackages="$pkgname-doc"
+source="http://www.ex-parrot.com/~pdw/$pkgname/download/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+md5sums="062bc8fb3856580319857326e0b8752d iftop-0.17.tar.gz"