aboutsummaryrefslogtreecommitdiffstats
path: root/main/indent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/indent
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
downloadaports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.bz2
aports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.xz
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/indent')
-rw-r--r--main/indent/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/indent/APKBUILD b/main/indent/APKBUILD
index 65c247549d..b68b71f259 100644
--- a/main/indent/APKBUILD
+++ b/main/indent/APKBUILD
@@ -17,6 +17,7 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ update_config_sub || return 1
# apply patches here
}
@@ -37,7 +38,10 @@ build() {
package() {
cd "$_builddir"
- make SUBDIRS="intl po src man" DESTDIR="$pkgdir" install
+ make SUBDIRS="intl po src man" DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null
+ return 0
}
md5sums="98beafca62472805a3739d3867d5d70f indent-2.2.11.tar.gz"