aboutsummaryrefslogtreecommitdiffstats
path: root/main/ipsec-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-03-07 10:47:35 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-03-07 10:47:35 +0200
commit4b3e3f7ab3af18ea69b20f4f3b99e09d32b2989d (patch)
tree2d4d59fbd5e700405b01a00b50c9f506c24e53c9 /main/ipsec-tools
parentcf69eaf36ac0a0befeca9bd6747dfe8ba2cc0aa9 (diff)
downloadaports-4b3e3f7ab3af18ea69b20f4f3b99e09d32b2989d.tar.bz2
aports-4b3e3f7ab3af18ea69b20f4f3b99e09d32b2989d.tar.xz
main/ipsec-tools: upgrade to 0.8.2
remove patches cherry-picked early from upstream
Diffstat (limited to 'main/ipsec-tools')
-rw-r--r--main/ipsec-tools/01-fix-deletion-notification.patch12
-rw-r--r--main/ipsec-tools/02-fix-xauth-double-free-on-reload.patch19
-rw-r--r--main/ipsec-tools/03-fix-sport-selection.patch29
-rw-r--r--main/ipsec-tools/APKBUILD22
4 files changed, 5 insertions, 77 deletions
diff --git a/main/ipsec-tools/01-fix-deletion-notification.patch b/main/ipsec-tools/01-fix-deletion-notification.patch
deleted file mode 100644
index c81846289d..0000000000
--- a/main/ipsec-tools/01-fix-deletion-notification.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -r1.48 isakmp_inf.c
---- a/src/racoon/isakmp_inf.c 29 Aug 2012 12:01:30 -0000 1.48
-+++ b/src/racoon/isakmp_inf.c 24 Jan 2013 06:46:45 -0000
-@@ -492,7 +492,7 @@
- "delete payload for protocol %s\n",
- s_ipsecdoi_proto(delete->proto_id));
-
-- if(!iph1->rmconf->weak_phase1_check && !encrypted) {
-+ if((iph1 == NULL || !iph1->rmconf->weak_phase1_check) && !encrypted) {
- plog(LLV_WARNING, LOCATION, iph1->remote,
- "Ignoring unencrypted delete payload "
- "(check the weak_phase1_check option)\n");
diff --git a/main/ipsec-tools/02-fix-xauth-double-free-on-reload.patch b/main/ipsec-tools/02-fix-xauth-double-free-on-reload.patch
deleted file mode 100644
index af3f7468be..0000000000
--- a/main/ipsec-tools/02-fix-xauth-double-free-on-reload.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/src/racoon/isakmp_xauth.c 15 Nov 2011 13:51:23 -0000 1.24
-+++ b/src/racoon/isakmp_xauth.c 5 Feb 2013 06:21:03 -0000
-@@ -458,10 +458,14 @@
- vfree(xauth_rad_config.acct_server_list[i].host);
- vfree(xauth_rad_config.acct_server_list[i].secret);
- }
-- if (radius_auth_state != NULL)
-+ if (radius_auth_state != NULL) {
- rad_close(radius_auth_state);
-- if (radius_acct_state != NULL)
-+ radius_auth_state = NULL;
-+ }
-+ if (radius_acct_state != NULL) {
- rad_close(radius_acct_state);
-+ radius_acct_state = NULL;
-+ }
- }
-
- /* initialize radius config */
diff --git a/main/ipsec-tools/03-fix-sport-selection.patch b/main/ipsec-tools/03-fix-sport-selection.patch
deleted file mode 100644
index 56cd999b39..0000000000
--- a/main/ipsec-tools/03-fix-sport-selection.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/src/racoon/grabmyaddr.c 14 Mar 2011 17:18:12 -0000 1.28
-+++ b/src/racoon/grabmyaddr.c 5 Feb 2013 11:32:59 -0000
-@@ -274,13 +274,24 @@
- struct sockaddr *addr;
- {
- struct myaddr *my;
-+ int port = 0, wport;
-
- LIST_FOREACH(my, &opened, chain) {
-- if (cmpsaddr((struct sockaddr *) &my->addr, addr) <= CMPSADDR_WILDPORT_MATCH)
-+ switch (cmpsaddr((struct sockaddr *) &my->addr, addr)) {
-+ case CMPSADDR_MATCH:
- return extract_port((struct sockaddr *) &my->addr);
-+ case CMPSADDR_WILDPORT_MATCH:
-+ wport = extract_port((struct sockaddr *) &my->addr);
-+ if (port == 0 || wport < port)
-+ port = wport;
-+ break;
-+ }
- }
-+
-+ if (port == 0)
-+ port = PORT_ISAKMP;
-
-- return PORT_ISAKMP;
-+ return port;
- }
-
- void
diff --git a/main/ipsec-tools/APKBUILD b/main/ipsec-tools/APKBUILD
index 04d8ccca63..4ce59f4cdd 100644
--- a/main/ipsec-tools/APKBUILD
+++ b/main/ipsec-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ipsec-tools
-pkgver=0.8.1
-pkgrel=3
+pkgver=0.8.2
+pkgrel=0
pkgdesc="User-space IPsec tools for various IPsec implementations"
url="http://ipsec-tools.sourceforge.net/"
arch="all"
@@ -12,9 +12,6 @@ subpackages="$pkgname-doc $pkgname-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
racoon.initd
racoon.confd
- 01-fix-deletion-notification.patch
- 02-fix-xauth-double-free-on-reload.patch
- 03-fix-sport-selection.patch
20-grekey-support.patch
50-reverse-connect.patch
70-defer-isakmp-ident-handling.patch
@@ -66,36 +63,27 @@ package() {
install -D -m644 ../racoon.confd "$pkgdir"/etc/conf.d/racoon
}
-md5sums="4d5d5ccc402c9c6bec0e87217e451fe5 ipsec-tools-0.8.1.tar.gz
+md5sums="8c222aedb897820e946aac203113b650 ipsec-tools-0.8.2.tar.gz
74f12ed04ed273a738229c0bfbf829cc racoon.initd
2d00250cf72da7f2f559c91b65a48747 racoon.confd
-c8b141e2c705c31af1c35d481e695ee6 01-fix-deletion-notification.patch
-5f30dfa6997b32e89c0e86826a70f777 02-fix-xauth-double-free-on-reload.patch
-2dd6bc764a5464b811edd6b4847880eb 03-fix-sport-selection.patch
a6efed1359bde30ea3652fdbe76d89c0 20-grekey-support.patch
f97205eea3dc68d2437a2ad8720f4520 50-reverse-connect.patch
94773c94233e14cdce0fa02ff780a43e 70-defer-isakmp-ident-handling.patch
2d5d24c4a3684a38584f88720f71c7d6 75-racoonctl-rcvbuf.patch
1d0d8ef21c65138d40f902502412da9c 90-dead-on-initial-contact.patch
2c415f8a8a0ffdc985c8162324d92677 musl-cdefs.patch"
-sha256sums="f31d927ad94fc4117855dfeb6f79a05c336811578b37ad6173b11f66e5c7272f ipsec-tools-0.8.1.tar.gz
+sha256sums="5e702549103d4cffb73d5bcd3a9b4cb75c398e7988f2421b2901cc0e15915785 ipsec-tools-0.8.2.tar.gz
07d6736958444f4473325f74857682232e048c201ac2154dc39be5f9e413e377 racoon.initd
b97aecfe8c7263487934801a588426693e1c441a77144374d7d8f84af4ce83f5 racoon.confd
-7ba0e60ba892b01f1852ac8230b92526fffec4c0164f35eb7da8e1a01c1c9182 01-fix-deletion-notification.patch
-32aa7eac936f17f9f9101a724ff6580a3d806e60244e768f750a3a83e4688f55 02-fix-xauth-double-free-on-reload.patch
-b41bf700ea35f28b62d7c11477ec882fa924ba6bb7a679a7c308d21eabb1b440 03-fix-sport-selection.patch
ac505943c53fe26ef67b1f2e5543de785f0e6cbb8279f3045cb1b0e324baea0a 20-grekey-support.patch
04fa15dbce53099e59b03e8fa1dab2da42b82743b1d88aaafc34b6bdfefc170c 50-reverse-connect.patch
bad8fc8d4e5c50295d4e2f5e9c1cfcb6f5d018b801e0618ccf9d6ecbf6b3ab06 70-defer-isakmp-ident-handling.patch
c07a9569ef19199e13c1d2f7b761c3354edf81b928194ac6e8cf911586f7cd25 75-racoonctl-rcvbuf.patch
8ea20cc244f9a8d0b819e773a4e5dd12c70639aa7f0fb78c797a394cf4ad72f2 90-dead-on-initial-contact.patch
df70ae2e83cf6da053739e01157b72f5b4ce1e9e4fbe3d0daac26e6cefee67b4 musl-cdefs.patch"
-sha512sums="80506f34d97712c5220ad566d9c461c9788b2179ae172579f05def72c5e40cd787dafe601a494e452878a5efa3fdf3c61d3ef9c0800fb708cfcdf8510f3f2374 ipsec-tools-0.8.1.tar.gz
+sha512sums="6cf4f1da7b461127e75f87fba8349f46b879f8bca179ae1cb27b2e011045753460c5edddbe8ba5892d6a28a021a0a01a9ff9fdb0f5da451519859570d748b9f2 ipsec-tools-0.8.2.tar.gz
d821245731c370c12a63ef1fdf65ae1e4d9aceb390d7bd0bf191fa19c3522fea70882cf43cf550eb0b5603fefc47602acf3c8b898f82cffcf3eaacb73f500436 racoon.initd
61c285e63a21e4162efa058d91cc061ad0a8387a7e6f654151f31bac757cdd250247c1be6776e1f04edea223dfb56d015285459ab5bbfd6218bfe3e51b861576 racoon.confd
-09a7d951f77c97c2e17028060fd012e4493b6e93242ce53d0ff0af6f1be208e65057ccf9c45c8b5e22e0fe1367b0d461d411d0700b65ad1f08004f9f988cda9c 01-fix-deletion-notification.patch
-6feaa039ccdbe1a1d021e251512ce4b8daa69f18857e5fee9f8a59a4b3c838c5cc2cb0d2946e7cbc61e8f37102e4747bf801b79babaf17b943a9b60967a9c0af 02-fix-xauth-double-free-on-reload.patch
-81003f4143ed384f8563df0c3afb5a9b8dfafc7e80964c9b3a5ad1f0a58a500129c635e0cf93481028b6e87b8f024f0fe55ad4cb3bb90a180bcf121f85b28ae8 03-fix-sport-selection.patch
22b79d5906dd4c5e740655303fe88fbdc2596cfbd057347cc303f8cfdd22f83fe61098613127d78030e3098335be83f46fe6d4dd5c2ebc8dd93ed94b7904812c 20-grekey-support.patch
2e111e0388a5e94ffa87483eac8c0b38fff1ba44d79c3db7438b3d03010db6334861acffecf044ebd3953f062230b528c34a05d38cf6831f5ebece0a307fb776 50-reverse-connect.patch
00ea3fb4b2ac91a550aaaffe53a29cc22f37f713052e2c5aee1bada6bcbc55b55ebe577f3df1ab09b314e99a45fd322152c2858263173cff17ff17993007b042 70-defer-isakmp-ident-handling.patch