aboutsummaryrefslogtreecommitdiffstats
path: root/main/iptables
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-03-27 09:11:34 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 17:45:40 +0000
commit5639562d54068646cdd2ba00beb75688043a1210 (patch)
treeefa4346d254ad1bbcff9b2c1a48ec969bfbafe06 /main/iptables
parentb5f69c4e1eeddf1f0e10e7ab6167575df421548d (diff)
downloadaports-5639562d54068646cdd2ba00beb75688043a1210.tar.bz2
aports-5639562d54068646cdd2ba00beb75688043a1210.tar.xz
main/iptables: upgrade to 1.8.2
Diffstat (limited to 'main/iptables')
-rw-r--r--main/iptables/APKBUILD14
-rw-r--r--main/iptables/iptables-1.8.2-musl-fixes.patch (renamed from main/iptables/iptables-1.6.0-musl-fixes.patch)23
2 files changed, 24 insertions, 13 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 65dc7bf1e1..0476b507d2 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -1,17 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iptables
-pkgver=1.6.2
-pkgrel=2
+pkgver=1.8.2
+pkgrel=0
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
-url="http://www.netfilter.org/projects/iptables/index.html"
+url="https://www.netfilter.org/projects/iptables/index.html"
arch="all"
license="GPL-2.0-or-later"
depends_dev="linux-headers"
makedepends="$depends_dev libnftnl-dev bison flex autoconf automake"
subpackages="ip6tables $pkgname-doc $pkgname-dev"
-source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
- iptables-1.6.0-musl-fixes.patch
+source="https://www.netfilter.org/projects/iptables/files/iptables-$pkgver.tar.bz2
+ iptables-1.8.2-musl-fixes.patch
iptables.initd
iptables.confd
ip6tables.confd
@@ -83,8 +83,8 @@ ip6tables() {
install -D -m644 "$srcdir"/ip6tables.confd etc/conf.d/ip6tables
}
-sha512sums="04f22e969c794246b9aa28055b202638081cfb0bb4a5625c049a30c48ac84cdd41db12a53c5831398cfe47c8f5691aa02b30b0ae3b5afe0f20ec48cf86a799c0 iptables-1.6.2.tar.bz2
-e79344cab67c4fa0449dfeef6d1504bcd41d16d595010a18a7d9e75eba46021617d31fbb79c62894fd35898ec643b542a6111b06d405c79ffff41a3078327b62 iptables-1.6.0-musl-fixes.patch
+sha512sums="8cf0f515764e1dc6e03284581d682d1949b33e8f25fea29c27ae856f1089fe8ca7b1814524b85f4378fd1fc7c7c7d002f06557b257ae2bbc945f8555bad0dc76 iptables-1.8.2.tar.bz2
+90a4fe20e8adba9a6a0890cccd70896493ddfa36d091cb62e95c0c940a99e32532b877474d53484a74e4aa385ba41a5c51dff485c382e39a0a00618989759196 iptables-1.8.2-musl-fixes.patch
059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1 iptables.initd
cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e iptables.confd
0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4 ip6tables.confd"
diff --git a/main/iptables/iptables-1.6.0-musl-fixes.patch b/main/iptables/iptables-1.8.2-musl-fixes.patch
index 4a89e19999..efde8746d0 100644
--- a/main/iptables/iptables-1.6.0-musl-fixes.patch
+++ b/main/iptables/iptables-1.8.2-musl-fixes.patch
@@ -1,5 +1,5 @@
---- iptables-1.4.12.1.o/extensions/libip6t_ipv6header.c
-+++ iptables-1.4.12.1/extensions/libip6t_ipv6header.c
+--- a/extensions/libip6t_ipv6header.c
++++ b/extensions/libip6t_ipv6header.c
@@ -10,6 +10,9 @@
#include <netdb.h>
#include <xtables.h>
@@ -10,8 +10,8 @@
enum {
O_HEADER = 0,
---- iptables-1.4.12.1.o/extensions/libxt_TCPOPTSTRIP.c
-+++ iptables-1.4.12.1/extensions/libxt_TCPOPTSTRIP.c
+--- a/extensions/libxt_TCPOPTSTRIP.c
++++ b/extensions/libxt_TCPOPTSTRIP.c
@@ -12,6 +12,21 @@
#ifndef TCPOPT_MD5SIG
# define TCPOPT_MD5SIG 19
@@ -34,8 +34,8 @@
enum {
O_STRIP_OPTION = 0,
---- iptables-1.4.12.1.o/include/linux/netfilter_ipv4/ip_tables.h
-+++ iptables-1.4.12.1/include/linux/netfilter_ipv4/ip_tables.h
+--- a/include/linux/netfilter_ipv4/ip_tables.h
++++ b/include/linux/netfilter_ipv4/ip_tables.h
@@ -16,6 +16,7 @@
#define _IPTABLES_H
@@ -43,3 +43,14 @@
+#include <sys/types.h>
#include <linux/netfilter_ipv4.h>
+
+--- a/extensions/libebt_vlan.c
++++ b/extensions/libebt_vlan.c
+@@ -12,6 +12,7 @@
+ #include <getopt.h>
+ #include <ctype.h>
+ #include <xtables.h>
++#include <netinet/if_ether.h>
+ #include <linux/netfilter_bridge/ebt_vlan.h>
+ #include <linux/if_ether.h>
+ #include "iptables/nft.h"