aboutsummaryrefslogtreecommitdiffstats
path: root/main/irssi
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-04 19:27:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:25 +0000
commit64d1510dc0fc330b2382aaa3fdfa5024419951e7 (patch)
tree9cf1df0a497fa591a010908e236bc02f5917b73f /main/irssi
parentd06b3682c5e989b066256801a821bb4137dca5b0 (diff)
downloadaports-64d1510dc0fc330b2382aaa3fdfa5024419951e7.tar.bz2
aports-64d1510dc0fc330b2382aaa3fdfa5024419951e7.tar.xz
main/irssi: rebuild against libressl-2.7
Diffstat (limited to 'main/irssi')
-rw-r--r--main/irssi/APKBUILD9
-rw-r--r--main/irssi/libressl-2.7.patch22
2 files changed, 28 insertions, 3 deletions
diff --git a/main/irssi/APKBUILD b/main/irssi/APKBUILD
index d547008059..4cd4a5dc30 100644
--- a/main/irssi/APKBUILD
+++ b/main/irssi/APKBUILD
@@ -1,14 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=irssi
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Modular textUI IRC client with IPv6 support"
url="https://irssi.org/"
arch="all"
license="GPL-2.0-or-later"
makedepends="glib-dev libressl-dev ncurses-dev perl-dev automake autoconf libtool"
subpackages="$pkgname-doc $pkgname-dev $pkgname-proxy $pkgname-perl"
-source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
+source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
+ libressl-2.7.patch
+ "
builddir="$srcdir"/$pkgname-$pkgver
# secfixes:
@@ -85,4 +87,5 @@ proxy() {
mv "$pkgdir"/usr/lib/irssi/modules/libirc_proxy.* "$subpkgdir"/usr/lib/irssi/modules/
}
-sha512sums="b2fc0805d6213c31bc34c48237baf2e33ac509c0fa09c483fd39f1473e32eee227ff4532efc60fb495c2ec263c05290578bca7ad6d39149e0594f864da5986c0 irssi-1.1.1.tar.xz"
+sha512sums="b2fc0805d6213c31bc34c48237baf2e33ac509c0fa09c483fd39f1473e32eee227ff4532efc60fb495c2ec263c05290578bca7ad6d39149e0594f864da5986c0 irssi-1.1.1.tar.xz
+6b5d987a9aeb189f3926272b37c631d04403832b495004779e8c23e9925a19349c7303927bab65b964ecb631fe7ac2394cf1c8e42ab69e300e30a121a95215ad libressl-2.7.patch"
diff --git a/main/irssi/libressl-2.7.patch b/main/irssi/libressl-2.7.patch
new file mode 100644
index 0000000000..f3705805f1
--- /dev/null
+++ b/main/irssi/libressl-2.7.patch
@@ -0,0 +1,22 @@
+diff --git a/src/core/network-openssl.c b/src/core/network-openssl.c
+index 9fddf07..e6de608 100644
+--- a/src/core/network-openssl.c
++++ b/src/core/network-openssl.c
+@@ -35,7 +35,7 @@
+ #include <openssl/err.h>
+
+ /* OpenSSL 1.1.0 introduced some backward-incompatible changes to the api */
+-#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
+ /* The two functions below could be already defined if OPENSSL_API_COMPAT is
+ * below the 1.1.0 version so let's do a clean start */
+ #undef X509_get_notBefore
+@@ -47,7 +47,7 @@
+
+ /* OpenSSL 1.1.0 also introduced some useful additions to the api */
+ #if (OPENSSL_VERSION_NUMBER >= 0x10002000L)
+-#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined (LIBRESSL_VERSION_NUMBER)
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
+ static int X509_STORE_up_ref(X509_STORE *vfy)
+ {
+ int n;