aboutsummaryrefslogtreecommitdiffstats
path: root/main/iscsitarget
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-19 14:42:50 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-19 14:42:50 +0100
commit6b5e935e2c4f0b083798d8430808fb35ca66f9c1 (patch)
tree8e5e913106039c806a2b14b12bc73bf0ce4a4672 /main/iscsitarget
parentc1038d0df56fd971ecf2e59183109b20dd63421f (diff)
downloadaports-6b5e935e2c4f0b083798d8430808fb35ca66f9c1.tar.bz2
aports-6b5e935e2c4f0b083798d8430808fb35ca66f9c1.tar.xz
main/iscsitarget*: removed
The kernel module does not build We provide alpine-scst iso image for now Upstream seems to go for LIO Enough reasons to remove from our tree
Diffstat (limited to 'main/iscsitarget')
-rw-r--r--main/iscsitarget/APKBUILD46
-rw-r--r--main/iscsitarget/ietd.confd30
-rw-r--r--main/iscsitarget/ietd.initd107
3 files changed, 0 insertions, 183 deletions
diff --git a/main/iscsitarget/APKBUILD b/main/iscsitarget/APKBUILD
deleted file mode 100644
index 99528f3f56..0000000000
--- a/main/iscsitarget/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-
-pkgname=iscsitarget
-pkgver=1.4.20.2
-pkgrel=3
-pkgdesc="Open Source iSCSI target with professional features - userspace utils"
-url="http://iscsitarget.sourceforge.net/"
-arch="all"
-license="GPL-2"
-depends=
-makedepends="openssl-dev"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- ietd.initd
- ietd.confd
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in ../*.patch; do
- [ -r "$i" ] || continue
- msg "Applying $i"
- patch -p1 < $i || return 1
- done
-}
-
-build() {
- cd "$_builddir"
- make usr || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install-usr install-doc
-
- for i in etc/ietd.conf etc/initiators.*; do
- install -Dm640 $i "$pkgdir"/$i || return 1
- done
- install -Dm755 ../ietd.initd "$pkgdir"/etc/init.d/ietd
- install -Dm755 ../ietd.confd "$pkgdir"/etc/conf.d/ietd
-}
-
-md5sums="2f23c0bfe124d79f5c20e34ef2aaff82 iscsitarget-1.4.20.2.tar.gz
-840621ee01a5736474ef343b4eb0fa9d ietd.initd
-06ba479d3533d557b8582abe6f182410 ietd.confd"
diff --git a/main/iscsitarget/ietd.confd b/main/iscsitarget/ietd.confd
deleted file mode 100644
index 3621326b1a..0000000000
--- a/main/iscsitarget/ietd.confd
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2006 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/files/ietd-conf.d,v 1.1 2006/02/20 08:33:40 robbat2 Exp $
-
-# Address and port to listen on for connections.
-#ADDRESS="" # set this to non-empty to listen somewhere specific
-PORT=3260
-
-# Address of your SNS server
-# if available
-#ISNS=""
-
-# User and group to run as
-# You must ensure that the UID/GID have access to the files/devices you
-# have provided in your configuration.
-USER="root"
-GROUP="root"
-
-# Debug level - see ietd(8) for the levels
-#DEBUGLEVEL=
-
-# This setting disables the memory configuration warnings.
-# Upstream takes the general policy of forcing all of the memory settings that
-# they want, but that doesn't mesh with users that have it set higher.
-# Gentoo by default ignores the settings that are higher, but issues warnings
-# on those that are lower.
-# Uncomment the next line to disable those warnings.
-#DISABLE_MEMORY_WARNINGS=1
-
-# vim: filetype=gentoo-conf-d tw=72:
diff --git a/main/iscsitarget/ietd.initd b/main/iscsitarget/ietd.initd
deleted file mode 100644
index ac315609e6..0000000000
--- a/main/iscsitarget/ietd.initd
+++ /dev/null
@@ -1,107 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-block/iscsitarget/files/ietd-init.d-2,v 1.1 2008/07/18 16:03:38 flameeyes Exp $
-
-MEM_SIZE=1048576
-DAEMON=/usr/sbin/ietd
-CONFIG_FILE=/etc/ietd.conf
-PID_FILE=/var/run/iscsi_trgt.pid
-NAME="iSCSI Enterprise Target"
-
-ARGS=""
-[ -n "$USER" ] && ARGS="${ARGS} --uid=${USER}"
-[ -n "$GROUP" ] && ARGS="${ARGS} --gid=${GROUP}"
-[ -n "$ISNS" ] && ARGS="${ARGS} --isns=${ISNS}"
-[ -n "$PORT" ] && ARGS="${ARGS} --port=${PORT}"
-[ -n "$ADDRESS" ] && ARGS="${ARGS} --address=${ADDRESS}"
-[ -n "$DEBUGLEVEL" ] && ARGS="${ARGS} --debug=${DEBUGLEVEL}"
-
-depend() {
- use net
- after firewall modules
-}
-
-checkconfig() {
- if [ ! -f $CONFIG_FILE ]; then
- eerror "Config file $CONFIG_FILE does not exist!"
- return 1
- fi
- if [ -z "$DISABLE_MEMORY_WARNINGS" ]; then
- check_memsize
- fi
-}
-
-check_memsize() {
- local wr md sysctl_key v k
- for wr in r w; do
- for md in max default; do
- sysctl_key="net.core.${wr}mem_${md}"
- v="$(sysctl -n ${sysctl_key})"
- if [ "${v}" -lt "${MEM_SIZE}" ]; then
- ewarn "$sysctl_key ($v) is lower than recommended ${MEM_SIZE}"
- fi
- done
- done
- for wr in "" r w; do
- sysctl_key="net.ipv4.tcp_${wr}mem"
- set -- $(sysctl -n ${sysctl_key})
- for k in min default max ; do
- if [ "${1}" -lt "${MEM_SIZE}" ]; then
- ewarn "$sysctl_key:$k (${1}) is lower than recommended ${MEM_SIZE}"
- fi
- shift
- done
- done
-}
-
-do_modules() {
- msg="$1"
- shift
- modules="$1"
- shift
- opts="$@"
- for m in ${modules}; do
- ebegin "${msg} - ${m}"
- modprobe ${opts} $m
- ret=$?
- eend $ret
- [ $ret -ne 0 ] && return $ret
- done
- return 0
-}
-
-start() {
- checkconfig || return 1
- do_modules 'Loading iSCSI-Target modules' 'iscsi_trgt'
- ebegin "Starting ${NAME}"
- start-stop-daemon --start --exec $DAEMON --quiet -- ${ARGS}
- eend $?
-}
-
-stop() {
- ebegin "Removing ${NAME} devices"
- # ugly, but ietadm does not allways provides correct exit values
- RETURN="$(ietadm --op delete 2>&1)"
- RETVAL=$?
- if [ $RETVAL -eq 0 ] && [ "$RETURN" != "something wrong" ] ; then
- eend 0
- else
- eend 1
- eerror "ietadm failed - $RETURN"
- return 1
- fi
-
- ebegin "Stopping ${NAME}"
- start-stop-daemon --stop --quiet --exec $DAEMON --pidfile $PID_FILE
- ret=$?
- eend $ret
- [ $ret -ne 0 ] && return 1
-
- # ugly, but pid file is not removed by ietd
- rm -f $PID_FILE
- # do_modules 'Removing iSCSI-Target modules' 'iscsi_trgt' '-r'
- return $?
-}
-
-# vim: tw=72: