aboutsummaryrefslogtreecommitdiffstats
path: root/main/iw/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-02 14:24:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-02 14:24:03 +0000
commit50ccfb291320049d541fc5074a1213a66920383c (patch)
treef30f7c57fa23a4c0e8bf1055271bcda9fffe4bf2 /main/iw/APKBUILD
parent70389a0d59c21210fa41c3968d6f25525a10022d (diff)
downloadaports-50ccfb291320049d541fc5074a1213a66920383c.tar.bz2
aports-50ccfb291320049d541fc5074a1213a66920383c.tar.xz
main/iw: moved from testing
Diffstat (limited to 'main/iw/APKBUILD')
-rw-r--r--main/iw/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/iw/APKBUILD b/main/iw/APKBUILD
new file mode 100644
index 0000000000..3cce23eff1
--- /dev/null
+++ b/main/iw/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=iw
+pkgver=0.9.18
+pkgrel=0
+pkgdesc="nl80211 based CLI configuration utility for wireless devices"
+url="http://wireless.kernel.org/en/users/Documentation/iw"
+license="GPL"
+depends=""
+makedepends="libnl-dev"
+source="http://wireless.kernel.org/download/iw/iw-$pkgver.tar.bz2
+ iw-bb-install.patch
+ iw-git-version.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/iw-bb-install.patch || return 1
+ patch -p1 -i "$srcdir"/iw-git-version.patch || return 1
+}
+
+build () {
+ cd "$_builddir"
+ make V=1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9734080d8a5c4b768c5e0da665a48950 iw-0.9.18.tar.bz2
+7f8cfc205fdcfd49d04c8923c76f439a iw-bb-install.patch
+779d0e73df6e484c071149c9fb720551 iw-git-version.patch"