aboutsummaryrefslogtreecommitdiffstats
path: root/main/jasper/rpath.patch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-25 12:59:16 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-26 07:07:56 +0000
commit07c1c1d2910f0b4cc6de3ab497704db772be1708 (patch)
tree74ff0dac25e9e000ae43960f653c13aa478e802d /main/jasper/rpath.patch
parent85964a38d7eb30c32e559ad7df8a142f6274abd8 (diff)
downloadaports-07c1c1d2910f0b4cc6de3ab497704db772be1708.tar.bz2
aports-07c1c1d2910f0b4cc6de3ab497704db772be1708.tar.xz
main/jasper: update to 2.0.16
Diffstat (limited to 'main/jasper/rpath.patch')
-rw-r--r--main/jasper/rpath.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/jasper/rpath.patch b/main/jasper/rpath.patch
new file mode 100644
index 0000000000..322ff837de
--- /dev/null
+++ b/main/jasper/rpath.patch
@@ -0,0 +1,25 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5f59d19..9208c65 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -340,19 +340,6 @@ endif()
+
+ if (JAS_ENABLE_SHARED)
+
+- # use, i.e. don't skip the full RPATH for the build tree
+- set(CMAKE_SKIP_BUILD_RPATH FALSE)
+-
+- # when building, don't use the install RPATH already
+- # (but later on when installing)
+- set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+-
+- set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+-
+- # add the automatically determined parts of the RPATH
+- # which point to directories outside the build tree to the install RPATH
+- set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-
+ # The RPATH to be used when installing, but only if it's not a
+ # system directory
+ list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES
+