aboutsummaryrefslogtreecommitdiffstats
path: root/main/jq/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-26 15:29:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-26 15:31:15 +0000
commit6d30e78f610975b527b795307549d9021853276d (patch)
treeeb4afaa78eedf64b491aa74c92f2f88a5fb602d6 /main/jq/APKBUILD
parent95bdd48092ccf25e7727f96a9dc1fd48c02cd812 (diff)
downloadaports-6d30e78f610975b527b795307549d9021853276d.tar.bz2
aports-6d30e78f610975b527b795307549d9021853276d.tar.xz
main/jq: security fix for CVE-2015-8863
fixes #5632
Diffstat (limited to 'main/jq/APKBUILD')
-rw-r--r--main/jq/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/main/jq/APKBUILD b/main/jq/APKBUILD
index 0c70cb30a5..06cff23fa7 100644
--- a/main/jq/APKBUILD
+++ b/main/jq/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=jq
pkgver=1.5
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight and flexible command-line JSON processor"
url="http://stedolan.github.io/jq/"
arch="all"
@@ -12,21 +12,26 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/stedolan/jq/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
+source="https://github.com/stedolan/jq/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz
+ CVE-2015-8863.patch
+ "
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+builddir="${srcdir}/${pkgname}-${pkgver}"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr --disable-docs
make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" prefix=/usr install
}
-md5sums="0933532b086bd8b6a41c1b162b1731f9 jq-1.5.tar.gz"
-sha256sums="c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c jq-1.5.tar.gz"
-sha512sums="4a0bb069ae875f47731d7d84ae6b82240703dc7a694cfb0aee4c7e9639defe7ba9af575d17dc32bda4426b80c186cc8dcd4505f3a6bcbe16b39e9b13097da238 jq-1.5.tar.gz"
+md5sums="0933532b086bd8b6a41c1b162b1731f9 jq-1.5.tar.gz
+bb9ef50162ebbba9a936a96bef607e1a CVE-2015-8863.patch"
+sha256sums="c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c jq-1.5.tar.gz
+cbe2003ab7d65acae4e6249df75bddbe78b076126b4d1c332eee46df24cb09e0 CVE-2015-8863.patch"
+sha512sums="4a0bb069ae875f47731d7d84ae6b82240703dc7a694cfb0aee4c7e9639defe7ba9af575d17dc32bda4426b80c186cc8dcd4505f3a6bcbe16b39e9b13097da238 jq-1.5.tar.gz
+e7e7fdf346ccd6df725dd28029654a6bebaa45ed6f14119f51d7f898b555416595d004bfc8a51f612039c11e9573d0f6ea28c3c2ca6aca1d23f1ee0543bfe1e9 CVE-2015-8863.patch"