aboutsummaryrefslogtreecommitdiffstats
path: root/main/jq/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-08-31 15:44:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-09-08 08:35:26 +0000
commit88a359be5d6bc6aa690308d941dc5c13c450d3ad (patch)
tree349e5ca2c1731f1e8bc3a8a01381db023bd584e2 /main/jq/APKBUILD
parent34047e3ece739aa676de589ce4b52f51a0eefdf1 (diff)
downloadaports-88a359be5d6bc6aa690308d941dc5c13c450d3ad.tar.bz2
aports-88a359be5d6bc6aa690308d941dc5c13c450d3ad.tar.xz
main/jq: add check function
Backport a patch from jq master that allow tests to work correctly with mktemp from busybox.
Diffstat (limited to 'main/jq/APKBUILD')
-rw-r--r--main/jq/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/jq/APKBUILD b/main/jq/APKBUILD
index 52d54e5f23..2c6b01915c 100644
--- a/main/jq/APKBUILD
+++ b/main/jq/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=jq
pkgver=1.5
-pkgrel=3
+pkgrel=4
pkgdesc="A lightweight and flexible command-line JSON processor"
url="http://stedolan.github.io/jq/"
arch="all"
@@ -13,6 +13,7 @@ makedepends="$depends_dev oniguruma-dev"
install=""
subpackages="$pkgname-doc $pkgname-dev"
source="https://github.com/stedolan/jq/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz
+ 0001-mktemp-needs-6-or-more-X-s-fix-1000.patch
CVE-2015-8863.patch
"
@@ -24,14 +25,16 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" prefix=/usr install
}
-md5sums="0933532b086bd8b6a41c1b162b1731f9 jq-1.5.tar.gz
-bb9ef50162ebbba9a936a96bef607e1a CVE-2015-8863.patch"
-sha256sums="c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c jq-1.5.tar.gz
-cbe2003ab7d65acae4e6249df75bddbe78b076126b4d1c332eee46df24cb09e0 CVE-2015-8863.patch"
sha512sums="4a0bb069ae875f47731d7d84ae6b82240703dc7a694cfb0aee4c7e9639defe7ba9af575d17dc32bda4426b80c186cc8dcd4505f3a6bcbe16b39e9b13097da238 jq-1.5.tar.gz
+c3508ad1692ebd7ad3486e376869f0f89230ad5869e00353c682cf86ff43cc15360ee2f45803ec113d7fd822d863856a9b93ff22b83b69d319786fe5bdce1edb 0001-mktemp-needs-6-or-more-X-s-fix-1000.patch
e7e7fdf346ccd6df725dd28029654a6bebaa45ed6f14119f51d7f898b555416595d004bfc8a51f612039c11e9573d0f6ea28c3c2ca6aca1d23f1ee0543bfe1e9 CVE-2015-8863.patch"