aboutsummaryrefslogtreecommitdiffstats
path: root/main/json-c0.12
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-13 21:03:03 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-14 07:18:43 +0000
commiteb560670fdcd3242acd38f86c082662f47c15aa4 (patch)
treeba734603e49ac7ba366c733ca595f697402f607d /main/json-c0.12
parent7e04a9a597a823c1352c0f343ebfd73cf5a2805e (diff)
downloadaports-eb560670fdcd3242acd38f86c082662f47c15aa4.tar.bz2
aports-eb560670fdcd3242acd38f86c082662f47c15aa4.tar.xz
main/json-c0.12: fix build with gcc8
Diffstat (limited to 'main/json-c0.12')
-rw-r--r--main/json-c0.12/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/json-c0.12/APKBUILD b/main/json-c0.12/APKBUILD
index f3cc53b53b..2cf2388cfd 100644
--- a/main/json-c0.12/APKBUILD
+++ b/main/json-c0.12/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=json-c0.12
pkgver=0.12.1
-pkgrel=1
+pkgrel=2
pkgdesc="A JSON implementation in C"
url="https://github.com/json-c/json-c/wiki"
arch="all"
@@ -21,7 +21,7 @@ prepare() {
build() {
cd "$builddir"
- export CFLAGS="${CFLAGS} -Wno-error=unused-but-set-variable"
+ export CFLAGS="${CFLAGS} -Wno-error=unused-but-set-variable -Wno-error=implicit-fallthrough"
./configure --prefix=/usr \
--build=$CBUILD \
--host=$CHOST \