aboutsummaryrefslogtreecommitdiffstats
path: root/main/jwhois/no-gnulib.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-27 10:01:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-27 10:01:39 +0000
commit343afb6beb1113e7f7e9c876921cb6dbae8efeb6 (patch)
tree2fe39fb99d8d8a010e388d1960ad70e963b4bb2d /main/jwhois/no-gnulib.patch
parent0e1ded7150d46ce84415e38fcb328eb7433950e4 (diff)
downloadaports-343afb6beb1113e7f7e9c876921cb6dbae8efeb6.tar.bz2
aports-343afb6beb1113e7f7e9c876921cb6dbae8efeb6.tar.xz
main/jwhois: use system snprintf
Using snprintf from gnulib will make fortify break. We simply remove use of gnulib since the only functions used is snprintf.
Diffstat (limited to 'main/jwhois/no-gnulib.patch')
-rw-r--r--main/jwhois/no-gnulib.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/jwhois/no-gnulib.patch b/main/jwhois/no-gnulib.patch
new file mode 100644
index 0000000000..f4610214f1
--- /dev/null
+++ b/main/jwhois/no-gnulib.patch
@@ -0,0 +1,52 @@
+--- ./configure.ac.orig
++++ ./configure.ac
+@@ -88,7 +88,6 @@
+ AC_PROG_INSTALL
+ AC_PROG_CC
+ AC_PROG_RANLIB
+-gl_EARLY
+
+ GETTEXT_PACKAGE=jwhois
+ AC_SUBST(GETTEXT_PACKAGE)
+@@ -209,14 +208,11 @@
+ OLDCFLAGS=$CFLAGS
+ AC_SUBST(OLDCFLAGS)
+
+-gl_INIT
+-
+ AC_OUTPUT([ po/Makefile.in m4/Makefile
+ Makefile
+ doc/Makefile
+ doc/sv/Makefile
+ src/Makefile
+-gl/Makefile
+ example/Makefile
+ jwhois.spec
+ ])
+--- ./Makefile.am.orig
++++ ./Makefile.am
+@@ -19,9 +19,8 @@
+ ##
+
+ EXTRA_DIST = config.rpath m4/ChangeLog config.rpath include/*.h example/jwhois.conf m4/*.m4 jwhois.spec.in jwhois.spec
+-SUBDIRS = m4 doc gl src example po
++SUBDIRS = m4 doc src example po
+
+-AM_CPPFLAGS = -I$(top_srcdir)/gl
+ LDADD = lib/libgnu.a
+
+-ACLOCAL_AMFLAGS = -I m4 -I gl/m4
++ACLOCAL_AMFLAGS = -I m4
+--- ./src/Makefile.am.orig
++++ ./src/Makefile.am
+@@ -30,9 +30,7 @@
+ -DLOCALSTATEDIR="\"$(localstatedir)\"" \
+ -DLOCALEDIR="\"$(localedir)\""
+
+-jwhois_LDADD = $(top_srcdir)/gl/libgnu.a
+-
+ AM_CFLAGS = $(jwhois_CFLAGS)
+
+
+-INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl -I$(top_srcdir)/gl
++INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl