aboutsummaryrefslogtreecommitdiffstats
path: root/main/kamailio
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-07-30 13:38:32 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-07-30 14:32:21 +0000
commit83c970f5a9d0d12c7155db15a6323704d6cb4188 (patch)
tree06b46a2654e63a96778c9e7616cb737797261ef2 /main/kamailio
parent1e82a561f3dcaf2e66dae0979c356197ce0446aa (diff)
downloadaports-83c970f5a9d0d12c7155db15a6323704d6cb4188.tar.bz2
aports-83c970f5a9d0d12c7155db15a6323704d6cb4188.tar.xz
main/kamailio: fix memleak in mohqueue module
Diffstat (limited to 'main/kamailio')
-rw-r--r--main/kamailio/0001-mohqueue.patch17
-rw-r--r--main/kamailio/APKBUILD5
2 files changed, 20 insertions, 2 deletions
diff --git a/main/kamailio/0001-mohqueue.patch b/main/kamailio/0001-mohqueue.patch
new file mode 100644
index 0000000000..72ca36b12b
--- /dev/null
+++ b/main/kamailio/0001-mohqueue.patch
@@ -0,0 +1,17 @@
+--- a/src/modules/mohqueue/mohq_funcs.c
++++ b/src/modules/mohqueue/mohq_funcs.c
+@@ -1405,9 +1405,12 @@
+
+ {
+ call_lst *pcall = (call_lst *)*pcbp->param;
++if (pcall->call_state >= CLSTA_INQUEUE)
++ { return; }
++LM_ERR ("invite_cb: INVITE failed for call (%s), code=%x, callstate=%x!\n",
++ pcall->call_from, ntype, pcall->call_state);
+ if (ntype == TMCB_DESTROY)
+ { pcall->call_hash = pcall->call_label = 0; }
+-LM_ERR ("invite_cb: INVITE failed for call (%s)!\n", pcall->call_from);
+ delete_call (pcall);
+ return;
+ }
+
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index 298777a021..60f7c9f12b 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -5,7 +5,7 @@
pkgname=kamailio
pkgver=5.1.8
-pkgrel=0
+pkgrel=1
# If building from a git snapshot, specify the gitcommit
# If building a proper release, leave gitcommit blank
@@ -249,6 +249,7 @@ for _i in db postgres sqlite dbtext mysql \
done
source="${pkgname}-${pkgver}${_suffix}.tar.gz::https://github.com/kamailio/$pkgname/archive/$_gitcommit.tar.gz
+ 0001-mohqueue.patch
0004-src_core_tcp_read_c.patch
kamailio.initd
"
@@ -535,7 +536,7 @@ sipdump() {
_generic_pkg "This module writes SIP traffic and some associated details into local files" \
"$_mod_list_sipdump"
}
-
sha512sums="a9d93bde174834ba04909a2fe781aac34b288082f279b30d56c53fb318982026557fff0efa214f1d4604d27f717e3c77ec216b113e2c68d0639e05a730bd8769 kamailio-5.1.8.tar.gz
+bbb00a3b680d2805aebf412a7cd77d5ac16e5edb45077516635101f78782dcaa779f84a3678fdd820fa7d7f021ae89271811b2e344092a8f5b7fe6eeee4c2599 0001-mohqueue.patch
af8362201957eae6b66baf7368c9ca884024209a396d77c5c52180c9aabe13772e9c6513e59721d39503e5bb7a8c1030f5c10301ea9055bddafb7f01ee2f3076 0004-src_core_tcp_read_c.patch
cd6e3b677d803cd78561ad14d9b2589fd35ad0096f48047fdcb4ddc7d9103871357efba3b350946844cb53dbb081210746421fc420c22ac845b90251168a628e kamailio.initd"