aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-04-08 13:19:00 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-15 14:44:00 +0000
commitff615f38c999c9d67fbd2c11374bff85c0ea8d81 (patch)
tree1c92361f7e62191004b4f06a2590391d547d255b /main/ldb
parent616b4ded11cebb33782b1d68e547e774e429d466 (diff)
downloadaports-ff615f38c999c9d67fbd2c11374bff85c0ea8d81.tar.bz2
aports-ff615f38c999c9d67fbd2c11374bff85c0ea8d81.tar.xz
main/ldb: upgrade to 1.3.8
Diffstat (limited to 'main/ldb')
-rw-r--r--main/ldb/APKBUILD12
-rw-r--r--main/ldb/disable-compile-error-test.patch21
-rw-r--r--main/ldb/disable-python-tests.patch27
-rw-r--r--main/ldb/fix-tests.patch376
4 files changed, 26 insertions, 410 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index 55b4eefc8d..9981860f44 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,17 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
-pkgver=1.3.5
+pkgver=1.3.8
pkgrel=0
pkgdesc="A schema-less, ldap like, API and database"
-url="http://ldb.samba.org/"
+url="https://ldb.samba.org/"
arch="all"
license="LGPL-3.0-or-later"
makedepends="libtirpc-dev tevent-dev py2-tevent tdb-dev py2-tdb talloc-dev
python2-dev python3-dev popt-dev cmocka-dev"
subpackages="$pkgname-dev py2-$pkgname:_py2 py3-$pkgname:_py3 $pkgname-tools"
source="https://www.samba.org/ftp/pub/ldb/$pkgname-$pkgver.tar.gz
- disable-python-tests.patch
- fix-tests.patch
+ disable-compile-error-test.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -72,6 +71,5 @@ tools() {
mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
}
-sha512sums="acf0854d4b1e1248296780574b20efefb153602396177f0a27f531118e843da5feacee0b755486825edc9c9e2a0b8bc6a06a774c608fdbf75e4c127c592c6859 ldb-1.3.5.tar.gz
-4b65362539ad169997b437b4b3444693ff318892931a827e220583e6c5114472a2029e90681be942c3a3ec76db82dedc23300d82e094c8fa8e9f24814756f8f9 disable-python-tests.patch
-10b09c967e0a09fb4522e4920e5e463568373242c13cfa79de433dd6a3996fe6ce58ceb4adc963c4e1ebdc91f32930c1e0ea2fe5f1bf6659a9076e85fa3813a6 fix-tests.patch"
+sha512sums="06d1b4c2badbf0c27733a64f979c48af8b599747cef7cd7f5417cd55a76447e8f8987bd061694c5af63261fdb35433e3844122c14103d5cc8b4eaab1f4752541 ldb-1.3.8.tar.gz
+ed55d5151bbcaf5c0a1b70a1f44b461a501ad94ce02ee97e3ea10c560ce3656a190510697bbd3c5b6f70a74519bf7c0a91210bcb415ffd97d9440045e10a02e8 disable-compile-error-test.patch"
diff --git a/main/ldb/disable-compile-error-test.patch b/main/ldb/disable-compile-error-test.patch
new file mode 100644
index 0000000000..16849ee549
--- /dev/null
+++ b/main/ldb/disable-compile-error-test.patch
@@ -0,0 +1,21 @@
+--- a/tests/ldb_match_test.c
++++ b/tests/ldb_match_test.c
+@@ -32,6 +32,8 @@
+ * This allows test applications to use custom definitions of C standard
+ * library functions and types.
+ */
++// disabled on alpine
++#if 0
+ #include <stdarg.h>
+ #include <stddef.h>
+ #include <stdint.h>
+@@ -189,3 +191,9 @@
+
+ return cmocka_run_group_tests(tests, NULL, NULL);
+ }
++#else
++int main(int argc, const char **argv)
++{
++ return 0;
++}
++#endif
diff --git a/main/ldb/disable-python-tests.patch b/main/ldb/disable-python-tests.patch
deleted file mode 100644
index 2025ab806c..0000000000
--- a/main/ldb/disable-python-tests.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Do not run python tests, they take eternity to finish.
-
---- a/wscript
-+++ b/wscript
-@@ -370,21 +370,13 @@
- ret = samba_utils.RUN_COMMAND(cmd)
- print("testsuite returned %d" % ret)
-
-- tmp_dir = os.path.join(test_prefix, 'tmp')
-- if not os.path.exists(tmp_dir):
-- os.mkdir(tmp_dir)
-- pyret = samba_utils.RUN_PYTHON_TESTS(
-- ['tests/python/api.py', 'tests/python/index.py'],
-- extra_env={'SELFTEST_PREFIX': test_prefix})
-- print("Python testsuite returned %d" % pyret)
--
- cmocka_ret = 0
- for test_exe in ['ldb_tdb_mod_op_test',
- 'ldb_msg_test']:
- cmd = os.path.join(Utils.g_module.blddir, test_exe)
- cmocka_ret = cmocka_ret or samba_utils.RUN_COMMAND(cmd)
-
-- sys.exit(ret or pyret or cmocka_ret)
-+ sys.exit(ret or cmocka_ret)
-
- def dist():
- '''makes a tarball for distribution'''
diff --git a/main/ldb/fix-tests.patch b/main/ldb/fix-tests.patch
deleted file mode 100644
index ef458457ca..0000000000
--- a/main/ldb/fix-tests.patch
+++ /dev/null
@@ -1,376 +0,0 @@
-From 373fc3382070bac760d0a59ed356c2cd1a537ab1 Mon Sep 17 00:00:00 2001
-From: Andrew Bartlett <abartlet@samba.org>
-Date: Thu, 8 Mar 2018 14:01:50 +1300
-Subject: [PATCH 1/2] ldb: Fix missing NULL terminator in ldb_mod_op_test
- testsuite
-
-BUG: https://bugzilla.samba.org/show_bug.cgi?id=13575
-
-Signed-off-by: Andrew Bartlett <abartlet@samba.org>
-Reviewed-by: Gary Lockyer <gary@catalyst.net.nz>
-(cherry picked from commit f8b368c9f0c2a34b6d15303a9d6facd762e1a517)
----
- tests/ldb_mod_op_test.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/ldb_mod_op_test.c b/tests/ldb_mod_op_test.c
-index c8b9c1aa9ff..f52cfdefc03 100644
---- a/tests/ldb_mod_op_test.c
-+++ b/tests/ldb_mod_op_test.c
-@@ -3314,7 +3314,7 @@ static int ldb_unique_index_test_setup(void **state)
- "dn: @INDEXLIST\n"
- "@IDXATTR: cn\n"
- "\n";
-- const char *options[] = {"modules:unique_index_test"};
-+ const char *options[] = {"modules:unique_index_test", NULL};
-
-
- ret = ldb_register_module(&ldb_unique_index_test_module_ops);
-@@ -3416,7 +3416,7 @@ static int ldb_non_unique_index_test_setup(void **state)
- "dn: @INDEXLIST\n"
- "@IDXATTR: cn\n"
- "\n";
-- const char *options[] = {"modules:unique_index_test"};
-+ const char *options[] = {"modules:unique_index_test", NULL};
-
-
- ret = ldb_register_module(&ldb_unique_index_test_module_ops);
---
-2.11.0
-
-
-From d876f14e651c1e264318ea1f14d9c6e2c09ac22c Mon Sep 17 00:00:00 2001
-From: Andrew Bartlett <abartlet@samba.org>
-Date: Thu, 16 Aug 2018 09:22:22 +1200
-Subject: [PATCH 2/2] ldb: Release LDB 1.3.6
-
- * make test fails on ldb 1.3.4 due to missing NULL terminator in tests (bug 13575)
-
-Signed-off-by: Andrew Bartlett <abartlet@samba.org>
----
- lib/ldb/ABI/ldb-1.3.6.sigs | 279 ++++++++++++++++++++++++++++++++++
- lib/ldb/ABI/pyldb-util-1.3.6.sigs | 2 +
- lib/ldb/ABI/pyldb-util.py3-1.3.6.sigs | 2 +
- lib/ldb/wscript | 2 +-
- 4 files changed, 284 insertions(+), 1 deletion(-)
- create mode 100644 lib/ldb/ABI/ldb-1.3.6.sigs
- create mode 100644 lib/ldb/ABI/pyldb-util-1.3.6.sigs
- create mode 100644 lib/ldb/ABI/pyldb-util.py3-1.3.6.sigs
-
-diff --git a/ABI/ldb-1.3.6.sigs b/lib/ldb/ABI/ldb-1.3.6.sigs
-new file mode 100644
-index 00000000000..a31b84ef4b5
---- /dev/null
-+++ b/ABI/ldb-1.3.6.sigs
-@@ -0,0 +1,279 @@
-+ldb_add: int (struct ldb_context *, const struct ldb_message *)
-+ldb_any_comparison: int (struct ldb_context *, void *, ldb_attr_handler_t, const struct ldb_val *, const struct ldb_val *)
-+ldb_asprintf_errstring: void (struct ldb_context *, const char *, ...)
-+ldb_attr_casefold: char *(TALLOC_CTX *, const char *)
-+ldb_attr_dn: int (const char *)
-+ldb_attr_in_list: int (const char * const *, const char *)
-+ldb_attr_list_copy: const char **(TALLOC_CTX *, const char * const *)
-+ldb_attr_list_copy_add: const char **(TALLOC_CTX *, const char * const *, const char *)
-+ldb_base64_decode: int (char *)
-+ldb_base64_encode: char *(TALLOC_CTX *, const char *, int)
-+ldb_binary_decode: struct ldb_val (TALLOC_CTX *, const char *)
-+ldb_binary_encode: char *(TALLOC_CTX *, struct ldb_val)
-+ldb_binary_encode_string: char *(TALLOC_CTX *, const char *)
-+ldb_build_add_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, const struct ldb_message *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_del_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, struct ldb_dn *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_extended_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, const char *, void *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_mod_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, const struct ldb_message *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_rename_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, struct ldb_dn *, struct ldb_dn *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_search_req: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, struct ldb_dn *, enum ldb_scope, const char *, const char * const *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_build_search_req_ex: int (struct ldb_request **, struct ldb_context *, TALLOC_CTX *, struct ldb_dn *, enum ldb_scope, struct ldb_parse_tree *, const char * const *, struct ldb_control **, void *, ldb_request_callback_t, struct ldb_request *)
-+ldb_casefold: char *(struct ldb_context *, TALLOC_CTX *, const char *, size_t)
-+ldb_casefold_default: char *(void *, TALLOC_CTX *, const char *, size_t)
-+ldb_check_critical_controls: int (struct ldb_control **)
-+ldb_comparison_binary: int (struct ldb_context *, void *, const struct ldb_val *, const struct ldb_val *)
-+ldb_comparison_fold: int (struct ldb_context *, void *, const struct ldb_val *, const struct ldb_val *)
-+ldb_connect: int (struct ldb_context *, const char *, unsigned int, const char **)
-+ldb_control_to_string: char *(TALLOC_CTX *, const struct ldb_control *)
-+ldb_controls_except_specified: struct ldb_control **(struct ldb_control **, TALLOC_CTX *, struct ldb_control *)
-+ldb_debug: void (struct ldb_context *, enum ldb_debug_level, const char *, ...)
-+ldb_debug_add: void (struct ldb_context *, const char *, ...)
-+ldb_debug_end: void (struct ldb_context *, enum ldb_debug_level)
-+ldb_debug_set: void (struct ldb_context *, enum ldb_debug_level, const char *, ...)
-+ldb_delete: int (struct ldb_context *, struct ldb_dn *)
-+ldb_dn_add_base: bool (struct ldb_dn *, struct ldb_dn *)
-+ldb_dn_add_base_fmt: bool (struct ldb_dn *, const char *, ...)
-+ldb_dn_add_child: bool (struct ldb_dn *, struct ldb_dn *)
-+ldb_dn_add_child_fmt: bool (struct ldb_dn *, const char *, ...)
-+ldb_dn_alloc_casefold: char *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_alloc_linearized: char *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_canonical_ex_string: char *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_canonical_string: char *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_check_local: bool (struct ldb_module *, struct ldb_dn *)
-+ldb_dn_check_special: bool (struct ldb_dn *, const char *)
-+ldb_dn_compare: int (struct ldb_dn *, struct ldb_dn *)
-+ldb_dn_compare_base: int (struct ldb_dn *, struct ldb_dn *)
-+ldb_dn_copy: struct ldb_dn *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_escape_value: char *(TALLOC_CTX *, struct ldb_val)
-+ldb_dn_extended_add_syntax: int (struct ldb_context *, unsigned int, const struct ldb_dn_extended_syntax *)
-+ldb_dn_extended_filter: void (struct ldb_dn *, const char * const *)
-+ldb_dn_extended_syntax_by_name: const struct ldb_dn_extended_syntax *(struct ldb_context *, const char *)
-+ldb_dn_from_ldb_val: struct ldb_dn *(TALLOC_CTX *, struct ldb_context *, const struct ldb_val *)
-+ldb_dn_get_casefold: const char *(struct ldb_dn *)
-+ldb_dn_get_comp_num: int (struct ldb_dn *)
-+ldb_dn_get_component_name: const char *(struct ldb_dn *, unsigned int)
-+ldb_dn_get_component_val: const struct ldb_val *(struct ldb_dn *, unsigned int)
-+ldb_dn_get_extended_comp_num: int (struct ldb_dn *)
-+ldb_dn_get_extended_component: const struct ldb_val *(struct ldb_dn *, const char *)
-+ldb_dn_get_extended_linearized: char *(TALLOC_CTX *, struct ldb_dn *, int)
-+ldb_dn_get_ldb_context: struct ldb_context *(struct ldb_dn *)
-+ldb_dn_get_linearized: const char *(struct ldb_dn *)
-+ldb_dn_get_parent: struct ldb_dn *(TALLOC_CTX *, struct ldb_dn *)
-+ldb_dn_get_rdn_name: const char *(struct ldb_dn *)
-+ldb_dn_get_rdn_val: const struct ldb_val *(struct ldb_dn *)
-+ldb_dn_has_extended: bool (struct ldb_dn *)
-+ldb_dn_is_null: bool (struct ldb_dn *)
-+ldb_dn_is_special: bool (struct ldb_dn *)
-+ldb_dn_is_valid: bool (struct ldb_dn *)
-+ldb_dn_map_local: struct ldb_dn *(struct ldb_module *, void *, struct ldb_dn *)
-+ldb_dn_map_rebase_remote: struct ldb_dn *(struct ldb_module *, void *, struct ldb_dn *)
-+ldb_dn_map_remote: struct ldb_dn *(struct ldb_module *, void *, struct ldb_dn *)
-+ldb_dn_minimise: bool (struct ldb_dn *)
-+ldb_dn_new: struct ldb_dn *(TALLOC_CTX *, struct ldb_context *, const char *)
-+ldb_dn_new_fmt: struct ldb_dn *(TALLOC_CTX *, struct ldb_context *, const char *, ...)
-+ldb_dn_remove_base_components: bool (struct ldb_dn *, unsigned int)
-+ldb_dn_remove_child_components: bool (struct ldb_dn *, unsigned int)
-+ldb_dn_remove_extended_components: void (struct ldb_dn *)
-+ldb_dn_replace_components: bool (struct ldb_dn *, struct ldb_dn *)
-+ldb_dn_set_component: int (struct ldb_dn *, int, const char *, const struct ldb_val)
-+ldb_dn_set_extended_component: int (struct ldb_dn *, const char *, const struct ldb_val *)
-+ldb_dn_update_components: int (struct ldb_dn *, const struct ldb_dn *)
-+ldb_dn_validate: bool (struct ldb_dn *)
-+ldb_dump_results: void (struct ldb_context *, struct ldb_result *, FILE *)
-+ldb_error_at: int (struct ldb_context *, int, const char *, const char *, int)
-+ldb_errstring: const char *(struct ldb_context *)
-+ldb_extended: int (struct ldb_context *, const char *, void *, struct ldb_result **)
-+ldb_extended_default_callback: int (struct ldb_request *, struct ldb_reply *)
-+ldb_filter_from_tree: char *(TALLOC_CTX *, const struct ldb_parse_tree *)
-+ldb_get_config_basedn: struct ldb_dn *(struct ldb_context *)
-+ldb_get_create_perms: unsigned int (struct ldb_context *)
-+ldb_get_default_basedn: struct ldb_dn *(struct ldb_context *)
-+ldb_get_event_context: struct tevent_context *(struct ldb_context *)
-+ldb_get_flags: unsigned int (struct ldb_context *)
-+ldb_get_opaque: void *(struct ldb_context *, const char *)
-+ldb_get_root_basedn: struct ldb_dn *(struct ldb_context *)
-+ldb_get_schema_basedn: struct ldb_dn *(struct ldb_context *)
-+ldb_global_init: int (void)
-+ldb_handle_get_event_context: struct tevent_context *(struct ldb_handle *)
-+ldb_handle_new: struct ldb_handle *(TALLOC_CTX *, struct ldb_context *)
-+ldb_handle_use_global_event_context: void (struct ldb_handle *)
-+ldb_handler_copy: int (struct ldb_context *, void *, const struct ldb_val *, struct ldb_val *)
-+ldb_handler_fold: int (struct ldb_context *, void *, const struct ldb_val *, struct ldb_val *)
-+ldb_init: struct ldb_context *(TALLOC_CTX *, struct tevent_context *)
-+ldb_ldif_message_redacted_string: char *(struct ldb_context *, TALLOC_CTX *, enum ldb_changetype, const struct ldb_message *)
-+ldb_ldif_message_string: char *(struct ldb_context *, TALLOC_CTX *, enum ldb_changetype, const struct ldb_message *)
-+ldb_ldif_parse_modrdn: int (struct ldb_context *, const struct ldb_ldif *, TALLOC_CTX *, struct ldb_dn **, struct ldb_dn **, bool *, struct ldb_dn **, struct ldb_dn **)
-+ldb_ldif_read: struct ldb_ldif *(struct ldb_context *, int (*)(void *), void *)
-+ldb_ldif_read_file: struct ldb_ldif *(struct ldb_context *, FILE *)
-+ldb_ldif_read_file_state: struct ldb_ldif *(struct ldb_context *, struct ldif_read_file_state *)
-+ldb_ldif_read_free: void (struct ldb_context *, struct ldb_ldif *)
-+ldb_ldif_read_string: struct ldb_ldif *(struct ldb_context *, const char **)
-+ldb_ldif_write: int (struct ldb_context *, int (*)(void *, const char *, ...), void *, const struct ldb_ldif *)
-+ldb_ldif_write_file: int (struct ldb_context *, FILE *, const struct ldb_ldif *)
-+ldb_ldif_write_redacted_trace_string: char *(struct ldb_context *, TALLOC_CTX *, const struct ldb_ldif *)
-+ldb_ldif_write_string: char *(struct ldb_context *, TALLOC_CTX *, const struct ldb_ldif *)
-+ldb_load_modules: int (struct ldb_context *, const char **)
-+ldb_map_add: int (struct ldb_module *, struct ldb_request *)
-+ldb_map_delete: int (struct ldb_module *, struct ldb_request *)
-+ldb_map_init: int (struct ldb_module *, const struct ldb_map_attribute *, const struct ldb_map_objectclass *, const char * const *, const char *, const char *)
-+ldb_map_modify: int (struct ldb_module *, struct ldb_request *)
-+ldb_map_rename: int (struct ldb_module *, struct ldb_request *)
-+ldb_map_search: int (struct ldb_module *, struct ldb_request *)
-+ldb_match_message: int (struct ldb_context *, const struct ldb_message *, const struct ldb_parse_tree *, enum ldb_scope, bool *)
-+ldb_match_msg: int (struct ldb_context *, const struct ldb_message *, const struct ldb_parse_tree *, struct ldb_dn *, enum ldb_scope)
-+ldb_match_msg_error: int (struct ldb_context *, const struct ldb_message *, const struct ldb_parse_tree *, struct ldb_dn *, enum ldb_scope, bool *)
-+ldb_match_msg_objectclass: int (const struct ldb_message *, const char *)
-+ldb_mod_register_control: int (struct ldb_module *, const char *)
-+ldb_modify: int (struct ldb_context *, const struct ldb_message *)
-+ldb_modify_default_callback: int (struct ldb_request *, struct ldb_reply *)
-+ldb_module_call_chain: char *(struct ldb_request *, TALLOC_CTX *)
-+ldb_module_connect_backend: int (struct ldb_context *, const char *, const char **, struct ldb_module **)
-+ldb_module_done: int (struct ldb_request *, struct ldb_control **, struct ldb_extended *, int)
-+ldb_module_flags: uint32_t (struct ldb_context *)
-+ldb_module_get_ctx: struct ldb_context *(struct ldb_module *)
-+ldb_module_get_name: const char *(struct ldb_module *)
-+ldb_module_get_ops: const struct ldb_module_ops *(struct ldb_module *)
-+ldb_module_get_private: void *(struct ldb_module *)
-+ldb_module_init_chain: int (struct ldb_context *, struct ldb_module *)
-+ldb_module_load_list: int (struct ldb_context *, const char **, struct ldb_module *, struct ldb_module **)
-+ldb_module_new: struct ldb_module *(TALLOC_CTX *, struct ldb_context *, const char *, const struct ldb_module_ops *)
-+ldb_module_next: struct ldb_module *(struct ldb_module *)
-+ldb_module_popt_options: struct poptOption **(struct ldb_context *)
-+ldb_module_send_entry: int (struct ldb_request *, struct ldb_message *, struct ldb_control **)
-+ldb_module_send_referral: int (struct ldb_request *, char *)
-+ldb_module_set_next: void (struct ldb_module *, struct ldb_module *)
-+ldb_module_set_private: void (struct ldb_module *, void *)
-+ldb_modules_hook: int (struct ldb_context *, enum ldb_module_hook_type)
-+ldb_modules_list_from_string: const char **(struct ldb_context *, TALLOC_CTX *, const char *)
-+ldb_modules_load: int (const char *, const char *)
-+ldb_msg_add: int (struct ldb_message *, const struct ldb_message_element *, int)
-+ldb_msg_add_empty: int (struct ldb_message *, const char *, int, struct ldb_message_element **)
-+ldb_msg_add_fmt: int (struct ldb_message *, const char *, const char *, ...)
-+ldb_msg_add_linearized_dn: int (struct ldb_message *, const char *, struct ldb_dn *)
-+ldb_msg_add_steal_string: int (struct ldb_message *, const char *, char *)
-+ldb_msg_add_steal_value: int (struct ldb_message *, const char *, struct ldb_val *)
-+ldb_msg_add_string: int (struct ldb_message *, const char *, const char *)
-+ldb_msg_add_value: int (struct ldb_message *, const char *, const struct ldb_val *, struct ldb_message_element **)
-+ldb_msg_canonicalize: struct ldb_message *(struct ldb_context *, const struct ldb_message *)
-+ldb_msg_check_string_attribute: int (const struct ldb_message *, const char *, const char *)
-+ldb_msg_copy: struct ldb_message *(TALLOC_CTX *, const struct ldb_message *)
-+ldb_msg_copy_attr: int (struct ldb_message *, const char *, const char *)
-+ldb_msg_copy_shallow: struct ldb_message *(TALLOC_CTX *, const struct ldb_message *)
-+ldb_msg_diff: struct ldb_message *(struct ldb_context *, struct ldb_message *, struct ldb_message *)
-+ldb_msg_difference: int (struct ldb_context *, TALLOC_CTX *, struct ldb_message *, struct ldb_message *, struct ldb_message **)
-+ldb_msg_element_compare: int (struct ldb_message_element *, struct ldb_message_element *)
-+ldb_msg_element_compare_name: int (struct ldb_message_element *, struct ldb_message_element *)
-+ldb_msg_element_equal_ordered: bool (const struct ldb_message_element *, const struct ldb_message_element *)
-+ldb_msg_find_attr_as_bool: int (const struct ldb_message *, const char *, int)
-+ldb_msg_find_attr_as_dn: struct ldb_dn *(struct ldb_context *, TALLOC_CTX *, const struct ldb_message *, const char *)
-+ldb_msg_find_attr_as_double: double (const struct ldb_message *, const char *, double)
-+ldb_msg_find_attr_as_int: int (const struct ldb_message *, const char *, int)
-+ldb_msg_find_attr_as_int64: int64_t (const struct ldb_message *, const char *, int64_t)
-+ldb_msg_find_attr_as_string: const char *(const struct ldb_message *, const char *, const char *)
-+ldb_msg_find_attr_as_uint: unsigned int (const struct ldb_message *, const char *, unsigned int)
-+ldb_msg_find_attr_as_uint64: uint64_t (const struct ldb_message *, const char *, uint64_t)
-+ldb_msg_find_common_values: int (struct ldb_context *, TALLOC_CTX *, struct ldb_message_element *, struct ldb_message_element *, uint32_t)
-+ldb_msg_find_duplicate_val: int (struct ldb_context *, TALLOC_CTX *, const struct ldb_message_element *, struct ldb_val **, uint32_t)
-+ldb_msg_find_element: struct ldb_message_element *(const struct ldb_message *, const char *)
-+ldb_msg_find_ldb_val: const struct ldb_val *(const struct ldb_message *, const char *)
-+ldb_msg_find_val: struct ldb_val *(const struct ldb_message_element *, struct ldb_val *)
-+ldb_msg_new: struct ldb_message *(TALLOC_CTX *)
-+ldb_msg_normalize: int (struct ldb_context *, TALLOC_CTX *, const struct ldb_message *, struct ldb_message **)
-+ldb_msg_remove_attr: void (struct ldb_message *, const char *)
-+ldb_msg_remove_element: void (struct ldb_message *, struct ldb_message_element *)
-+ldb_msg_rename_attr: int (struct ldb_message *, const char *, const char *)
-+ldb_msg_sanity_check: int (struct ldb_context *, const struct ldb_message *)
-+ldb_msg_sort_elements: void (struct ldb_message *)
-+ldb_next_del_trans: int (struct ldb_module *)
-+ldb_next_end_trans: int (struct ldb_module *)
-+ldb_next_init: int (struct ldb_module *)
-+ldb_next_prepare_commit: int (struct ldb_module *)
-+ldb_next_read_lock: int (struct ldb_module *)
-+ldb_next_read_unlock: int (struct ldb_module *)
-+ldb_next_remote_request: int (struct ldb_module *, struct ldb_request *)
-+ldb_next_request: int (struct ldb_module *, struct ldb_request *)
-+ldb_next_start_trans: int (struct ldb_module *)
-+ldb_op_default_callback: int (struct ldb_request *, struct ldb_reply *)
-+ldb_options_find: const char *(struct ldb_context *, const char **, const char *)
-+ldb_pack_data: int (struct ldb_context *, const struct ldb_message *, struct ldb_val *)
-+ldb_parse_control_from_string: struct ldb_control *(struct ldb_context *, TALLOC_CTX *, const char *)
-+ldb_parse_control_strings: struct ldb_control **(struct ldb_context *, TALLOC_CTX *, const char **)
-+ldb_parse_tree: struct ldb_parse_tree *(TALLOC_CTX *, const char *)
-+ldb_parse_tree_attr_replace: void (struct ldb_parse_tree *, const char *, const char *)
-+ldb_parse_tree_copy_shallow: struct ldb_parse_tree *(TALLOC_CTX *, const struct ldb_parse_tree *)
-+ldb_parse_tree_walk: int (struct ldb_parse_tree *, int (*)(struct ldb_parse_tree *, void *), void *)
-+ldb_qsort: void (void * const, size_t, size_t, void *, ldb_qsort_cmp_fn_t)
-+ldb_register_backend: int (const char *, ldb_connect_fn, bool)
-+ldb_register_extended_match_rule: int (struct ldb_context *, const struct ldb_extended_match_rule *)
-+ldb_register_hook: int (ldb_hook_fn)
-+ldb_register_module: int (const struct ldb_module_ops *)
-+ldb_rename: int (struct ldb_context *, struct ldb_dn *, struct ldb_dn *)
-+ldb_reply_add_control: int (struct ldb_reply *, const char *, bool, void *)
-+ldb_reply_get_control: struct ldb_control *(struct ldb_reply *, const char *)
-+ldb_req_get_custom_flags: uint32_t (struct ldb_request *)
-+ldb_req_is_untrusted: bool (struct ldb_request *)
-+ldb_req_location: const char *(struct ldb_request *)
-+ldb_req_mark_trusted: void (struct ldb_request *)
-+ldb_req_mark_untrusted: void (struct ldb_request *)
-+ldb_req_set_custom_flags: void (struct ldb_request *, uint32_t)
-+ldb_req_set_location: void (struct ldb_request *, const char *)
-+ldb_request: int (struct ldb_context *, struct ldb_request *)
-+ldb_request_add_control: int (struct ldb_request *, const char *, bool, void *)
-+ldb_request_done: int (struct ldb_request *, int)
-+ldb_request_get_control: struct ldb_control *(struct ldb_request *, const char *)
-+ldb_request_get_status: int (struct ldb_request *)
-+ldb_request_replace_control: int (struct ldb_request *, const char *, bool, void *)
-+ldb_request_set_state: void (struct ldb_request *, int)
-+ldb_reset_err_string: void (struct ldb_context *)
-+ldb_save_controls: int (struct ldb_control *, struct ldb_request *, struct ldb_control ***)
-+ldb_schema_attribute_add: int (struct ldb_context *, const char *, unsigned int, const char *)
-+ldb_schema_attribute_add_with_syntax: int (struct ldb_context *, const char *, unsigned int, const struct ldb_schema_syntax *)
-+ldb_schema_attribute_by_name: const struct ldb_schema_attribute *(struct ldb_context *, const char *)
-+ldb_schema_attribute_fill_with_syntax: int (struct ldb_context *, TALLOC_CTX *, const char *, unsigned int, const struct ldb_schema_syntax *, struct ldb_schema_attribute *)
-+ldb_schema_attribute_remove: void (struct ldb_context *, const char *)
-+ldb_schema_attribute_remove_flagged: void (struct ldb_context *, unsigned int)
-+ldb_schema_attribute_set_override_handler: void (struct ldb_context *, ldb_attribute_handler_override_fn_t, void *)
-+ldb_schema_set_override_GUID_index: void (struct ldb_context *, const char *, const char *)
-+ldb_schema_set_override_indexlist: void (struct ldb_context *, bool)
-+ldb_search: int (struct ldb_context *, TALLOC_CTX *, struct ldb_result **, struct ldb_dn *, enum ldb_scope, const char * const *, const char *, ...)
-+ldb_search_default_callback: int (struct ldb_request *, struct ldb_reply *)
-+ldb_sequence_number: int (struct ldb_context *, enum ldb_sequence_type, uint64_t *)
-+ldb_set_create_perms: void (struct ldb_context *, unsigned int)
-+ldb_set_debug: int (struct ldb_context *, void (*)(void *, enum ldb_debug_level, const char *, va_list), void *)
-+ldb_set_debug_stderr: int (struct ldb_context *)
-+ldb_set_default_dns: void (struct ldb_context *)
-+ldb_set_errstring: void (struct ldb_context *, const char *)
-+ldb_set_event_context: void (struct ldb_context *, struct tevent_context *)
-+ldb_set_flags: void (struct ldb_context *, unsigned int)
-+ldb_set_modules_dir: void (struct ldb_context *, const char *)
-+ldb_set_opaque: int (struct ldb_context *, const char *, void *)
-+ldb_set_require_private_event_context: void (struct ldb_context *)
-+ldb_set_timeout: int (struct ldb_context *, struct ldb_request *, int)
-+ldb_set_timeout_from_prev_req: int (struct ldb_context *, struct ldb_request *, struct ldb_request *)
-+ldb_set_utf8_default: void (struct ldb_context *)
-+ldb_set_utf8_fns: void (struct ldb_context *, void *, char *(*)(void *, void *, const char *, size_t))
-+ldb_setup_wellknown_attributes: int (struct ldb_context *)
-+ldb_should_b64_encode: int (struct ldb_context *, const struct ldb_val *)
-+ldb_standard_syntax_by_name: const struct ldb_schema_syntax *(struct ldb_context *, const char *)
-+ldb_strerror: const char *(int)
-+ldb_string_to_time: time_t (const char *)
-+ldb_string_utc_to_time: time_t (const char *)
-+ldb_timestring: char *(TALLOC_CTX *, time_t)
-+ldb_timestring_utc: char *(TALLOC_CTX *, time_t)
-+ldb_transaction_cancel: int (struct ldb_context *)
-+ldb_transaction_cancel_noerr: int (struct ldb_context *)
-+ldb_transaction_commit: int (struct ldb_context *)
-+ldb_transaction_prepare_commit: int (struct ldb_context *)
-+ldb_transaction_start: int (struct ldb_context *)
-+ldb_unpack_data: int (struct ldb_context *, const struct ldb_val *, struct ldb_message *)
-+ldb_unpack_data_only_attr_list: int (struct ldb_context *, const struct ldb_val *, struct ldb_message *, const char * const *, unsigned int, unsigned int *)
-+ldb_unpack_data_only_attr_list_flags: int (struct ldb_context *, const struct ldb_val *, struct ldb_message *, const char * const *, unsigned int, unsigned int, unsigned int *)
-+ldb_val_dup: struct ldb_val (TALLOC_CTX *, const struct ldb_val *)
-+ldb_val_equal_exact: int (const struct ldb_val *, const struct ldb_val *)
-+ldb_val_map_local: struct ldb_val (struct ldb_module *, void *, const struct ldb_map_attribute *, const struct ldb_val *)
-+ldb_val_map_remote: struct ldb_val (struct ldb_module *, void *, const struct ldb_map_attribute *, const struct ldb_val *)
-+ldb_val_string_cmp: int (const struct ldb_val *, const char *)
-+ldb_val_to_time: int (const struct ldb_val *, time_t *)
-+ldb_valid_attr_name: int (const char *)
-+ldb_vdebug: void (struct ldb_context *, enum ldb_debug_level, const char *, va_list)
-+ldb_wait: int (struct ldb_handle *, enum ldb_wait_type)
-diff --git a/ABI/pyldb-util-1.3.6.sigs b/ABI/pyldb-util-1.3.6.sigs
-new file mode 100644
-index 00000000000..74d6719d2bc
---- /dev/null
-+++ b/ABI/pyldb-util-1.3.6.sigs
-@@ -0,0 +1,2 @@
-+pyldb_Dn_FromDn: PyObject *(struct ldb_dn *)
-+pyldb_Object_AsDn: bool (TALLOC_CTX *, PyObject *, struct ldb_context *, struct ldb_dn **)
-diff --git a/ABI/pyldb-util.py3-1.3.6.sigs b/ABI/pyldb-util.py3-1.3.6.sigs
-new file mode 100644
-index 00000000000..74d6719d2bc
---- /dev/null
-+++ b/ABI/pyldb-util.py3-1.3.6.sigs
-@@ -0,0 +1,2 @@
-+pyldb_Dn_FromDn: PyObject *(struct ldb_dn *)
-+pyldb_Object_AsDn: bool (TALLOC_CTX *, PyObject *, struct ldb_context *, struct ldb_dn **)
-diff --git a/wscript b/wscript
-index 27b4df120a0..dfc3d9dce23 100644
---- a/wscript
-+++ b/wscript
-@@ -1,7 +1,7 @@
- #!/usr/bin/env python
-
- APPNAME = 'ldb'
--VERSION = '1.3.5'
-+VERSION = '1.3.6'
-
- blddir = 'bin'
-
---
-2.11.0
-