aboutsummaryrefslogtreecommitdiffstats
path: root/main/ldb
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-08-20 03:53:41 +0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-08-20 14:33:06 +0000
commitbe7c0e1dcba3a83d85999e7875b0e87820c93f53 (patch)
tree8242cba186171ba305ff143d558a7ac382c27c82 /main/ldb
parent4f49fff3f864b3b55cf9da465de676e4336350bf (diff)
downloadaports-be7c0e1dcba3a83d85999e7875b0e87820c93f53.tar.bz2
aports-be7c0e1dcba3a83d85999e7875b0e87820c93f53.tar.xz
main/ldb: Upgrade to 1.3.5
* Test suite fails if compiler flags set * Use waf directly instead of disguising as autotools * Re-arrange and remove unused configure options
Diffstat (limited to 'main/ldb')
-rw-r--r--main/ldb/APKBUILD26
-rw-r--r--main/ldb/fix-memory-leak-on-module-context.patch23
2 files changed, 11 insertions, 38 deletions
diff --git a/main/ldb/APKBUILD b/main/ldb/APKBUILD
index 780636b48a..a8fc002aba 100644
--- a/main/ldb/APKBUILD
+++ b/main/ldb/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ldb
-pkgver=1.3.3
+pkgver=1.3.5
pkgrel=0
pkgdesc="A schema-less, ldap like, API and database"
url="http://ldb.samba.org/"
@@ -10,36 +10,33 @@ makedepends="libtirpc-dev tevent-dev py2-tevent tdb-dev py2-tdb talloc-dev
python2-dev python3-dev popt-dev cmocka-dev"
subpackages="$pkgname-dev py2-$pkgname:_py2 py3-$pkgname:_py3 $pkgname-tools"
source="https://www.samba.org/ftp/pub/ldb/$pkgname-$pkgver.tar.gz
- fix-memory-leak-on-module-context.patch
disable-python-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
+_waf="python "$builddir"/buildtools/bin/waf"
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ # As of 1.3.5, test suite fails when compiler flags set. Remove if no longer needed.
+ unset CFLAGS CXXFLAGS CPPFLAGS
+ $_waf configure \
--prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
--disable-rpath \
- --bundled-libraries=NONE \
+ --disable-rpath-install \
--builtin-libraries=replace \
+ --bundled-libraries=NONE \
--with-modulesdir=/usr/lib/ldb/modules \
--extra-python=/usr/bin/python3
- make
+ $_waf build
}
check() {
cd "$builddir"
- make check
+ $_waf test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" $_waf install
}
_py2() {
@@ -67,6 +64,5 @@ tools() {
mv "$pkgdir"/usr/lib/ldb/libldb-cmdline.* "$subpkgdir"/usr/lib/ldb/
}
-sha512sums="ad272a1fd82d5138d9a056c1d81cfcd6167886719852b41447b9e6fb6acd926b137fd76e16f476d68bc0991943142ea1482666dc48155e9a1ef09f13b041c350 ldb-1.3.3.tar.gz
-7524e23ff8fe378fc4e24ac9e93bfa27012a2a646c5411d419d0181ffd4192fdbb0c3b28f4e2a2e43cf93a1340eeaf526699ac16d846b616612d922abd2595aa fix-memory-leak-on-module-context.patch
+sha512sums="acf0854d4b1e1248296780574b20efefb153602396177f0a27f531118e843da5feacee0b755486825edc9c9e2a0b8bc6a06a774c608fdbf75e4c127c592c6859 ldb-1.3.5.tar.gz
4b65362539ad169997b437b4b3444693ff318892931a827e220583e6c5114472a2029e90681be942c3a3ec76db82dedc23300d82e094c8fa8e9f24814756f8f9 disable-python-tests.patch"
diff --git a/main/ldb/fix-memory-leak-on-module-context.patch b/main/ldb/fix-memory-leak-on-module-context.patch
deleted file mode 100644
index f8fcfff716..0000000000
--- a/main/ldb/fix-memory-leak-on-module-context.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 6c78935344a4f086fc209d0bd77feac0ea5894b3 Mon Sep 17 00:00:00 2001
-From: Lukas Slebodnik <lslebodn@fedoraproject.org>
-Date: Sat, 21 Oct 2017 15:09:01 +0200
-Subject: [PATCH] ldb: Fix memory leak on module context
-
-Introduced in e8cdacc509016d9273d63faf334d9f827585c3eb
-
-Patch-Source: https://src.fedoraproject.org/rpms/libldb/blob/f28/f/0001-ldb-Fix-memory-leak-on-module-context.patch
-
---- a/ldb_tdb/ldb_index.c
-+++ b/ldb_tdb/ldb_index.c
-@@ -516,9 +516,9 @@ static int ltdb_dn_list_store_full(struct ldb_module *module,
- if (list->count == 0) {
- ret = ltdb_delete_noindex(module, msg);
- if (ret == LDB_ERR_NO_SUCH_OBJECT) {
-- talloc_free(msg);
-- return LDB_SUCCESS;
-+ ret = LDB_SUCCESS;
- }
-+ talloc_free(msg);
- return ret;
- }
-