aboutsummaryrefslogtreecommitdiffstats
path: root/main/libasr/APKBUILD
diff options
context:
space:
mode:
authorxentec <xentec@aix0.eu>2017-02-11 15:00:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-13 18:28:14 +0100
commitd3a7437a76d864f6aa585e6ae82789cd5455c04d (patch)
tree9bbee0eb0f8cd69fc196b66ddbb376331d440753 /main/libasr/APKBUILD
parent0850971f05a1ea0ff352c1f83fa68d1b4055ea68 (diff)
downloadaports-d3a7437a76d864f6aa585e6ae82789cd5455c04d.tar.bz2
aports-d3a7437a76d864f6aa585e6ae82789cd5455c04d.tar.xz
main/libasr: replace res_randomid() impl. with call to arc4random() from libcrypto
Fixes recursive call loop which causes a stack overflow in opensmtpd. ref #6578
Diffstat (limited to 'main/libasr/APKBUILD')
-rw-r--r--main/libasr/APKBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/main/libasr/APKBUILD b/main/libasr/APKBUILD
index d5b81757a7..b3801c2cd3 100644
--- a/main/libasr/APKBUILD
+++ b/main/libasr/APKBUILD
@@ -12,41 +12,41 @@ depends_dev=""
makedepends="mdocml bison libressl-dev automake autoconf libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/OpenSMTPD/libasr/archive/libasr-$pkgver.zip
- 00-use-openbsd-res_randomid.patch"
+source="https://github.com/OpenSMTPD/libasr/archive/libasr-$pkgver.tar.gz
+ 0001-Fix-NETDB_SUCCESS-value.patch
+ 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
+ 0003-no-need-for-openssl-in-libasr.patch
+ "
-_builddir=${srcdir}/${pkgname}-${pkgname}-${pkgver}
+builddir=${srcdir}/${pkgname}-${pkgname}-${pkgver}
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- ./bootstrap
+ default_prepare || return 1
+
+ cd "$builddir"
+ ./bootstrap || return 1
}
build() {
- cd "$_builddir"
- ./configure --build=$CBUILD \
+ cd "$builddir"
+
+ ./configure --build=$CBUILD \
--host=$CHOST \
--with-pie \
--with-Werror \
--prefix=/usr \
--mandir=/usr/share/man \
- --with-mantype=man || return 1
- make || return 1
+ --with-mantype=man \
+ || return 1
+
+ make || return 1
}
package() {
- cd "$_builddir"
- make DESTDIR=${pkgdir} install || return 1
+ cd "$builddir"
+ make DESTDIR=${pkgdir} install || return 1
}
-md5sums="1919b1b1c5a08821901fd2c0a6d488a7 libasr-1.0.2.zip
-2d32d1f831dc000137d5fcaf9db3e33f 00-use-openbsd-res_randomid.patch"
-sha256sums="8e1ed7420446219d105ac0c384cf69160791335dc69bf1ca0581279472241ca7 libasr-1.0.2.zip
-19ad3fe95f881b60c317ec63777c1b4843dbaea39d28343eb67c5bdbabe4e5f9 00-use-openbsd-res_randomid.patch"
-sha512sums="2b9185c9bd953d093be397554bc024ddab03003e0c56f19018a8bc22d48434fe3364274fef631cd5e2984321368baff4cd4a504d61b71c60ceffd9e5cc3c8124 libasr-1.0.2.zip
-2dd30b5147562f209b23b4a939be787304125cf559bccd937781149cc7cb487c4cf6ec358fba32a33407c7ca3e44545ebbe04ddc2a14504835409f23bdef9689 00-use-openbsd-res_randomid.patch"
+sha512sums="d70d5fb5728678074f4fd3d0f925b13a8a5ac9fec7a38277f2ed0e6b3f3fe2591845d035f43ece1ee16f1fdfd7d7443140ca36f171f94f310ed821b88b82b924 libasr-1.0.2.tar.gz
+aebd80ae1fd33604f547833d4244161cc8551404c61e666967062e484a30d88f597e71c9f9956a3604bf02e625d8aabd9b4669d3efad1a2a15efb2f8acd8ac03 0001-Fix-NETDB_SUCCESS-value.patch
+2bef347875b1ad4ec47a6d642e0f555f40906e19bce7684fd89c1c3c867f67fff8cf42ddd836480ee73a8b4491ef9385f84c12f39197d677d239f8ac23d740a0 0002-Replace-missing-res_randomid-with-the-more-secure-ar.patch
+32ffc6e64d9eeb7aa37a2f4b4633ac462508f2ee7a9152b6c6b87aeebdcc89e809e839d4cc66ed49486b98d34706ff8cd86d8466663bd8712dacd99cfec64e03 0003-no-need-for-openssl-in-libasr.patch"