aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd/APKBUILD
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-25 18:48:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-25 19:04:17 +0000
commit1eba7932edc2dcb0d601a65eab0c7b9af7866c2a (patch)
tree0dd98e858bc5a7bb1d18406722955b9277b2d958 /main/libbsd/APKBUILD
parenteead5f8364feaad02302f551320d0e5eb0cad811 (diff)
downloadaports-1eba7932edc2dcb0d601a65eab0c7b9af7866c2a.tar.bz2
aports-1eba7932edc2dcb0d601a65eab0c7b9af7866c2a.tar.xz
main/libbsd: fix a.out.h bug
Ref https://git.yoctoproject.org/cgit.cgi/poky/tree/meta/recipes-support/libbsd/libbsd https://patchwork.openembedded.org/patch/133637/
Diffstat (limited to 'main/libbsd/APKBUILD')
-rw-r--r--main/libbsd/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index 5094657100..6581fb0ed6 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -3,20 +3,22 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libbsd
pkgver=0.8.3
-pkgrel=2
+pkgrel=3
pkgdesc="commonly-used BSD functions not implemented by all libcs"
url="http://libbsd.freedesktop.org/"
-arch="all !armhf !aarch64"
+arch="all"
license="BSD"
depends=""
depends_dev="bsd-compat-headers linux-headers"
makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="http://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
- musl-fixes.patch
- fix-build-with-musl-on-ppc64le-s390x.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+ 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+ 0002-Remove-funopen.patch
+ 0003-Fix-build-breaks-due-to-missing-a.out.h.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare || return 1
@@ -44,5 +46,6 @@ package() {
}
sha512sums="155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f libbsd-0.8.3.tar.xz
-032b8de7abfe6ffec80957db05fcb02b2cec74f26ecc99ef20d2a314efd0dfd88486e31bd33dd7460ac85b48acdab3ba849cd96bdd0884cd5667e7a43ab30c3a musl-fixes.patch
-f6c6bf62f1f840de6939e255eca165298a50f45241588b2ea18b314991fb60677316ba954bab179538b5babe0c6140e038b6fb49ecdeea569048fc3e5be7caf0 fix-build-with-musl-on-ppc64le-s390x.patch"
+4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+aee969d880bc968b2ad6c1a343bc6733c230fdc55c8ded9c4f211be267dcf26f605e3c23d1ce2abc49616fcf6864c51a6c16a67b945180360bd65d4c4d3ddf86 0002-Remove-funopen.patch
+64b68497c9a638d43f90f148d206d59afabec0a62e39522200f72f9ba27529809c6e578ad670681424b2b940ba32a9fab6c526487fd9c6863e0c9a15749bd80a 0003-Fix-build-breaks-due-to-missing-a.out.h.patch"