aboutsummaryrefslogtreecommitdiffstats
path: root/main/libcdio
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 21:55:07 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:19:04 +0000
commit675826c99db12c9f52be4e6292d8c3d4ce56d6b8 (patch)
tree29b7412aa70d37325d43bdf1209ca424e8e05a33 /main/libcdio
parentf58824478c62eb5bf2e1df5b15135d99acd8700b (diff)
downloadaports-675826c99db12c9f52be4e6292d8c3d4ce56d6b8.tar.bz2
aports-675826c99db12c9f52be4e6292d8c3d4ce56d6b8.tar.xz
main/libcdio: modernise, add check
Diffstat (limited to 'main/libcdio')
-rw-r--r--main/libcdio/APKBUILD29
-rw-r--r--main/libcdio/disable-broken-test.patch34
2 files changed, 48 insertions, 15 deletions
diff --git a/main/libcdio/APKBUILD b/main/libcdio/APKBUILD
index df8c80799b..bbe6920fc8 100644
--- a/main/libcdio/APKBUILD
+++ b/main/libcdio/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libcdio
pkgver=0.94
-pkgrel=0
+pkgrel=1
pkgdesc="GNU Compact Disc Input and Control Library"
url="https://www.gnu.org/software/libcdio/"
arch="all"
@@ -11,17 +11,11 @@ depends=
makedepends="libcddb-dev ncurses-dev linux-headers"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools ${pkgname}++:_cpp"
-source="http://ftp.gnu.org/gnu/libcdio/${pkgname}-${pkgver}.tar.gz"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- # apply patches here
-}
+source="http://ftp.gnu.org/gnu/libcdio/${pkgname}-${pkgver}.tar.gz
+ disable-broken-test.patch"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,13 +26,17 @@ build() {
--disable-vcd-info \
--disable-static \
--disable-rpath \
- --disable-cpp-progs \
- || return 1
- make || return 1
+ --disable-cpp-progs
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
@@ -54,4 +52,5 @@ _cpp() {
mv "$pkgdir"/usr/lib/*++.* "$subpkgdir"/usr/lib/
}
-sha512sums="e1d3c96c4acc7be923c97109c3f76223adc00b293278daef7d5008b1e5d67f33402f9f224f05120e9e1e8b3a8d1fa1b0bd5069dc6dd309741e3590e2c19e0e66 libcdio-0.94.tar.gz"
+sha512sums="e1d3c96c4acc7be923c97109c3f76223adc00b293278daef7d5008b1e5d67f33402f9f224f05120e9e1e8b3a8d1fa1b0bd5069dc6dd309741e3590e2c19e0e66 libcdio-0.94.tar.gz
+be0149128bb2fa131f514bcff848279d826340a99a05b958e104f4640bda1a89d6146b0ec348783f4bbd8a3c313c41297152f75ee04f492f08b337bd79dd9c3e disable-broken-test.patch"
diff --git a/main/libcdio/disable-broken-test.patch b/main/libcdio/disable-broken-test.patch
new file mode 100644
index 0000000000..223445df3f
--- /dev/null
+++ b/main/libcdio/disable-broken-test.patch
@@ -0,0 +1,34 @@
+--- libcdio-0.94/test/driver/realpath.c.old 2015-05-08 06:40:54.000000000 -0500
++++ libcdio-0.94/test/driver/realpath.c 2017-10-07 02:03:01.832979859 -0500
+@@ -155,6 +155,7 @@
+ check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
+ }
+
++#if 0 /* This test requires undefined behaviour in realpath(3). */
+ /* Make sure we handle a cyclic symbolic name, e.g. xx -> xx */
+ cdio_realpath(psz_symlink_file, symlink_file);
+ rc = check_rc(symlink(psz_symlink_file, psz_symlink_file),
+@@ -168,6 +169,7 @@
+ }
+ check_rc(unlink(psz_symlink_file), "unlink", psz_symlink_file);
+ }
++#endif
+
+ }
+
+--- libcdio-0.94/test/malformed.right.old 2015-05-07 23:25:02.000000000 -0500
++++ libcdio-0.94/test/malformed.right 2017-10-07 02:08:17.898937537 -0500
+@@ -1,3 +1,3 @@
+-Error getting above directory information
+ __________________________________
++Error getting above directory information
+ ISO-9660 Information
+--- libcdio-0.94/test/malformed2.right.old 2015-05-08 05:54:32.000000000 -0500
++++ libcdio-0.94/test/malformed2.right 2017-10-07 02:09:46.362072631 -0500
+@@ -1,5 +1,5 @@
+-Error getting above directory information
+ __________________________________
++Error getting above directory information
+ ISO-9660 Information
+ 2048 /a
+ 0 /b.txt