aboutsummaryrefslogtreecommitdiffstats
path: root/main/libebml
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-20 22:26:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:11:35 +0000
commit81b232ec81649f783ce112fce1ca4f32d031554a (patch)
tree2fa0c28bbbd9f1f290a11cff566fb554cca3eb9b /main/libebml
parent2b52e7f75fd86ae76ea7303f901c685a1ed4ffcf (diff)
downloadaports-81b232ec81649f783ce112fce1ca4f32d031554a.tar.bz2
aports-81b232ec81649f783ce112fce1ca4f32d031554a.tar.xz
main/libebml: upgrade to 1.3.6
Switch to cmake is required by upstream
Diffstat (limited to 'main/libebml')
-rw-r--r--main/libebml/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/main/libebml/APKBUILD b/main/libebml/APKBUILD
index 452e61665b..5da2fde5e8 100644
--- a/main/libebml/APKBUILD
+++ b/main/libebml/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libebml
-pkgver=1.3.5
-pkgrel=1
+pkgver=1.3.6
+pkgrel=0
pkgdesc="C++ library to parse Extensible Binary Meta-Language files"
url="https://www.matroska.org/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1+"
depends=
+makedepends="cmake"
subpackages="$pkgname-dev"
source="http://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
make
}
@@ -27,4 +34,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="cdf05015724919b19281bf99c562bb7e0bdf16990da274010f664ff316b6ce95ecbeaa1e479f03505281a7f45d5796aee6e7750a9e1c0596b630911d220dca24 libebml-1.3.5.tar.xz"
+sha512sums="6a31a56dcde39642848f25353a462f4621d6cfd3bc9ef62add1b00d098c6a80b3c2b50ecf4d6dd50650c609eb39a6150c6d1b69ea3a77a3928bd3300af7dd91f libebml-1.3.6.tar.xz"