aboutsummaryrefslogtreecommitdiffstats
path: root/main/libelf
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-17 05:42:03 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:40:49 +0000
commit26fcb98d3493e2f881998bfdacd76efff0479003 (patch)
tree739aa1db0a4f2cbc2aa0877d5ed11a06e920b147 /main/libelf
parent76ea81d26be534ef1d0a8705bbacc08899048c00 (diff)
downloadaports-26fcb98d3493e2f881998bfdacd76efff0479003.tar.bz2
aports-26fcb98d3493e2f881998bfdacd76efff0479003.tar.xz
main/libelf: add stubby test suite, modernise
Diffstat (limited to 'main/libelf')
-rw-r--r--main/libelf/APKBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/main/libelf/APKBUILD b/main/libelf/APKBUILD
index 9b118415a8..35f5af9950 100644
--- a/main/libelf/APKBUILD
+++ b/main/libelf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libelf
pkgver=0.8.13
-pkgrel=2
+pkgrel=3
pkgdesc="libelf is a free ELF object file access library"
url="http://www.mr511.de/software/"
arch="all"
@@ -11,15 +11,16 @@ makedepends=
subpackages="$pkgname-dev"
source="http://www.mr511.de/software/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ default_prepare
+ update_config_sub
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,13 +28,17 @@ build() {
--enable-shared \
--enable-gnu-names \
--enable-compat \
- --disable-nls \
- || return 1
- make || return 1
+ --disable-nls
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make install prefix="$pkgdir"/usr || return 1
+ cd "$builddir"
+ make install prefix="$pkgdir"/usr
}
sha512sums="d2a4ea8ccc0bbfecac38fa20fbd96aefa8e86f8af38691fb6991cd9c5a03f587475ecc2365fc89a4954c11a679d93460ee9a5890693112f6133719af3e6582fe libelf-0.8.13.tar.gz"