aboutsummaryrefslogtreecommitdiffstats
path: root/main/libestr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-30 11:11:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-30 11:21:23 +0000
commite0e8339a5806a84b063d964b8411672dae034e74 (patch)
treee9570b958fc96a9139d31f63880cd2c1c57d4660 /main/libestr
parentb802501b189226b4cce67a571a8018e8aff35042 (diff)
downloadaports-e0e8339a5806a84b063d964b8411672dae034e74.tar.bz2
aports-e0e8339a5806a84b063d964b8411672dae034e74.tar.xz
main/libestr: backport from edge
needed by rsyslog
Diffstat (limited to 'main/libestr')
-rw-r--r--main/libestr/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/libestr/APKBUILD b/main/libestr/APKBUILD
new file mode 100644
index 0000000000..3ce89068dd
--- /dev/null
+++ b/main/libestr/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Uros
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+pkgname=libestr
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="essentials for string handling (and a bit more)"
+url="http://libestr.adiscon.com"
+arch="all"
+license="LGPL2.1"
+subpackages="$pkgname-dev"
+source="http://libestr.adiscon.com/files/download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/lib/libestr.la
+}
+
+md5sums="30ec4054155dc7d7e9b06418181c4f12 libestr-0.1.2.tar.gz"