aboutsummaryrefslogtreecommitdiffstats
path: root/main/libfastjson
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-07 15:46:45 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-19 14:50:51 +0000
commit9f1deab7a8bb37802d7d30f6daf487a4853c315b (patch)
treeb1079b2bc35ef76012dc2dffaf7280053c5dd67f /main/libfastjson
parent372cfef2763935f35cc81e63ce702fa56da8cbe7 (diff)
downloadaports-9f1deab7a8bb37802d7d30f6daf487a4853c315b.tar.bz2
aports-9f1deab7a8bb37802d7d30f6daf487a4853c315b.tar.xz
main/libfastjson: fix url
Diffstat (limited to 'main/libfastjson')
-rw-r--r--main/libfastjson/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/libfastjson/APKBUILD b/main/libfastjson/APKBUILD
index b43e741157..9bbd2d786b 100644
--- a/main/libfastjson/APKBUILD
+++ b/main/libfastjson/APKBUILD
@@ -2,25 +2,29 @@
# Maintainer: Ashley Sommer <ashleysommer@gmail.com>
pkgname=libfastjson
pkgver=0.99.8
-pkgrel=1
+pkgrel=2
pkgdesc="A fork of the json-c library for rsyslog, optimized for liblognorm processing."
-url="http://www.rsyslog.com/"
+url="https://www.rsyslog.com/"
arch="all"
license="MIT"
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-dbg"
source="$pkgname-$pkgver.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ ./autogen.sh
+}
build() {
- cd "$builddir"
- sh autogen.sh \
+ cd "$builddir"
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man \
+ --disable-static
make
}