aboutsummaryrefslogtreecommitdiffstats
path: root/main/libfetch/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-03 16:27:59 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-03 16:27:59 +0200
commitcd841eaf0778a9b2732519507a59dd1cdc1a9822 (patch)
treeb02b04941af945277c4c6e6f1b518aae62cc6a7a /main/libfetch/APKBUILD
parent2a5c968bee88db6fad68c04df1733e2ff29d4419 (diff)
downloadaports-cd841eaf0778a9b2732519507a59dd1cdc1a9822.tar.bz2
aports-cd841eaf0778a9b2732519507a59dd1cdc1a9822.tar.xz
main/libfetch: move from testing
Diffstat (limited to 'main/libfetch/APKBUILD')
-rw-r--r--main/libfetch/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/libfetch/APKBUILD b/main/libfetch/APKBUILD
new file mode 100644
index 0000000000..fcd925cb16
--- /dev/null
+++ b/main/libfetch/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libfetch
+pkgver=2.33
+pkgrel=0
+pkgdesc="URL based download library"
+url="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
+arch="all"
+license="BSD"
+depends=
+makedepends="openssl-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="Makefile
+ ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cp "$srcdir"/Makefile "$_builddir"
+}
+
+build () {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR=$pkgdir install
+}
+md5sums="cf18907a75c67f543b1173d7f87830af Makefile
+a176b94f7f30344ef8a71c047ca2136b libfetch-2.33.tar.gz"