aboutsummaryrefslogtreecommitdiffstats
path: root/main/libgit2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-04 12:12:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:24 +0000
commit26139567fa01bc9f57a9ee5d4d39544b440c7db5 (patch)
tree42a8cec77de2f3b833e752bcec37d93fd905c33a /main/libgit2
parenta8d4525d8af29daae854e6f5c414c951a881c2f9 (diff)
downloadaports-26139567fa01bc9f57a9ee5d4d39544b440c7db5.tar.bz2
aports-26139567fa01bc9f57a9ee5d4d39544b440c7db5.tar.xz
main/libgit2: rebuild against libressl-2.7
Diffstat (limited to 'main/libgit2')
-rw-r--r--main/libgit2/APKBUILD7
-rw-r--r--main/libgit2/libressl-2.7.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/main/libgit2/APKBUILD b/main/libgit2/APKBUILD
index 8fd252220d..93994fd74f 100644
--- a/main/libgit2/APKBUILD
+++ b/main/libgit2/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgit2
pkgver=0.26.3
-pkgrel=0
+pkgrel=1
pkgdesc="A linkable library for Git"
url="https://libgit2.github.com/"
arch="all"
@@ -16,7 +16,9 @@ provides="$pkgname-libs" # for backward compatibility with v3.4
replaces="$pkgname-libs" # for backward compatibility with v3.4
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
build-both-static-dynamic.patch
+ libressl-2.7.patch
"
+options="!check" # FIXME some tests fails
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -57,4 +59,5 @@ tests() {
}
sha512sums="abcd3a904bed05c1f200be2ffbc2c44cebd1b548459ee834d5635c5eaf7bcd551a4993bcc1cb9fbeae9ea990c5ebc07655007ff4e623fa7c697f326c0ce12c3e libgit2-0.26.3.tar.gz
-6817cae286f663c6ceb890576c491d89ffe0cf57b96a7340b8b4ef2c021a35d7672ce76b6e875ed72155e960455d29973329782850bd9cca543c6f74a9a6f93f build-both-static-dynamic.patch"
+6817cae286f663c6ceb890576c491d89ffe0cf57b96a7340b8b4ef2c021a35d7672ce76b6e875ed72155e960455d29973329782850bd9cca543c6f74a9a6f93f build-both-static-dynamic.patch
+02c167b55daa5045486662f628c53e5affd636043f95551b1349de8c2e643c98432c8b7bb73e8301c1f1c51248a7bf16e920ed759a349c0701e6f185f763078e libressl-2.7.patch"
diff --git a/main/libgit2/libressl-2.7.patch b/main/libgit2/libressl-2.7.patch
new file mode 100644
index 0000000000..5c96b335a5
--- /dev/null
+++ b/main/libgit2/libressl-2.7.patch
@@ -0,0 +1,13 @@
+diff --git a/src/openssl_stream.h b/src/openssl_stream.h
+index f5e59da..b769437 100644
+--- a/src/openssl_stream.h
++++ b/src/openssl_stream.h
+@@ -27,7 +27,7 @@ extern int git_openssl_stream_new(git_stream **out, const char *host, const char
+
+
+
+-# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
++# if OPENSSL_VERSION_NUMBER < 0x10100000L
+
+ GIT_INLINE(BIO_METHOD*) BIO_meth_new(int type, const char *name)
+ {