aboutsummaryrefslogtreecommitdiffstats
path: root/main/libgit2
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-12-01 05:30:10 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-16 01:55:38 +0100
commitaa5d8f79338f88702decde530357b3fa50e22427 (patch)
tree27d429de1efff410b4d0cf7265751d7036004ccd /main/libgit2
parentc394e557d4cf409af13fc92dbc22b68d309d218f (diff)
downloadaports-aa5d8f79338f88702decde530357b3fa50e22427.tar.bz2
aports-aa5d8f79338f88702decde530357b3fa50e22427.tar.xz
main/libgit2: upgrade to 0.26.0 and modernize abuild
Diffstat (limited to 'main/libgit2')
-rw-r--r--main/libgit2/APKBUILD29
-rw-r--r--main/libgit2/build-both-static-dynamic.patch8
-rw-r--r--main/libgit2/libressl.patch12
-rw-r--r--main/libgit2/pkgconfig-do-not-quote-Libs.patch26
4 files changed, 17 insertions, 58 deletions
diff --git a/main/libgit2/APKBUILD b/main/libgit2/APKBUILD
index 38904871f6..4ef57fbb18 100644
--- a/main/libgit2/APKBUILD
+++ b/main/libgit2/APKBUILD
@@ -3,21 +3,18 @@
# Contributor: Pierre-Gilas MILLON <pgmillon@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libgit2
-pkgver=0.25.1
-pkgrel=4
+pkgver=0.26.0
+pkgrel=0
pkgdesc="A linkable library for Git"
url="https://libgit2.github.com/"
arch="all"
license="GPL-2.0"
-depends=""
depends_dev="curl-dev libssh2-dev"
makedepends="$depends_dev python2 cmake zlib-dev libressl-dev"
subpackages="$pkgname-dev"
provides="$pkgname-libs" # for backward compatibility with v3.4
replaces="$pkgname-libs" # for backward compatibility with v3.4
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
- libressl.patch
- pkgconfig-do-not-quote-Libs.patch
build-both-static-dynamic.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -36,19 +33,19 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- || return 1
- make || return 1
+ -DCMAKE_C_FLAGS="$CFLAGS"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- make DESTDIR="$pkgdir" \
- -C "$builddir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-sha512sums="e20c7f4a55d2183522fd851a002a9e861e2f3b550c09aea7fbcd9eae5c39410596e4cd4f852d81256bb0bee6365eab0f9b854b66fd459afe2b7d149f68c1c103 libgit2-0.25.1.tar.gz
-3674957d09207b11d268ba9fcb442a081b8efe318d0e8501b7afa0ae2397efc9aff8572b1ffd9f2286c46a06a647fbe943c2cc7e8f97d1a0288e74010846d439 libressl.patch
-635fb1f64c4b676044e7800cc8796646f90d7e6447ab77f97b3491f746351e826ffa9c03b6bef7ffabad9c50a5c5e983ea9e53b4972211813f54d81b703b4aed pkgconfig-do-not-quote-Libs.patch
-39534d10f38f394446f93df810233464807fca3b0e903ee40067971ecbe1d78102bbe04283435032f757f970e6846ecf279eb727ab137c01e84427bd16913ee6 build-both-static-dynamic.patch"
+sha512sums="b6e51f2216c7c23f352572b780ea1325a25a517396709f036bb573295c2bd02aa505ba616846ac7e07863e99e640e7d47fefc5727478a257b283da99060ee47c libgit2-0.26.0.tar.gz
+6817cae286f663c6ceb890576c491d89ffe0cf57b96a7340b8b4ef2c021a35d7672ce76b6e875ed72155e960455d29973329782850bd9cca543c6f74a9a6f93f build-both-static-dynamic.patch"
diff --git a/main/libgit2/build-both-static-dynamic.patch b/main/libgit2/build-both-static-dynamic.patch
index eeb179a1e0..9c85dc56b4 100644
--- a/main/libgit2/build-both-static-dynamic.patch
+++ b/main/libgit2/build-both-static-dynamic.patch
@@ -13,7 +13,7 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
OPTION( THREADSAFE "Build libgit2 as threadsafe" ON )
OPTION( BUILD_CLAR "Build Tests using the Clar suite" ON )
OPTION( BUILD_EXAMPLES "Build library usage example apps" OFF )
-@@ -44,6 +43,8 @@
+@@ -45,6 +44,8 @@
OPTION( CURL "Use curl for HTTP if available" ON)
OPTION( DEBUG_POOL "Enable debug pool allocator" OFF )
@@ -22,7 +22,7 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
IF(DEBUG_POOL)
ADD_DEFINITIONS(-DGIT_DEBUG_POOL)
ENDIF()
-@@ -602,7 +603,8 @@
+@@ -609,7 +610,8 @@
ENDIF()
# Compile and link libgit2
@@ -32,7 +32,7 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
TARGET_LINK_LIBRARIES(git2 ${SECURITY_DIRS})
TARGET_LINK_LIBRARIES(git2 ${COREFOUNDATION_DIRS})
TARGET_LINK_LIBRARIES(git2 ${SSL_LIBRARIES})
-@@ -611,6 +613,9 @@
+@@ -618,6 +620,9 @@
TARGET_LINK_LIBRARIES(git2 ${ICONV_LIBRARIES})
TARGET_OS_LIBRARIES(git2)
@@ -42,7 +42,7 @@ This is very hack-ish, it makes option BUILD_SHARED_LIBS unusable.
# Workaround for Cmake bug #0011240 (see http://public.kitware.com/Bug/view.php?id=11240)
# Win64+MSVC+static libs = linker error
IF(MSVC AND GIT_ARCH_64 AND NOT BUILD_SHARED_LIBS)
-@@ -639,7 +644,7 @@
+@@ -646,7 +651,7 @@
ENDIF ()
# Install
diff --git a/main/libgit2/libressl.patch b/main/libgit2/libressl.patch
deleted file mode 100644
index 967cdc4982..0000000000
--- a/main/libgit2/libressl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru src.orig/libgit2-0.25.1/src/openssl_stream.h src/libgit2-0.25.1/src/openssl_stream.h
---- libgit2-0.25.1/src/copenssl_stream.h.orig
-+++ libgit2-0.25.1/src/openssl_stream.h
-@@ -27,7 +27,7 @@
-
-
-
--# if OPENSSL_VERSION_NUMBER < 0x10100000L
-+# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-
- GIT_INLINE(BIO_METHOD*) BIO_meth_new(int type, const char *name)
- {
diff --git a/main/libgit2/pkgconfig-do-not-quote-Libs.patch b/main/libgit2/pkgconfig-do-not-quote-Libs.patch
deleted file mode 100644
index 86133612ed..0000000000
--- a/main/libgit2/pkgconfig-do-not-quote-Libs.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 452ba68cde25423d13ebb36f0a54559f07aa53a2 Mon Sep 17 00:00:00 2001
-From: Igor Gnatenko <ignatenko@redhat.com>
-Date: Tue, 7 Feb 2017 16:37:47 +0100
-Subject: [PATCH] pkgconfig: do not quote Libs
-
-It doesn't make sense at all.
----
- libgit2.pc.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libgit2.pc.in b/libgit2.pc.in
-index 329a560a7..880266a30 100644
---- a/libgit2.pc.in
-+++ b/libgit2.pc.in
-@@ -6,7 +6,7 @@ Name: libgit2
- Description: The git library, take 2
- Version: @LIBGIT2_VERSION_STRING@
-
--Libs: -L"${libdir}" -lgit2
-+Libs: -L${libdir} -lgit2
- Libs.private: @LIBGIT2_PC_LIBS@
- Requires.private: @LIBGIT2_PC_REQUIRES@
-
---
-2.11.0
-