aboutsummaryrefslogtreecommitdiffstats
path: root/main/libmad
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-26 22:05:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 12:47:06 +0000
commit870acc25ca1d36706c9928eb5ce6051f3194aeb9 (patch)
treefbf065cb6f6e9089cd12d7a922b00799320ebd7d /main/libmad
parent5edd31ea60f017248e2aaa5b41ccfa574e7ae2b8 (diff)
downloadaports-870acc25ca1d36706c9928eb5ce6051f3194aeb9.tar.bz2
aports-870acc25ca1d36706c9928eb5ce6051f3194aeb9.tar.xz
main/libmad: fix build on mips*
libmad uses the now unsupported inline asm constraint in the code so switch mips* to generic high-precision version. Keep pkgrel intact since other architectures are unaffected and no previously built mips* apks exist.
Diffstat (limited to 'main/libmad')
-rw-r--r--main/libmad/APKBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/main/libmad/APKBUILD b/main/libmad/APKBUILD
index d552568938..1f4248801f 100644
--- a/main/libmad/APKBUILD
+++ b/main/libmad/APKBUILD
@@ -30,10 +30,12 @@ prepare() {
build() {
cd "$builddir"
+ case "$CARCH" in mips*) _enable_fpm_64bit="--enable-fpm=64bit";; esac
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ $_enable_fpm_64bit \
--enable-accuracy
make -j1