aboutsummaryrefslogtreecommitdiffstats
path: root/main/libmateweather
diff options
context:
space:
mode:
authorAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 14:25:42 +0000
committerAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 16:19:35 +0000
commit78724693f7cec0d412f4326271db15f56526c928 (patch)
tree09868b2cd04209c1930479bec925a9f5b34cb3cd /main/libmateweather
parent32935991ae31b9426ddfaa031ad59d234989e042 (diff)
downloadaports-78724693f7cec0d412f4326271db15f56526c928.tar.bz2
aports-78724693f7cec0d412f4326271db15f56526c928.tar.xz
main/libmateweather: move from testing
Diffstat (limited to 'main/libmateweather')
-rw-r--r--main/libmateweather/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/libmateweather/APKBUILD b/main/libmateweather/APKBUILD
new file mode 100644
index 0000000000..6b58169f86
--- /dev/null
+++ b/main/libmateweather/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=libmateweather
+pkgver=1.9.90
+pkgrel=0
+pkgdesc="A library to access weather information from online services for numerous locations"
+url="https://github.com/mate-desktop/libmateweather"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev libsoup-dev libtool intltool gtk+-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --with-zoneinfo-dir \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+ find "$pkgdir" -name \*.la -delete
+}
+
+md5sums="a73d3970f49884bcfdb933089984c466 libmateweather-1.9.90.tar.xz"
+sha256sums="0b35a00a24e78cec67f096da0fa54625a84129159c263533aa8d61bcb154378d libmateweather-1.9.90.tar.xz"
+sha512sums="c27ef43a2fb1c73ed57480f25c4ed4d518b37697913de4bf8003fdc0400a07b632d342bfaa0397bc85d2b112c01ffa908467d9be0c77949b864f685730b76c91 libmateweather-1.9.90.tar.xz"