aboutsummaryrefslogtreecommitdiffstats
path: root/main/libmatroska
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-20 22:37:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:11:36 +0000
commit014ff094cd56514438dcfe226cbab99156f350d5 (patch)
treef857168a6283b7a61d31328637ae8df793ed6614 /main/libmatroska
parentd687717ebe75d5537d0014da69a20235ca197e82 (diff)
downloadaports-014ff094cd56514438dcfe226cbab99156f350d5.tar.bz2
aports-014ff094cd56514438dcfe226cbab99156f350d5.tar.xz
main/libmatroska: upgrade to 1.4.9
Switch to cmake is required by upstream
Diffstat (limited to 'main/libmatroska')
-rw-r--r--main/libmatroska/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/main/libmatroska/APKBUILD b/main/libmatroska/APKBUILD
index 323786446b..5032380579 100644
--- a/main/libmatroska/APKBUILD
+++ b/main/libmatroska/APKBUILD
@@ -1,25 +1,31 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libmatroska
-pkgver=1.4.8
-pkgrel=1
+pkgver=1.4.9
+pkgrel=0
pkgdesc="a C++ library to parse Matroska files"
url="https://www.matroska.org/"
arch="all"
options="!check" # Tests don't build; 'make check' target disabled by upstream
license="LGPL-2.1+"
-makedepends="libebml-dev>=1.3.3"
+makedepends="cmake libebml-dev>=1.3.6"
subpackages="$pkgname-dev"
-source="http://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
+source="https://dl.matroska.org/downloads/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
make
}
@@ -28,4 +34,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="af3b8bfae891be77896b6afa2da3325ebba73a957cd43a4e6086b68e1237bb37b2e6d5eb57322c05ede0ad0c03464087b77fbdf06101314f09411648e1073cee libmatroska-1.4.8.tar.xz"
+sha512sums="281224b66ce7ef39daf0f186cda1144250e190b914e64f4f2524e8bf0170a3d18dbc50f204d4ca8d7eaffe183a61f96c92ba6ec4325bacb068272d62cdbcef33 libmatroska-1.4.9.tar.xz"