aboutsummaryrefslogtreecommitdiffstats
path: root/main/libmicrohttpd
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-25 17:43:10 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-26 07:13:16 +0000
commitf158480f13f18f05df912f5191211d5d542a06cb (patch)
treefa098a278a32e8bece22cab2170448903e76668d /main/libmicrohttpd
parentb374bb28729e0a6c783aae6ec5e2ebb40c7aaa3f (diff)
downloadaports-f158480f13f18f05df912f5191211d5d542a06cb.tar.bz2
aports-f158480f13f18f05df912f5191211d5d542a06cb.tar.xz
main/libmicrohttpd: update to 0.9.63
Diffstat (limited to 'main/libmicrohttpd')
-rw-r--r--main/libmicrohttpd/APKBUILD13
-rw-r--r--main/libmicrohttpd/disable-test_options.patch25
2 files changed, 33 insertions, 5 deletions
diff --git a/main/libmicrohttpd/APKBUILD b/main/libmicrohttpd/APKBUILD
index 6e5b0bdf5a..a84652b4e9 100644
--- a/main/libmicrohttpd/APKBUILD
+++ b/main/libmicrohttpd/APKBUILD
@@ -1,16 +1,18 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmicrohttpd
-pkgver=0.9.62
+pkgver=0.9.63
pkgrel=0
pkgdesc="A small C library that is supposed to make it easy to run an HTTP server as part of another application."
url="https://www.gnu.org/software/libmicrohttpd/"
arch="all"
-license="GPL"
-makedepends="curl-dev libgcrypt-dev gnutls-dev"
+license="LGPL-2.1-or-later"
+makedepends="curl-dev libgcrypt-dev gnutls-dev automake autoconf libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="ftp://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz"
+source="http://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz
+ disable-test_options.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -41,4 +43,5 @@ package() {
"$pkgdir"/usr/include/platform.h
}
-sha512sums="337f29dbc5e8c30132c17aad6142f21ea1c794b0ce80a3fc4c5e1e14b3dabb300aa410bf9413ef9e65d5d486fcfedbc3716725763a1fa28b4687c9f2aa3158e4 libmicrohttpd-0.9.62.tar.gz"
+sha512sums="cb99e7af84fb6d7c0fd3894a9dc0fbff14959b35347506bd3211a65bbfad36455007b9e67493e97c9d8394834408df10eeabdc7758573e6aae0ba6f5f87afe17 libmicrohttpd-0.9.63.tar.gz
+7bbd8d2571f2bf7d06c956cc5e5decf154139baa1a716b43501b822b18a396b2cc97efd72118bc3dd5e20439611eb333730c436fe9f0a1ce2cf928066520e619 disable-test_options.patch"
diff --git a/main/libmicrohttpd/disable-test_options.patch b/main/libmicrohttpd/disable-test_options.patch
new file mode 100644
index 0000000000..da4718396b
--- /dev/null
+++ b/main/libmicrohttpd/disable-test_options.patch
@@ -0,0 +1,25 @@
+Works on live machine, fails on CI
+
+diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
+index 1f4ffca..5464a0b 100644
+--- a/src/microhttpd/Makefile.am
++++ b/src/microhttpd/Makefile.am
+@@ -156,8 +156,7 @@ check_PROGRAMS = \
+ test_str_token \
+ test_http_reasons \
+ test_start_stop \
+- test_daemon \
+- test_options
++ test_daemon
+
+ if HAVE_POSIX_THREADS
+ if ENABLE_UPGRADE
+@@ -316,7 +315,3 @@ test_http_reasons_SOURCES = \
+ test_http_reasons.c \
+ reason_phrase.c mhd_str.c mhd_str.h
+
+-test_options_SOURCES = \
+- test_options.c
+-test_options_LDADD = \
+- $(top_builddir)/src/microhttpd/libmicrohttpd.la
+