aboutsummaryrefslogtreecommitdiffstats
path: root/main/libtirpc
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-24 03:53:26 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-24 11:53:56 +0100
commit5bb40348daf07fc32acd629a6b1f33c199dfb515 (patch)
tree2121a1bc58bd465a8b2b9692bdbcb5daea9caac8 /main/libtirpc
parentdaf9f81f61cc571954a4c1a637f4d9f1cf82fe94 (diff)
downloadaports-5bb40348daf07fc32acd629a6b1f33c199dfb515.tar.bz2
aports-5bb40348daf07fc32acd629a6b1f33c199dfb515.tar.xz
main/libtirpc: upgrade to 1.2.5
Diffstat (limited to 'main/libtirpc')
-rw-r--r--main/libtirpc/APKBUILD19
-rw-r--r--main/libtirpc/musl.patch11
2 files changed, 5 insertions, 25 deletions
diff --git a/main/libtirpc/APKBUILD b/main/libtirpc/APKBUILD
index e8304f5c8d..04743208d8 100644
--- a/main/libtirpc/APKBUILD
+++ b/main/libtirpc/APKBUILD
@@ -1,30 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtirpc
-pkgver=1.1.4
+pkgver=1.2.5
pkgrel=0
pkgdesc="Transport Independent RPC library (SunRPC replacement)"
url="https://sourceforge.net/projects/libtirpc"
arch="all"
license="BSD-3-Clause"
options="!check"
-depends=
depends_dev="krb5-dev bsd-compat-headers"
makedepends="$depends_dev autoconf automake libtool linux-headers"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
-source="https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2
- musl.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-dbg"
+source="https://sourceforge.net/projects/libtirpc/files/libtirpc/$pkgver/libtirpc-$pkgver.tar.bz2"
prepare() {
- cd "$builddir"
default_prepare
- aclocal
- autoreconf
+ autoreconf -fi
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,9 +27,7 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="392f391f9fc1bd68d81dc44e4058831a64b32790b5c8c37338b0ab416fad2ae4d16389e632596734dba09780347918cc65c6f134e0c1afd09e81ec250785ed23 libtirpc-1.1.4.tar.bz2
-8e52246ae478ae9e4689426627e17d9c58d701f4fd21a40ffe3cf17c4ceaa4ab2e8e91d2fa3ba0d0c7adc52ae4b986fcda113ec86e370ede83903bb641de520c musl.patch"
+sha512sums="d31cd4e22301abe1baddd7e8f45aaaf056a40799e961646691d071084fed50563b5eecdd9b78062fe378be8db7a6d4b87597e21cb81ac925e447148684a2b002 libtirpc-1.2.5.tar.bz2"
diff --git a/main/libtirpc/musl.patch b/main/libtirpc/musl.patch
deleted file mode 100644
index 5a4fb04f50..0000000000
--- a/main/libtirpc/musl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tirpc/rpc/types.h.orig 2018-03-17 10:23:10.022055255 +0100
-+++ ./tirpc/rpc/types.h 2018-03-17 10:23:30.877751656 +0100
-@@ -66,7 +66,7 @@
- #define mem_free(ptr, bsize) free(ptr)
-
-
--#if defined __APPLE_CC__ || defined __FreeBSD__
-+#if defined __APPLE_CC__ || defined __FreeBSD__ || !defined(__GLIBC__)
- # define __u_char_defined
- # define __daddr_t_defined
- #endif