aboutsummaryrefslogtreecommitdiffstats
path: root/main/libva-glx/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-24 14:45:31 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-07 18:38:45 +0000
commit86a99eeccf091f60aa7d0cf5dab12326822bdef3 (patch)
tree8854d0575bc01001c274d9eceeb76c7dd06d74b3 /main/libva-glx/APKBUILD
parent343339a511f4b71829b7a72cf887f64247fac39e (diff)
downloadaports-86a99eeccf091f60aa7d0cf5dab12326822bdef3.tar.bz2
aports-86a99eeccf091f60aa7d0cf5dab12326822bdef3.tar.xz
main/libva-glx: update to 2.4.1
Diffstat (limited to 'main/libva-glx/APKBUILD')
-rw-r--r--main/libva-glx/APKBUILD49
1 files changed, 20 insertions, 29 deletions
diff --git a/main/libva-glx/APKBUILD b/main/libva-glx/APKBUILD
index cf1ec7ef57..097032dea4 100644
--- a/main/libva-glx/APKBUILD
+++ b/main/libva-glx/APKBUILD
@@ -3,19 +3,17 @@
# this package is to resolve the circular dependency libva -> mesa -> libva
pkgname=libva-glx
-pkgver=2.2.0
+pkgver=2.4.1
pkgrel=0
pkgdesc="Video Acceleration (VA) API for Linux with MESA support"
url="https://freedesktop.org/wiki/Software/vaapi"
arch="all"
options="!check" # No test suite.
license="MIT"
-depends=""
-depends_dev="libva-dev mesa-dev"
-makedepends="$depends_dev autoconf automake libtool"
-install=""
+depends_dev="libva-dev mesa-dev libxfixes-dev"
+makedepends="$depends_dev meson wayland-dev"
subpackages="$pkgname-dev"
-source="https://github.com/01org/libva/releases/download/$pkgver/libva-$pkgver.tar.bz2"
+source="libva-$pkgver.tar.gz::https://github.com/intel/libva/archive/${pkgver}.tar.gz"
builddir="$srcdir"/libva-$pkgver
prepare() {
@@ -26,38 +24,31 @@ prepare() {
die "libva and libva-glx needs to be same version"
fi
fi )
-
cd "$builddir"
default_prepare
- # we need to regen the configure script which will unconditionally
- # depend on wayland scanner otherwise
- libtoolize --force && aclocal -I m4 && autoconf \
- && automake --add-missing
}
build() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --enable-x11 \
- --enable-glx \
- --disable-drm \
- --disable-wayland \
- --disable-static \
- --enable-shared
- make
+ meson builddir \
+ --prefix=/usr\
+ -Dwith_glx=yes \
+ -Dwith_wayland=yes
+ ninja -C builddir
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install
- find "$pkgdir" \( -type f -o -type l \) \! -name '*glx*' -delete
+ DESTDIR="$pkgdir" ninja -C builddir install
+
+ mkdir -p ${builddir}/temp/usr/lib/pkgconfig ${builddir}/temp/usr/include/va
+
+ mv ${pkgdir}/usr/lib/libva-glx* ${builddir}/temp/usr/lib
+ mv ${pkgdir}/usr/include/va/va_glx.h ${builddir}/temp/usr/include/va
+ mv ${pkgdir}/usr/include/va/va_backend_glx.h ${builddir}/temp/usr/include/va
+ mv ${pkgdir}/usr/lib/pkgconfig/libva-glx.pc ${builddir}/temp/usr/lib/pkgconfig
+ rm -rf ${pkgdir}/*
+ mv ${builddir}/temp/* ${pkgdir}
}
-sha512sums="21e79b32cd846f3786635f470763c2046b302fdd3574eb70ac67c40140168ec76a33e2bbcdd2408859b38b9774fa15c89429e128ef381092505b4f39b1b1331a libva-2.2.0.tar.bz2"
+sha512sums="6ad2255aebcc62b3a7f67f03585f8046742a8a9b33c0feaee7dc0a713ab2117b13f154c3574f98aa2fb07fd2336635df3ea2675ec4d1c25ae3b2834aeab8692e libva-2.4.1.tar.gz"