aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvorbis
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-30 23:39:59 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-30 23:43:45 +0200
commitab7ce27c0401bc86196e90b903e62aedebe053f0 (patch)
tree2a00d8707917879bbcd574b31d85ed744e125088 /main/libvorbis
parente1ed2bcfba10348320bfd6a920b4b3aa0571e873 (diff)
downloadaports-ab7ce27c0401bc86196e90b903e62aedebe053f0.tar.bz2
aports-ab7ce27c0401bc86196e90b903e62aedebe053f0.tar.xz
main/libvorbis: modernize abuild and fix project's url
Diffstat (limited to 'main/libvorbis')
-rw-r--r--main/libvorbis/APKBUILD31
1 files changed, 11 insertions, 20 deletions
diff --git a/main/libvorbis/APKBUILD b/main/libvorbis/APKBUILD
index 86ad84de04..722f3e2a1b 100644
--- a/main/libvorbis/APKBUILD
+++ b/main/libvorbis/APKBUILD
@@ -3,39 +3,30 @@ pkgname=libvorbis
pkgver=1.3.5
pkgrel=1
pkgdesc="Vorbis codec library"
-url="http://www.xiph.org/ogg/vorbis/"
+url="https://xiph.org/vorbis/"
arch="all"
license="custom"
subpackages="$pkgname-dev $pkgname-doc"
-depends=
-depends_dev="libogg-dev"
-makedepends="$depends_dev"
-#source="http://people.xiph.org/~giles/2008/$pkgname-$pkgver.tar.gz"
-source="http://downloads.xiph.org/releases/vorbis/libvorbis-$pkgver.tar.gz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
-}
+makedepends="libogg-dev"
+source="http://downloads.xiph.org/releases/vorbis/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
+
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="7220e089f3be3412a2317d6fde9e3944 libvorbis-1.3.5.tar.gz"
-sha256sums="6efbcecdd3e5dfbf090341b485da9d176eb250d893e3eb378c428a2db38301ce libvorbis-1.3.5.tar.gz"
+
sha512sums="6c729a227143abc744a779ec4d4ce9932cd1234e301b766cb5111c3894b7cd866f0267590c7864afd3841ac0d4ae2eb2386e8d14345b7c41c8ce35e996e3656c libvorbis-1.3.5.tar.gz"