aboutsummaryrefslogtreecommitdiffstats
path: root/main/libvpx/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-11-13 13:51:37 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-11-13 13:53:14 +0200
commita716ed810e0c2d423de2f7efd0074c027aa02ef4 (patch)
treecae82ba5f168c6676b8cc24cfc2586c4abb623e4 /main/libvpx/APKBUILD
parentbb0047baac241425c425d698399e7486026fe1b8 (diff)
downloadaports-a716ed810e0c2d423de2f7efd0074c027aa02ef4.tar.bz2
aports-a716ed810e0c2d423de2f7efd0074c027aa02ef4.tar.xz
main/libvpx: fix armv7 configuration triplet
Diffstat (limited to 'main/libvpx/APKBUILD')
-rw-r--r--main/libvpx/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/main/libvpx/APKBUILD b/main/libvpx/APKBUILD
index 4929524b0e..767b2b21fa 100644
--- a/main/libvpx/APKBUILD
+++ b/main/libvpx/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libvpx
pkgver=1.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for the vp8 codec"
url="https://www.webmproject.org/"
arch="all"
@@ -9,15 +9,15 @@ license="GPL"
depends=""
makedepends="coreutils yasm bash perl"
subpackages="$pkgname-dev $pkgname-utils"
-source="https://storage.googleapis.com/downloads.webmproject.org/releases/webm/$pkgname-$pkgver.tar.bz2"
+source="https://storage.googleapis.com/downloads.webmproject.org/releases/webm/$pkgname-$pkgver.tar.bz2
+ fix-arm-float-abi.patch
+ "
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
# build fix for arm
export CROSS=" "
- #TODO this is a hack to get build working on armv7
- [ "$CARCH" = "armv7" ] && _target="--target=generic-gnu"
bash ./configure \
--enable-pic \
--enable-libs \
@@ -26,8 +26,7 @@ build() {
--enable-vp9 \
--enable-shared \
--disable-install-srcs \
- --enable-postproc \
- $_target
+ --enable-postproc
make
}
@@ -46,4 +45,5 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="1a4b009fe1737715c6563a79848126a5859394a5074b1e9cca9bc2e213df90890c15e708040d5f2c96c7c21e268f51e1352ac6911514bf891a4bf3eea154159d libvpx-1.6.1.tar.bz2"
+sha512sums="1a4b009fe1737715c6563a79848126a5859394a5074b1e9cca9bc2e213df90890c15e708040d5f2c96c7c21e268f51e1352ac6911514bf891a4bf3eea154159d libvpx-1.6.1.tar.bz2
+4eadbc2f4eb68eaff35cf85515aef271d6fd47293a53cba7b7a6e9e0fb71106dfb5ded45b9e9ba83264a91846e4a5fa4db42e39fc3eaff6ac37769e622f90f6c fix-arm-float-abi.patch"