aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxi
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-03 15:00:00 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:51:29 +0000
commit17d55f5bf868df42d950f74c055d86f1e944521e (patch)
treed1b250352fa82f04eee9117bd171e4c8f9a14a47 /main/libxi
parentea49699ac3a4f8828c15e8048f8e241357ee31e4 (diff)
downloadaports-17d55f5bf868df42d950f74c055d86f1e944521e.tar.bz2
aports-17d55f5bf868df42d950f74c055d86f1e944521e.tar.xz
main/fixesproto: modernise, add -doc, mark as having no test suite
Diffstat (limited to 'main/libxi')
-rw-r--r--main/libxi/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/main/libxi/APKBUILD b/main/libxi/APKBUILD
index 3f2c83d016..5d0d56258b 100644
--- a/main/libxi/APKBUILD
+++ b/main/libxi/APKBUILD
@@ -1,24 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxi
pkgver=1.7.9
-pkgrel=0
+pkgrel=1
pkgdesc="X11 Input extension library"
url="http://xorg.freedesktop.org"
arch="all"
license="custom"
+options="!check" # No test suite.
subpackages="$pkgname-dev $pkgname-doc"
depends=
-depends_dev="inputproto libx11-dev libxext-dev libxfixes-dev"
makedepends="
- $depends_dev
+ inputproto
+ libx11-dev
+ libxext-dev
+ libxfixes-dev
pkgconfig
+ util-macros
xextproto
+ xmlto
xproto
"
source="http://www.x.org/releases/individual/lib/libXi-$pkgver.tar.bz2"
builddir="$srcdir"/libXi-$pkgver
-build () {
+build() {
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -27,13 +32,14 @@ build () {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- || return 1
- make || return 1
+ --with-xmlto \
+ --without-fop
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}