aboutsummaryrefslogtreecommitdiffstats
path: root/main/libzdb
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-25 22:15:50 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-07 18:28:52 +0000
commitd65de9b8864c49b84deb2f1b9a3352995d7fe696 (patch)
tree1c39f0ed0fb2e2a3d23ded5b22230cdf0e13d1e9 /main/libzdb
parentf5cf8a771108f1e4fc87a7f60c26567284929abb (diff)
downloadaports-d65de9b8864c49b84deb2f1b9a3352995d7fe696.tar.bz2
aports-d65de9b8864c49b84deb2f1b9a3352995d7fe696.tar.xz
main/libzdb: update to 3.2
Diffstat (limited to 'main/libzdb')
-rw-r--r--main/libzdb/APKBUILD18
-rw-r--r--main/libzdb/missing-assert.patch13
-rw-r--r--main/libzdb/test-makefile.patch31
3 files changed, 24 insertions, 38 deletions
diff --git a/main/libzdb/APKBUILD b/main/libzdb/APKBUILD
index b072b2951e..18ecd0783f 100644
--- a/main/libzdb/APKBUILD
+++ b/main/libzdb/APKBUILD
@@ -2,17 +2,17 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=libzdb
-pkgver=3.1
-pkgrel=2
+pkgver=3.2
+pkgrel=0
pkgdesc="A thread-safe high level multi-database connection pool library"
url="http://www.tildeslash.com/libzdb/"
arch="all"
-license="GPL"
+license="GPL-3.0-only"
depends_dev="flex-dev sqlite-dev mariadb-connector-c-dev postgresql-dev"
makedepends="$depends_dev flex"
subpackages="$pkgname-dev"
source="http://www.tildeslash.com/libzdb/dist/libzdb-$pkgver.tar.gz
- test-makefile.patch"
+ missing-assert.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -27,7 +27,11 @@ build() {
check() {
cd "$builddir"
- make verify
+ # The test is manual and requires user input, we spam the dot char
+ # because it is a valid name for the database required by the test
+ # and dot is also the char for exiting the database once test is
+ # complete
+ yes . | make verify
}
package() {
@@ -35,5 +39,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-sha512sums="7cf24ccf0f0a938955d8b54af2c6eca8a8f700737beafde9e824129f324511e06adbc11a3fdbd6ad6d9b902fdae6f7caab4e5c1c594d2211be314e3a24c697f3 libzdb-3.1.tar.gz
-9e4ec8142ccae4b599f806568436179bd1c5847d32a2ae2979fd74cb035c4b00f9cd8bbc58f18231304ed81db62562c44b49eeb5a54e1822c81cca31e4289676 test-makefile.patch"
+sha512sums="b44ee217c0b221812eb2d1be03edcc8e74a5e3907ac3915defc15fa5faf228dac175bd04591fedf5d706773ab85f2dc98cd14c7a84ade5887f4f644d64739824 libzdb-3.2.tar.gz
+4547386470ac74079c41fcec9fb1e4129283982f0b489a2bd57f49586f25e900004ff5d6e61e796eac9ccd35c29e52aae184ec98802b23ad9f216213159b5db2 missing-assert.patch"
diff --git a/main/libzdb/missing-assert.patch b/main/libzdb/missing-assert.patch
new file mode 100644
index 0000000000..10e279d3b3
--- /dev/null
+++ b/main/libzdb/missing-assert.patch
@@ -0,0 +1,13 @@
+diff --git a/test/zdbpp.cpp b/test/zdbpp.cpp
+index 40d2eee..3fde62a 100644
+--- a/test/zdbpp.cpp
++++ b/test/zdbpp.cpp
+@@ -1,6 +1,7 @@
+ #include <iostream>
+ #include <string>
+ #include <map>
++#include <assert.h>
+
+ #include "zdbpp.h"
+ using namespace zdb;
+
diff --git a/main/libzdb/test-makefile.patch b/main/libzdb/test-makefile.patch
deleted file mode 100644
index 4d810d69e2..0000000000
--- a/main/libzdb/test-makefile.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-./pool is interactive, so we must feed it DB connection on stdin.
---- a/test/Makefile.am
-+++ b/test/Makefile.am
-@@ -17,4 +17,4 @@
- test: unit pool select
-
- verify:
-- @/bin/sh ./exception && ./unit && ./pool
-+ @/bin/sh ./exception && ./unit && echo 'sqlite:///tmp/sqlite.db?synchronous=off&heap_limit=2000' | ./pool
---- a/test/Makefile.in
-+++ b/test/Makefile.in
-@@ -619,7 +619,7 @@
- test: unit pool select
-
- verify:
-- @/bin/sh ./exception && ./unit && ./pool
-+ @/bin/sh ./exception && ./unit && echo 'sqlite:///tmp/sqlite.db?synchronous=off&heap_limit=2000' | ./pool
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
---- a/test/Makefile
-+++ b/test/Makefile
-@@ -619,7 +619,7 @@
- test: unit pool select
-
- verify:
-- @/bin/sh ./exception && ./unit && ./pool
-+ @/bin/sh ./exception && ./unit && echo 'sqlite:///tmp/sqlite.db?synchronous=off&heap_limit=2000' | ./pool
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.