aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-02-14 21:15:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-02-15 10:50:44 +0000
commit7de429a6d74cc001623b2f126c6a94af445de2f1 (patch)
tree63de5ac54d15424dc68b22f74b5361666c24d0cf /main/linux-grsec
parentb67ed761eb2e099578c4f984c981ef966b3a18ea (diff)
downloadaports-7de429a6d74cc001623b2f126c6a94af445de2f1.tar.bz2
aports-7de429a6d74cc001623b2f126c6a94af445de2f1.tar.xz
main/linux-grsec: fix loading of zfs modules
the zfs modules are built from sources with the RAP plugin so they should should work just fine.
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/zfs-fix.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 948117c7ab..9b05311d49 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -7,7 +7,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs"
@@ -19,6 +19,7 @@ source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
http://dev.alpinelinux.org/~ncopa/grsec/grsecurity-3.1-4.9.9-201702122044.patch
pax-cmpxchg8b_emu.patch
+ zfs-fix.patch
config-grsec.x86
config-grsec.x86_64
config-grsec.armhf
@@ -201,6 +202,7 @@ sha512sums="bf67ff812cc3cb7e5059e82cc5db0d9a7c5637f7ed9a42e4730c715bf7047c81ed3a
a7a2d44b83b00b20f1424d12af0f42e1c576d3053feacd13491ef185661fb1c789b9265c500b62f5ede39f57b72f358820000fa6c852a5f035e566ee1dfcd5d9 patch-4.9.9.xz
ba7396e1f69e89335cecd47db52c8855c993c13c9b2b9e805a0742fa1bd3a9092ae0459adb06f07a5233ff208ad9b6ced0fa68cacfe1a99b498c43ad953d5388 grsecurity-3.1-4.9.9-201702122044.patch
05b59599d7744415cca29f7c820343bb247df5ab52d461f663a7674c246e028ed4fc9509b7f21bfb18be1a72cfdc37d5a673f30067c343f2c1ac40cbcd5b88a9 pax-cmpxchg8b_emu.patch
+5a0a78e6de11eb8180d96830b9faa9ac560586f7beb663c8196a16ac6232b5008b9181b3c9b94e2b13a444acba4b6e80a3408d34606432f92eb4d169c3953d5d zfs-fix.patch
de080dc463af81f60e142c4ed52f294f523759710ac6d5dc227e6dc26c4bd53c61d94480a9af3e377a658360c16cab86060afd68694545cbe501d8bb0915ef36 config-grsec.x86
de5ad64e86bda944c1e6e7ae0eb77463fb0165e89c8ec23d9af12fddb79c0b566e8f3079b7bed1de8b27cef9bf1539f479e7114070772c078cb4288c45df1ff6 config-grsec.x86_64
274116a39ef092524ad85cef2e88d0e7555dfd3c6e5c15c1ec22c28776c509a6040a5221b066e96c6d18807e518ae98f03c9c1059c73b60e8d45f2a9482bd77b config-grsec.armhf
diff --git a/main/linux-grsec/zfs-fix.patch b/main/linux-grsec/zfs-fix.patch
new file mode 100644
index 0000000000..997add4dbc
--- /dev/null
+++ b/main/linux-grsec/zfs-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/kernel/module.c b/kernel/module.c
+index f9d983b..aadd2ed 100644
+--- a/kernel/module.c
++++ b/kernel/module.c
+@@ -3036,7 +3036,7 @@ static int check_modinfo(struct module *mod, struct load_info *info, int flags)
+ int err;
+
+ #if defined(CONFIG_PAX_KERNEXEC_PLUGIN_METHOD_OR) || defined(CONFIG_PAX_RAP)
+- if (!license || !license_is_gpl_compatible(license)) {
++ if (!license || (!license_is_gpl_compatible(license) && strcmp(license, "CDDL") != 0)) {
+ pr_err("%s: module is not compatible with the KERNEXEC 'or' method and RAP\n", mod->name);
+ return -ENOEXEC;
+ }