aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-headers
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-07 15:13:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-07 15:16:50 +0000
commitf3c86ef81958f9bdbcda0f34559ff77d64f87b95 (patch)
treeafc3a75fc73f184e22acfe9f875ed5f12c27d0e0 /main/linux-headers
parent03e2aa8f1d437cb97a6f08d4ea8a276ded031c93 (diff)
downloadaports-f3c86ef81958f9bdbcda0f34559ff77d64f87b95.tar.bz2
aports-f3c86ef81958f9bdbcda0f34559ff77d64f87b95.tar.xz
main/linux-headers: fix redefinition of sigcontext from libc on aarch64
Problem was introduced upstream with https://github.com/torvalds/linux/commit/43d4da2c45b2f5d62f8a79ff7c6f95089bb24656
Diffstat (limited to 'main/linux-headers')
-rw-r--r--main/linux-headers/APKBUILD6
-rw-r--r--main/linux-headers/fix-aarch64-asm-ptrace.patch27
2 files changed, 31 insertions, 2 deletions
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index 543b934428..398679e473 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -2,7 +2,7 @@
pkgname=linux-headers
pkgver=4.17.6
_kernver=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="Linux system headers"
url="http://kernel.org"
arch="all"
@@ -13,6 +13,7 @@ source="https://kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
https://kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
revert-broken-uapi.patch
0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch
+ fix-aarch64-asm-ptrace.patch
"
prepare() {
@@ -57,4 +58,5 @@ package() {
sha512sums="4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db linux-4.17.tar.xz
4b791d94db704cbbe3dbf6b340735fe7999957741f116ca14060ced836aece1d4b51d0c3f376af1564e7379fbb9c9132a8e4d021fc74599f3ab037237d718651 patch-4.17.6.xz
32597f2672d1ec365a936d15041a7cf219ef9353241d4a5c378244cf2fc155610443a19bbcd391c86099a0b08486c45e042ec7c90b0d04fe675c3ad0ffc36b53 revert-broken-uapi.patch
-302283b1b5f560c850e24aad73febcf7f906ed62b4cad2d826bf140ffe59191631f3cd4ac29525c349cdfe61aba6a47886a0d76f1c6a4a16b744d59b94ea5df8 0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch"
+302283b1b5f560c850e24aad73febcf7f906ed62b4cad2d826bf140ffe59191631f3cd4ac29525c349cdfe61aba6a47886a0d76f1c6a4a16b744d59b94ea5df8 0003-remove-inclusion-of-sysinfo.h-in-kernel.h.patch
+8b510dae7656ec9decee611773c21c0b379ccc8a776e4e0135cc28764fec611e9fc8bdee6a457d8df21f1399d3141659a20b70a0cb5efbb3e3b7aa7d5a5573ce fix-aarch64-asm-ptrace.patch"
diff --git a/main/linux-headers/fix-aarch64-asm-ptrace.patch b/main/linux-headers/fix-aarch64-asm-ptrace.patch
new file mode 100644
index 0000000000..516ec209fd
--- /dev/null
+++ b/main/linux-headers/fix-aarch64-asm-ptrace.patch
@@ -0,0 +1,27 @@
+Work around redefinition of sigcontext in libc headers
+
+Introduced with:
+https://github.com/torvalds/linux/commit/43d4da2c45b2f5d62f8a79ff7c6f95089bb24656
+
+diff --git a/arch/arm64/include/uapi/asm/ptrace.h b/arch/arm64/include/uapi/asm/ptrace.h
+index 98c4ce5..c44efed 100644
+--- a/arch/arm64/include/uapi/asm/ptrace.h
++++ b/arch/arm64/include/uapi/asm/ptrace.h
+@@ -23,8 +23,6 @@
+ #include <linux/types.h>
+
+ #include <asm/hwcap.h>
+-#include <asm/sigcontext.h>
+-
+
+ /*
+ * PSR bits
+@@ -64,8 +62,6 @@
+
+ #ifndef __ASSEMBLY__
+
+-#include <linux/prctl.h>
+-
+ /*
+ * User structures for general purpose, floating point and debug registers.
+ */