aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-rpi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-10-25 13:38:37 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-10-25 13:38:37 +0000
commit79e0d9b0bd7c6fe4e272cb829f014d6a774ba6b2 (patch)
treecfee5c60a56fbccb12e7ab77d427986212a1b657 /main/linux-rpi
parentedd55acf6b209416b1ae84d83947617351c7d73b (diff)
downloadaports-79e0d9b0bd7c6fe4e272cb829f014d6a774ba6b2.tar.bz2
aports-79e0d9b0bd7c6fe4e272cb829f014d6a774ba6b2.tar.xz
main/linux-rpi: upgrade to 4.1.11
Diffstat (limited to 'main/linux-rpi')
-rw-r--r--main/linux-rpi/0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch40
-rw-r--r--main/linux-rpi/APKBUILD42
-rw-r--r--main/linux-rpi/config-rpi.armhf6
-rw-r--r--main/linux-rpi/config-rpi2.armhf6
-rw-r--r--main/linux-rpi/rpi-cirrus-4.1.x-20151025.patch (renamed from main/linux-rpi/rpi-cirrus-4.1.x-20151006.patch)16
5 files changed, 36 insertions, 74 deletions
diff --git a/main/linux-rpi/0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch b/main/linux-rpi/0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
deleted file mode 100644
index fdd23d5cc5..0000000000
--- a/main/linux-rpi/0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 83fccfc3940c4a2db90fd7e7079f5b465cd8c6af Mon Sep 17 00:00:00 2001
-From: Eric Dumazet <edumazet@google.com>
-Date: Thu, 13 Aug 2015 15:44:51 -0700
-Subject: [PATCH] inet: fix potential deadlock in reqsk_queue_unlink()
-
-When replacing del_timer() with del_timer_sync(), I introduced
-a deadlock condition :
-
-reqsk_queue_unlink() is called from inet_csk_reqsk_queue_drop()
-
-inet_csk_reqsk_queue_drop() can be called from many contexts,
-one being the timer handler itself (reqsk_timer_handler()).
-
-In this case, del_timer_sync() loops forever.
-
-Simple fix is to test if timer is pending.
-
-Fixes: 2235f2ac75fd ("inet: fix races with reqsk timers")
-Signed-off-by: Eric Dumazet <edumazet@google.com>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- net/ipv4/inet_connection_sock.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/net/ipv4/inet_connection_sock.c b/net/ipv4/inet_connection_sock.c
-index 05e3145..1349571 100644
---- a/net/ipv4/inet_connection_sock.c
-+++ b/net/ipv4/inet_connection_sock.c
-@@ -593,7 +593,7 @@ static bool reqsk_queue_unlink(struct request_sock_queue *queue,
- }
-
- spin_unlock(&queue->syn_wait_lock);
-- if (del_timer_sync(&req->rsk_timer))
-+ if (timer_pending(&req->rsk_timer) && del_timer_sync(&req->rsk_timer))
- reqsk_put(req);
- return found;
- }
---
-2.6.0
-
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 580253b1cc..a8ee3559f7 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -2,12 +2,12 @@
_mainflavor=rpi
pkgname=linux-$_mainflavor
-pkgver=4.1.10
+pkgver=4.1.11
case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=${pkgver};;
esac
-pkgrel=1
+pkgrel=0
pkgdesc="Linux kernel with Raspberry Pi patches"
url=https://github.com/raspberrypi/linux
depends="mkinitfs linux-firmware"
@@ -16,9 +16,8 @@ options="!strip"
install=
source="http://ftp.kernel.org/pub/linux/kernel/v4.x/linux-$_kernver.tar.xz
http://ftp.kernel.org/pub/linux/kernel/v4.x/patch-$pkgver.xz
- http://dev.alpinelinux.org/~tteras/linux-4.1.y-rpi-20151006.patch
- rpi-cirrus-4.1.x-20151006.patch
- 0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
+ http://dev.alpinelinux.org/~tteras/linux-4.1.y-rpi-20151025.patch
+ rpi-cirrus-4.1.x-20151025.patch
config-rpi.armhf
config-rpi2.armhf
@@ -197,26 +196,23 @@ dev() {
}
md5sums="fe9dc0f6729f36400ea81aa41d614c37 linux-4.1.tar.xz
-599cb082ef44d8fb76ad8fd49d1b50fc patch-4.1.10.xz
-161b4c74b6071d5bfb51ac5175cbab04 linux-4.1.y-rpi-20151006.patch
-0d7a68e45940e4ea33ee78e98dd2220a rpi-cirrus-4.1.x-20151006.patch
-ffa7fdc282af20f2b48b95b2687b7452 0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
-ed39ac7b625c6fbe29c8e503f2657d21 config-rpi.armhf
-2247472fa947c79450406ae0de2ec910 config-rpi2.armhf
+46a403b167416719901565190298e680 patch-4.1.11.xz
+28edef874a4c2c9789605a30fda0a5b6 linux-4.1.y-rpi-20151025.patch
+e3429d7772cb3bf73ff4c51aabb2a5cf rpi-cirrus-4.1.x-20151025.patch
+e2e2333bbbf3e420b770c54c63e2c235 config-rpi.armhf
+f22be75c5c4f65fc06ae606eaf79b736 config-rpi2.armhf
e587cae1dca2f5992555d9bcf53deecf markdt"
sha256sums="caf51f085aac1e1cea4d00dbbf3093ead07b551fc07b31b2a989c05f8ea72d9f linux-4.1.tar.xz
-929e210fe6dbd5dd26812c146630be14e979aae6c960a2feb39544babb8e73cb patch-4.1.10.xz
-777909c66d87d0f18796cc4fe426a30ae89ce20380c62ae00976bbffd28374ec linux-4.1.y-rpi-20151006.patch
-ce55c9d56b862de3d1ac1eb39f0bbac2a4c0659dc5b0e298094a9c42556acf11 rpi-cirrus-4.1.x-20151006.patch
-c56583010561ca7d7b5e5aa3eed67c939f67deb2d22af7155e475c10baa4d7a5 0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
-838218b4df392befad9566cdd761b6475c6e473c9bc47ee107df09dc4f07169c config-rpi.armhf
-87bda7066763cf6ef16de7f3863300c8b6d89caa76d06e58e3b0a0ac2be2e4b5 config-rpi2.armhf
+f98156dd7ceac2849de16b38cdb7a530cd3c74833ab613e0822b7bc4583cccb1 patch-4.1.11.xz
+471375facefd099de01eae67215e74e31db1e113157c0e43a21e7df27e64ca75 linux-4.1.y-rpi-20151025.patch
+b1b5b8bf16e2eacec19931279984f2bc96851da6e9786d4c9422caa1ac7af2fe rpi-cirrus-4.1.x-20151025.patch
+17a112f574b066bc210aa4d8f7090f053596b4cb7dc02c6cb9926a994d7304fd config-rpi.armhf
+f480a726e92d871d1c9f7ef68abcc9f61f06f8027fc60a6668219909b6b657a2 config-rpi2.armhf
0f6681fc5c3590e1dbe13a2bde796403bd1529cf0fe19720899eaa0db79bcb49 markdt"
sha512sums="168ef84a4e67619f9f53f3574e438542a5747f9b43443363cb83597fcdac9f40d201625c66e375a23226745eaada9176eb006ca023613cec089349e91751f3c0 linux-4.1.tar.xz
-3b5cb5c8f494958c39a06a1b416e3e5a075a3c76c44f8bf1ae5a14deec9861407100c2ef59b0720e8fc0729b5c8422b4d819ff59f1f7ec4eed20c5ba8a95d6d5 patch-4.1.10.xz
-fa9022592a4ea1ce7cc2cadac672ba120471be6453f40acef8b8ac6ad50fa36701bd4ebe335507dff848d335c2b7f4e74ec0313ea039edfa7a35900c31639097 linux-4.1.y-rpi-20151006.patch
-c8e3b1a4a18a2b1864831e7b9de26e2c0d0bf7956632741152b150a7d749f1b0ab955f04f8db0c533c81f34b9580476007e2b5d9c5f01688441a14870675617f rpi-cirrus-4.1.x-20151006.patch
-32ae58cf74d5e02cb09445be35772dad0a517949bd1836f8dbc90b871de67901b61dba5eccdc2a795a9f7e5c06831335504a738205eb49768f7424cf30ddd8ae 0001-inet-fix-potential-deadlock-in-reqsk_queue_unlink.patch
-ddab2fed512e73b6ae501f0ab795f58c4b9a05afc297cff1a3b710048458db7c13c727af096b8a0fa24306c8dd1eba80a4e6c1c71cc5219fa8aa21b843f2d9f8 config-rpi.armhf
-b07701ce1069e2a29d609dd67f6f578fa3d3f10c0fbdf01ebe7b97680fcfb4c793948e655471e577f9eb73326891d9cac3a8ed9110b29c92b3b41584caa867f3 config-rpi2.armhf
+ebd9f9ed7a4921795a0aee43440f6c73bf2ba058a690eb96031b978e61e390ef4d3b64e818a7cce7fe520adb20b93e4b7dd485b50d32c2dcf3012db3477a852c patch-4.1.11.xz
+26752f27d0f2ca977e3d3a2132c150147b2263ce85ab5dfed67864b1adc2827a039ceaac14642d9c680a0572b7721d0f10d25786c2584fbc853817f487ef5ac3 linux-4.1.y-rpi-20151025.patch
+3e4717c21def19d7c9714b1d9d07f8dbf8fd27e986cbd978eda50c586cc21d1399b50db4255589d09abb6fe5b532c3959481098f229c4ea4526a044fc1da17b0 rpi-cirrus-4.1.x-20151025.patch
+3999e7defbc14681288febc420aa7f370c8fdbc047ad36b3c8d5bbee80a969af3c3f8b909a0d719d16cedf697a6a546cceceab39468ecb88554f73e422b7e076 config-rpi.armhf
+0f501be130951b2bfee26a3f056aaede9fac2b6becb6ffd28cd53f91571a70a69fe86d09589b3c61ecb04f40a6399ba6334aa8780601d709c95bfa74476a3e32 config-rpi2.armhf
a4ecd1f48db64f9d6a189250d1937d7f2cd3a049a3d24cc527d04d05db06137722f1ba44bcd6033794781c3f2cfe2fbe065410a16de4bfdf4b1cd95d89322a77 markdt"
diff --git a/main/linux-rpi/config-rpi.armhf b/main/linux-rpi/config-rpi.armhf
index b20110cbc3..c40ee50462 100644
--- a/main/linux-rpi/config-rpi.armhf
+++ b/main/linux-rpi/config-rpi.armhf
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.1.10 Kernel Configuration
+# Linux/arm 4.1.11 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1229,7 +1229,8 @@ CONFIG_ARM_CCI400_PMU=y
# CONFIG_ARM_CCN is not set
# CONFIG_BRCMSTB_GISB_ARB is not set
# CONFIG_VEXPRESS_CONFIG is not set
-CONFIG_CONNECTOR=m
+CONFIG_CONNECTOR=y
+CONFIG_PROC_EVENTS=y
# CONFIG_MTD is not set
CONFIG_DTC=y
CONFIG_OF=y
@@ -2877,6 +2878,7 @@ CONFIG_LCD_CLASS_DEVICE=m
CONFIG_BACKLIGHT_CLASS_DEVICE=y
# CONFIG_BACKLIGHT_GENERIC is not set
# CONFIG_BACKLIGHT_PWM is not set
+CONFIG_BACKLIGHT_RPI=m
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_LM3630A is not set
diff --git a/main/linux-rpi/config-rpi2.armhf b/main/linux-rpi/config-rpi2.armhf
index 1f3556d681..0121fc3e6f 100644
--- a/main/linux-rpi/config-rpi2.armhf
+++ b/main/linux-rpi/config-rpi2.armhf
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm 4.1.10 Kernel Configuration
+# Linux/arm 4.1.11 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -1280,7 +1280,8 @@ CONFIG_ARM_CCI400_PMU=y
# CONFIG_ARM_CCN is not set
# CONFIG_BRCMSTB_GISB_ARB is not set
# CONFIG_VEXPRESS_CONFIG is not set
-CONFIG_CONNECTOR=m
+CONFIG_CONNECTOR=y
+CONFIG_PROC_EVENTS=y
# CONFIG_MTD is not set
CONFIG_DTC=y
CONFIG_OF=y
@@ -2928,6 +2929,7 @@ CONFIG_LCD_CLASS_DEVICE=m
CONFIG_BACKLIGHT_CLASS_DEVICE=y
# CONFIG_BACKLIGHT_GENERIC is not set
# CONFIG_BACKLIGHT_PWM is not set
+CONFIG_BACKLIGHT_RPI=m
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_LM3630A is not set
diff --git a/main/linux-rpi/rpi-cirrus-4.1.x-20151006.patch b/main/linux-rpi/rpi-cirrus-4.1.x-20151025.patch
index c9c5b8dce3..f29b381efc 100644
--- a/main/linux-rpi/rpi-cirrus-4.1.x-20151006.patch
+++ b/main/linux-rpi/rpi-cirrus-4.1.x-20151025.patch
@@ -67,13 +67,13 @@ index 7665aa9..ec7979e 100644
+ wlf,dmic-ref = <0 0 1 0>;
};
diff --git a/arch/arm/boot/dts/overlays/Makefile b/arch/arm/boot/dts/overlays/Makefile
-index 192bda7..6046f13 100644
+index f4b2817..756c08d 100644
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
-@@ -38,6 +38,7 @@ dtb-$(RPI_DT_OVERLAYS) += pps-gpio-overlay.dtb
- dtb-$(RPI_DT_OVERLAYS) += pwm-overlay.dtb
+@@ -41,6 +41,7 @@ dtb-$(RPI_DT_OVERLAYS) += pwm-overlay.dtb
dtb-$(RPI_DT_OVERLAYS) += pwm-2chan-overlay.dtb
dtb-$(RPI_DT_OVERLAYS) += raspidac3-overlay.dtb
+ dtb-$(RPI_DT_OVERLAYS) += rpi-backlight-overlay.dtb
+dtb-$(RPI_DT_OVERLAYS) += rpi-cirrus-wm5102-overlay.dtb
dtb-$(RPI_DT_OVERLAYS) += rpi-dac-overlay.dtb
dtb-$(RPI_DT_OVERLAYS) += rpi-display-overlay.dtb
@@ -226,7 +226,7 @@ index 0000000..85b3d15
+ };
+};
diff --git a/arch/arm/configs/bcm2709_defconfig b/arch/arm/configs/bcm2709_defconfig
-index 630da1b..b4e2906 100644
+index fb402e8..74ebdc7 100644
--- a/arch/arm/configs/bcm2709_defconfig
+++ b/arch/arm/configs/bcm2709_defconfig
@@ -639,6 +639,9 @@ CONFIG_STMPE_SPI=y
@@ -239,7 +239,7 @@ index 630da1b..b4e2906 100644
CONFIG_MEDIA_SUPPORT=m
CONFIG_MEDIA_CAMERA_SUPPORT=y
CONFIG_MEDIA_ANALOG_TV_SUPPORT=y
-@@ -843,6 +846,7 @@ CONFIG_SND_BCM2708_SOC_RPI_DAC=m
+@@ -844,6 +847,7 @@ CONFIG_SND_BCM2708_SOC_RPI_DAC=m
CONFIG_SND_BCM2708_SOC_RPI_PROTO=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
@@ -248,7 +248,7 @@ index 630da1b..b4e2906 100644
CONFIG_SND_SOC_WM8804_I2C=m
CONFIG_SND_SIMPLE_CARD=m
diff --git a/arch/arm/configs/bcmrpi_defconfig b/arch/arm/configs/bcmrpi_defconfig
-index df4cebc..bfe13a3 100644
+index eb81555e..6528468 100644
--- a/arch/arm/configs/bcmrpi_defconfig
+++ b/arch/arm/configs/bcmrpi_defconfig
@@ -632,6 +632,9 @@ CONFIG_STMPE_SPI=y
@@ -261,7 +261,7 @@ index df4cebc..bfe13a3 100644
CONFIG_MEDIA_SUPPORT=m
CONFIG_MEDIA_CAMERA_SUPPORT=y
CONFIG_MEDIA_ANALOG_TV_SUPPORT=y
-@@ -836,6 +839,7 @@ CONFIG_SND_BCM2708_SOC_RPI_DAC=m
+@@ -837,6 +840,7 @@ CONFIG_SND_BCM2708_SOC_RPI_DAC=m
CONFIG_SND_BCM2708_SOC_RPI_PROTO=m
CONFIG_SND_BCM2708_SOC_IQAUDIO_DAC=m
CONFIG_SND_BCM2708_SOC_RASPIDAC3=m
@@ -2043,4 +2043,6 @@ index b6c12dc..e767365 100644
ret = snd_soc_dapm_add_path(&card->dapm, source, w, NULL, NULL);
if (ret)
+--
+2.6.1