aboutsummaryrefslogtreecommitdiffstats
path: root/main/linux-vanilla
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-08-22 10:54:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-22 10:59:57 +0000
commit8983dfcfa8687e7d6fa3a34cdd2c7b0ff8883581 (patch)
tree68dbfd160b39cceacc535b7dadf2a5138bfa6e35 /main/linux-vanilla
parente2f1359347f5ef0ab9869b3e387a90ac190b4a1c (diff)
downloadaports-8983dfcfa8687e7d6fa3a34cdd2c7b0ff8883581.tar.bz2
aports-8983dfcfa8687e7d6fa3a34cdd2c7b0ff8883581.tar.xz
main/linux-vanilla: avoid pulling in all firmware during build
We need to have linux-firmware in makedepends because the runtime dependency is addedin package() function, and we need to make sure that build order resolver gets that it needs to build linux-firmware before the linux-vanilla. Make it possible for build servers and lxc containers etc to manually install linux-firmware-none to avoid pull in all linux firmware dependencies during build.
Diffstat (limited to 'main/linux-vanilla')
-rw-r--r--main/linux-vanilla/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/linux-vanilla/APKBUILD b/main/linux-vanilla/APKBUILD
index 1e1e4d6ed1..e4911db822 100644
--- a/main/linux-vanilla/APKBUILD
+++ b/main/linux-vanilla/APKBUILD
@@ -12,7 +12,7 @@ pkgdesc="Linux vanilla kernel"
url="http://kernel.org"
depends="mkinitfs"
_depends_dev="perl gmp-dev elfutils-dev bash flex bison"
-makedepends="$_depends_dev sed installkernel bc linux-headers linux-firmware openssl-dev"
+makedepends="$_depends_dev sed installkernel bc linux-headers linux-firmware-any openssl-dev"
options="!strip"
_config=${config:-config-vanilla.${CARCH}}
install=