aboutsummaryrefslogtreecommitdiffstats
path: root/main/lttng-ust
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-22 18:39:36 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-23 07:02:05 +0000
commite20640bcf6f34a4b716968209170df9ca96d55bc (patch)
tree94a6f719ec759198446e276e757a7a4d3184d1eb /main/lttng-ust
parent80d689efb800b024f5fffef10109f7199f8c93d9 (diff)
downloadaports-e20640bcf6f34a4b716968209170df9ca96d55bc.tar.bz2
aports-e20640bcf6f34a4b716968209170df9ca96d55bc.tar.xz
main/lttng-ust: upgrade to 2.10.4
Diffstat (limited to 'main/lttng-ust')
-rw-r--r--main/lttng-ust/13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch103
-rw-r--r--main/lttng-ust/APKBUILD13
2 files changed, 4 insertions, 112 deletions
diff --git a/main/lttng-ust/13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch b/main/lttng-ust/13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch
deleted file mode 100644
index 6d770e30f8..0000000000
--- a/main/lttng-ust/13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch
+++ /dev/null
@@ -1,103 +0,0 @@
-From 13d2c5baf1565ba1daa2b96f5e4a297571c505b4 Mon Sep 17 00:00:00 2001
-From: Michael Jeanson <mjeanson@efficios.com>
-Date: Wed, 20 Mar 2019 11:07:35 -0400
-Subject: [PATCH] compat: work around broken _SC_NPROCESSORS_CONF on MUSL libc
-
-On MUSL libc the _SC_NPROCESSORS_CONF sysconf will report the number of
-CPUs allocated to the task based on the affinity mask instead of the
-total number of CPUs configured on the system.
-
-Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
-Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
----
- libringbuffer/smp.c | 66 +++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 66 insertions(+)
-
-diff --git a/libringbuffer/smp.c b/libringbuffer/smp.c
-index 9e7114be..656a75da 100644
---- a/libringbuffer/smp.c
-+++ b/libringbuffer/smp.c
-@@ -2,6 +2,7 @@
- * libringbuffer/smp.c
- *
- * Copyright (C) 2011-2012 Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
-+ * Copyright (C) 2019 Michael Jeanson <mjeanson@efficios.com>
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
-@@ -26,6 +27,7 @@
-
- int __num_possible_cpus;
-
-+#if (defined(__GLIBC__) || defined( __UCLIBC__))
- void _get_num_possible_cpus(void)
- {
- int result;
-@@ -43,3 +45,67 @@ void _get_num_possible_cpus(void)
- return;
- __num_possible_cpus = result;
- }
-+
-+#else
-+
-+/*
-+ * The MUSL libc implementation of the _SC_NPROCESSORS_CONF sysconf does not
-+ * return the number of configured CPUs in the system but relies on the cpu
-+ * affinity mask of the current task.
-+ *
-+ * So instead we use a strategy similar to GLIBC's, counting the cpu
-+ * directories in "/sys/devices/system/cpu" and fallback on the value from
-+ * sysconf if it fails.
-+ */
-+
-+#include <dirent.h>
-+#include <limits.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <sys/types.h>
-+
-+#define __max(a,b) ((a)>(b)?(a):(b))
-+
-+void _get_num_possible_cpus(void)
-+{
-+ int result, count = 0;
-+ DIR *cpudir;
-+ struct dirent *entry;
-+
-+ cpudir = opendir("/sys/devices/system/cpu");
-+ if (cpudir == NULL)
-+ goto end;
-+
-+ /*
-+ * Count the number of directories named "cpu" followed by and
-+ * integer. This is the same strategy as glibc uses.
-+ */
-+ while ((entry = readdir(cpudir))) {
-+ if (entry->d_type == DT_DIR &&
-+ strncmp(entry->d_name, "cpu", 3) == 0) {
-+
-+ char *endptr;
-+ unsigned long cpu_num;
-+
-+ cpu_num = strtoul(entry->d_name + 3, &endptr, 10);
-+ if ((cpu_num < ULONG_MAX) && (endptr != entry->d_name + 3)
-+ && (*endptr == '\0')) {
-+ count++;
-+ }
-+ }
-+ }
-+
-+end:
-+ /*
-+ * Get the sysconf value as a fallback. Keep the highest number.
-+ */
-+ result = __max(sysconf(_SC_NPROCESSORS_CONF), count);
-+
-+ /*
-+ * If both methods failed, don't store the value.
-+ */
-+ if (result < 1)
-+ return;
-+ __num_possible_cpus = result;
-+}
-+#endif
diff --git a/main/lttng-ust/APKBUILD b/main/lttng-ust/APKBUILD
index 2d513d0d91..2f999dd40c 100644
--- a/main/lttng-ust/APKBUILD
+++ b/main/lttng-ust/APKBUILD
@@ -1,19 +1,15 @@
# Contributor: Michael Jeanson <mjeanson@efficios.com>
# Maintainer: Michael Jeanson <mjeanson@efficios.com>
pkgname=lttng-ust
-pkgver=2.10.3
-pkgrel=1
+pkgver=2.10.4
+pkgrel=0
pkgdesc="LTTng 2.0 Userspace Tracer"
url="https://lttng.org"
arch="all"
license="LGPL-2.1-or-later"
makedepends="userspace-rcu-dev>0.10 util-linux-dev linux-headers bash"
-install=""
subpackages="$pkgname-doc $pkgname-dev"
-source="https://lttng.org/files/$pkgname/$pkgname-$pkgver.tar.bz2
- 13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://lttng.org/files/lttng-ust/lttng-ust-$pkgver.tar.bz2"
build() {
cd "$builddir"
@@ -35,5 +31,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="6f646de3a12dbad096014f3069c3e702fb54b824b78770e777f6f877c76ffc48fae863b10c432bff1bba29caafdb5b76cb2b9cb88eb7340d5121300d2c0ff65d lttng-ust-2.10.3.tar.bz2
-c91ea6ad2085f13de0508d0f238582bcd12f0460cb00f482a85fa5cfe8ec4ce675c084af27387f63cec9cc83430ca80fb995b289f44b515888efb796a97dc320 13d2c5baf1565ba1daa2b96f5e4a297571c505b4.patch"
+sha512sums="e10ab464abe1a305a2e51c37aa7111db3861a09ab8e451ba98f612d53f125c1e7a9225c6663b99bbab24913795f2d351c7dbafc0a52d1468d52899b8b966fc1b lttng-ust-2.10.4.tar.bz2"