aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-12 15:30:01 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-12 17:22:12 +0100
commitefb191b1fd982cc15886898fdab4ff2b2fd09d2b (patch)
treecb060c702fc63fbf55ca7ebaf8f0e234fc87495f /main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch
parentaebf2df2a6a56187dfcd958b4bae825eaae4c958 (diff)
downloadaports-efb191b1fd982cc15886898fdab4ff2b2fd09d2b.tar.bz2
aports-efb191b1fd982cc15886898fdab4ff2b2fd09d2b.tar.xz
main/lua-ldap: fix anonymous bind, add more metadata into patches
Diffstat (limited to 'main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch')
-rw-r--r--main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch22
1 files changed, 18 insertions, 4 deletions
diff --git a/main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch b/main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch
index a5a3853551..9ec951bd28 100644
--- a/main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch
+++ b/main/lua-ldap/script-to-run-test.lua-against-a-dummy-slapd.patch
@@ -1,8 +1,18 @@
+From d69b83f1464a6326c426f0228bb98c626c7f64bd Mon Sep 17 00:00:00 2001
From: Dan Callaghan <dcallagh@redhat.com>
Date: Mon, 30 Jun 2014 11:27:56 +1000
Subject: [PATCH] Add script to run test.lua against a dummy slapd
Ported from https://src.fedoraproject.org/cgit/rpms/lua-ldap.git/tree/0002-script-to-run-test.lua-against-a-dummy-slapd.patch
+Upstream-Issue: https://github.com/bdellegrazie/lualdap/pull/2
+---
+ Makefile | 3 ++
+ tests/run-tests.sh | 83 ++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 86 insertions(+)
+ create mode 100755 tests/run-tests.sh
+
+diff --git a/Makefile b/Makefile
+index 72ee348..9bfa542 100644
--- a/Makefile
+++ b/Makefile
@@ -26,3 +26,6 @@ install: src/$(LIBNAME)
@@ -14,10 +24,10 @@ Ported from https://src.fedoraproject.org/cgit/rpms/lua-ldap.git/tree/0002-scrip
+ LUA_CPATH="src/?.so.$V" sh tests/run-tests.sh
diff --git a/tests/run-tests.sh b/tests/run-tests.sh
new file mode 100755
-index 0000000..f3cafd0
+index 0000000..33949c1
--- /dev/null
+++ b/tests/run-tests.sh
-@@ -0,0 +1,80 @@
+@@ -0,0 +1,83 @@
+#!/bin/sh
+set -ex
+
@@ -96,5 +106,9 @@ index 0000000..f3cafd0
+slapd -F "$d/slapd-config" -h ldap://localhost:3899/
+trap 'kill -TERM $(cat "$d/slapd.pid")' EXIT
+
-+${LUA:-lua} tests/test.lua localhost:3899 \
-+ dc=example,dc=invalid uid=ldapuser,dc=example,dc=invalid "$password"
++${LUA:-lua} tests/test.lua \
++ localhost:3899 \
++ dc=example,dc=invalid \
++ uid=ldapuser,dc=example,dc=invalid \
++ "$password"
+