aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-ossl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-31 20:32:22 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-10-31 20:32:53 +0100
commitf83531035a907320be216a51691f65b6136d03c8 (patch)
treeae3c2c56606d4f4e5def57c77a6c4a8bb190d709 /main/lua-ossl
parentc8d463d461d40570036b403a6ab57661e60bcec5 (diff)
downloadaports-f83531035a907320be216a51691f65b6136d03c8.tar.bz2
aports-f83531035a907320be216a51691f65b6136d03c8.tar.xz
main/lua-ossl: run regression tests
Diffstat (limited to 'main/lua-ossl')
-rw-r--r--main/lua-ossl/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/main/lua-ossl/APKBUILD b/main/lua-ossl/APKBUILD
index aa930c5b78..e732f521be 100644
--- a/main/lua-ossl/APKBUILD
+++ b/main/lua-ossl/APKBUILD
@@ -30,6 +30,24 @@ build() {
done
}
+check() {
+ local lver; for lver in $_luaversions; do
+ msg "Checking on lua$lver..."
+
+ # Lua sources in src/ are in non-standard layout, so we can't
+ # use them directly.
+ make -C "$builddir" DESTDIR="$builddir/.test$lver" install$lver
+
+ cd "$builddir"/regress
+ local file; for file in $(find . -type f -perm +111); do
+ echo "$file:" >&2
+ LUA_CPATH="../.test$lver/usr/lib/lua/$lver/?.so;;" \
+ LUA_PATH="../.test$lver/usr/share/lua/$lver/?.lua;;" \
+ lua$lver $file
+ done
+ done
+}
+
package() {
mkdir -p "$pkgdir"
}