aboutsummaryrefslogtreecommitdiffstats
path: root/main/lua-sql-mysql
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-05 08:02:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-05 08:26:16 +0000
commitfa2422284685c88f06b20fd5a089ae27a0f543ab (patch)
tree4c89ed293ce0f54e31ccc3630f32bf824d44fb84 /main/lua-sql-mysql
parent8d61a971f145e0f6e70e71494ebec4b4cea56ab7 (diff)
downloadaports-fa2422284685c88f06b20fd5a089ae27a0f543ab.tar.bz2
aports-fa2422284685c88f06b20fd5a089ae27a0f543ab.tar.xz
main/lua-sql: merge lua-sql drivers
we build all the different sql drivers for all the different lua versions from a single APKBUILD
Diffstat (limited to 'main/lua-sql-mysql')
-rw-r--r--main/lua-sql-mysql/APKBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/main/lua-sql-mysql/APKBUILD b/main/lua-sql-mysql/APKBUILD
deleted file mode 100644
index 1b5f3a5723..0000000000
--- a/main/lua-sql-mysql/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=lua-sql-mysql
-_name=luasql-mysql
-pkgver=2.3.0
-pkgrel=0
-pkgdesc="MySQL driver for LuaSQL (luasql-mysql)"
-url="http://www.keplerproject.org/luasql/"
-arch="all"
-license="MIT"
-depends="lua"
-makedepends="lua-dev mysql-dev"
-install=
-subpackages=
-source="saveas-https://github.com/keplerproject/luasql/archive/v$pkgver.tar.gz/luasql-$pkgver.tar.gz"
-replaces=luasql-mysql
-
-build() {
- cd "$srcdir"/luasql-$pkgver
-
- # The config has DRIVER_INCS but it seems like its not respected
- # so we just fix the .c file
- sed -i -e 's:^\#include "mysql.h":\#include <mysql/mysql.h>:' \
- src/ls_mysql.c || return 1
-
- make CFLAGS="-fPIC $CFLAGS" T=mysql DRIVER_LIBS="-lmysqlclient" || return 1
-}
-
-package() {
- cd "$srcdir"/luasql-$pkgver
- local _install_cmod=$(pkg-config --variable INSTALL_CMOD lua)
- install -D src/mysql.so "$pkgdir"/$_install_cmod/luasql/mysql.so
-}
-
-md5sums="af9f0f3a2313a1fcf88c40700092048d luasql-2.3.0.tar.gz"