aboutsummaryrefslogtreecommitdiffstats
path: root/main/luasql-postgres/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:17:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-10 08:17:30 +0000
commit08a789230fb36d32a10b92ecbf12d8ec55c5e4a6 (patch)
tree9d72052c573a1a75fca7f29f176c91bd8511ea55 /main/luasql-postgres/APKBUILD
parent67d02df99a5f5f77e23ee1b10e8c0ecb5e01528e (diff)
downloadaports-08a789230fb36d32a10b92ecbf12d8ec55c5e4a6.tar.bz2
aports-08a789230fb36d32a10b92ecbf12d8ec55c5e4a6.tar.xz
main/luasql-postgres: simplify build. fix pkgdesc
remove the config.new and set the needed vairalbes from cmdline
Diffstat (limited to 'main/luasql-postgres/APKBUILD')
-rw-r--r--main/luasql-postgres/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/main/luasql-postgres/APKBUILD b/main/luasql-postgres/APKBUILD
index 36756ca657..7c36717f02 100644
--- a/main/luasql-postgres/APKBUILD
+++ b/main/luasql-postgres/APKBUILD
@@ -2,26 +2,20 @@
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=luasql-postgres
pkgver=2.1.1
-pkgrel=0
-pkgdesc="LuaSQL is a simple interface from Lua to a DBMS"
+pkgrel=1
+pkgdesc="PostgreSQL driver for LuaSQL"
url="http://www.keplerproject.org/luasql/"
license="MIT"
depends="lua"
makedepends="lua-dev postgresql-dev"
install=
subpackages=
-source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz
- config.new
- "
+source="http://luaforge.net/frs/download.php/2686/luasql-$pkgver.tar.gz"
build() {
cd "$srcdir/luasql-$pkgver"
- cp "$srcdir/config.new" config
-
- make || return 1
- mkdir -p "$pkgdir"/usr/lib/lua/5.1/luasql
- cp src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql
+ make CFLAGS="$CFLAGS" T=postgres DRIVER_LIBS="-lpq" || return 1
+ install -D src/postgres.so "$pkgdir"/usr/lib/lua/5.1/luasql/postgres.so
}
-md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz
-6ee28fa90394da6a7e38cf507d56ba80 config.new"
+md5sums="63bdd57de4b9d1be336ba112d8cb69eb luasql-2.1.1.tar.gz"